FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 12-01-2007, 04:19 PM
"Paul Smith"
 
Default Missing Dependency while installing TexLive

Dear All,

I am trying to install TexLive on F8, but I am getting the following problem:

Finished Dependency Resolution
Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt

Any ideas?

Thanks in advance,

Paul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 05:37 PM
"Michael Schwendt"
 
Default Missing Dependency while installing TexLive

On 01/12/2007, Paul Smith <phhs80@gmail.com> wrote:
> Dear All,
>
> I am trying to install TexLive on F8, but I am getting the following problem:
>
> Finished Dependency Resolution
> Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt
>
> Any ideas?

It's a standard package in the F8 Everything repo. Do you have that
repository set to enabled=1?

There is a new version, but it's not in the updates-testing repo yet:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26235

Show what "yum repolist" prints.
Show what "yum list poppler" prints.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 05:48 PM
"Paul Smith"
 
Default Missing Dependency while installing TexLive

On Dec 1, 2007 6:37 PM, Michael Schwendt <mschwendt@gmail.com> wrote:
> > I am trying to install TexLive on F8, but I am getting the following problem:
> >
> > Finished Dependency Resolution
> > Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt
> >
> > Any ideas?
>
> It's a standard package in the F8 Everything repo. Do you have that
> repository set to enabled=1?
>
> There is a new version, but it's not in the updates-testing repo yet:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=26235
>
> Show what "yum repolist" prints.
> Show what "yum list poppler" prints.

Thanks, Michael:

# yum repolist
repo id repo name status
fedora Fedora 8 - i386 enabled
texlive TeXLive 2007 for Fedora Core 8 - i386 enabled
updates Fedora 8 - i386 - Updates enabled
#
# yum list poppler
Installed Packages
poppler.i386 0.6-2.fc8 installed
Available Packages
poppler.i386 0.6.2-2.fc9 texlive
#

Paul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 06:04 PM
Matthew Saltzman
 
Default Missing Dependency while installing TexLive

On Sat, 2007-12-01 at 17:19 +0000, Paul Smith wrote:
> Dear All,
>
> I am trying to install TexLive on F8, but I am getting the following problem:
>
> Finished Dependency Resolution
> Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt
>
> Any ideas?

Upgrade poppler-qt to the rawhide version?

poppler-0.6-2.fc8 is the default version with F8. If TeXLive from
rawhide relies on a later poppler, then you'll need to upgrade (or
remove) anything that depends on the current poppler as well. If things
depend on poppler-qt, then you are standing at the mouth of dependency
hell.

You could also try rebuilding TeXLive from SRPM in F8 and see if it will
build with your current poppler.

>
> Thanks in advance,
>
> Paul
>
>
--
Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 07:49 PM
"Michael Schwendt"
 
Default Missing Dependency while installing TexLive

On 01/12/2007, Paul Smith <phhs80@gmail.com> wrote:

> > > Finished Dependency Resolution
> > > Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt

> # yum repolist
> repo id repo name status
> fedora Fedora 8 - i386 enabled
> texlive TeXLive 2007 for Fedora Core 8 - i386 enabled
> updates Fedora 8 - i386 - Updates enabled
> #
> # yum list poppler
> Installed Packages
> poppler.i386 0.6-2.fc8 installed
> Available Packages
> poppler.i386 0.6.2-2.fc9 texlive
> #

Tell the texlive repo maintainers that their repository is broken (and
incompatible with Fedora 8) if they don't provide an update for
poppler-qt. As it seems they don't replace/obsolete it either, so they
are incompatible with Fedora 9 Development, too.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 07:51 PM
"Paul Smith"
 
Default Missing Dependency while installing TexLive

On Dec 1, 2007 7:04 PM, Matthew Saltzman <mjs@clemson.edu> wrote:
> > I am trying to install TexLive on F8, but I am getting the following problem:
> >
> > Finished Dependency Resolution
> > Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt
> >
> > Any ideas?
>
> Upgrade poppler-qt to the rawhide version?
>
> poppler-0.6-2.fc8 is the default version with F8. If TeXLive from
> rawhide relies on a later poppler, then you'll need to upgrade (or
> remove) anything that depends on the current poppler as well. If things
> depend on poppler-qt, then you are standing at the mouth of dependency
> hell.
>
> You could also try rebuilding TeXLive from SRPM in F8 and see if it will
> build with your current poppler.

Thanks, Matthew. Now, there is no rpm at the repository. The
maintainer is probably replacing the rpms.

Paul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-01-2007, 09:51 PM
"Paul Smith"
 
Default Missing Dependency while installing TexLive

On Dec 1, 2007 8:51 PM, Paul Smith <phhs80@gmail.com> wrote:
> > > I am trying to install TexLive on F8, but I am getting the following problem:
> > >
> > > Finished Dependency Resolution
> > > Error: Missing Dependency: poppler = 0.6-2.fc8 is needed by package poppler-qt
> > >
> > > Any ideas?
> >
> > Upgrade poppler-qt to the rawhide version?
> >
> > poppler-0.6-2.fc8 is the default version with F8. If TeXLive from
> > rawhide relies on a later poppler, then you'll need to upgrade (or
> > remove) anything that depends on the current poppler as well. If things
> > depend on poppler-qt, then you are standing at the mouth of dependency
> > hell.
> >
> > You could also try rebuilding TeXLive from SRPM in F8 and see if it will
> > build with your current poppler.
>
> Thanks, Matthew. Now, there is no rpm at the repository. The
> maintainer is probably replacing the rpms.

The reported problem was meanwhile solved by Jindřich Nový, the
maintainer of the TexLive repository.

Paul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 07:19 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org