Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora SELinux Support (http://www.linux-archive.org/fedora-selinux-support/)
-   -   Long Boot times (http://www.linux-archive.org/fedora-selinux-support/607073-long-boot-times.html)

Arthur Dent 12-06-2011 03:26 PM

Long Boot times
 
Hello all,

I have just upgraded my F14 desktop system to F16 (fresh install
with /home partition maintained from previous Fedora install and some
config files copied across). Now about 50% of boot times are acceptable
(sub 1 minute even with a 5s grub delay) and others take around 2
minutes with a rather alarming black screen for much of that time.

I have no idea if this is caused by SEL, but when i look at dmesg for
the "slow" boots it shows this at the very end:

===============8<================================= ===
[root@localhost ~]# dmesg
[ snip ]
[ 32.248789] e1000e 0000:00:19.0: em1: 10/100 speed: disabling TSO
[ 32.248955] ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
[ 42.354015] em1: no IPv6 routers present
[ 90.858903] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
[ 90.863622] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
[ 90.867429] SELinux: initialized (dev 0:23, type nfs4), uses genfs_contexts
[ 90.868787] SELinux: initialized (dev 0:24, type nfs4), uses genfs_contexts
[ 90.872920] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
[ 90.877188] SELinux: initialized (dev 0:25, type nfs4), uses genfs_contexts
[ 90.878883] mount[998]: mount.nfs: /mnt/NFSmark is busy or already mounted
[ 90.887451] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
[ 90.927896] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
[ 90.932400] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
[ 92.714872] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxfffffff0ixffffff80]xffffffc0x03/3
[ 95.940096] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxffffffe9ixffffff80]xffffffc0x03/3
[root@localhost ~]#

===============8<================================= ===
On the successful boots dmesg ends with the "no IPv6 routers present"
line at around 44s.

Is this even anything to do with SEL?

Even if it isn't, can any of the gurus here suggest how to proceed
towards fixing it?

I originally thought that this was a NFS mounting problem and posted a
thread in the Fedora Users list as can be seen here:
http://lists.fedoraproject.org/pipermail/users/2011-December/409137.html
but I now think that that was a red-herring.

Thanks in advance for any help or suggestions...

Mark


--
selinux mailing list
selinux@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/selinux

Paul Howarth 12-06-2011 03:44 PM

Long Boot times
 
On 12/06/2011 04:26 PM, Arthur Dent wrote:
> Hello all,
>
> I have just upgraded my F14 desktop system to F16 (fresh install
> with /home partition maintained from previous Fedora install and some
> config files copied across). Now about 50% of boot times are acceptable
> (sub 1 minute even with a 5s grub delay) and others take around 2
> minutes with a rather alarming black screen for much of that time.
>
> I have no idea if this is caused by SEL, but when i look at dmesg for
> the "slow" boots it shows this at the very end:
>
> ===============8<================================= ===
> [root@localhost ~]# dmesg
> [ snip ]
> [ 32.248789] e1000e 0000:00:19.0: em1: 10/100 speed: disabling TSO
> [ 32.248955] ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
> [ 42.354015] em1: no IPv6 routers present
> [ 90.858903] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
> [ 90.863622] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
> [ 90.867429] SELinux: initialized (dev 0:23, type nfs4), uses genfs_contexts
> [ 90.868787] SELinux: initialized (dev 0:24, type nfs4), uses genfs_contexts
> [ 90.872920] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
> [ 90.877188] SELinux: initialized (dev 0:25, type nfs4), uses genfs_contexts
> [ 90.878883] mount[998]: mount.nfs: /mnt/NFSmark is busy or already mounted
> [ 90.887451] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
> [ 90.927896] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
> [ 90.932400] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
> [ 92.714872] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxfffffff0ixffffff80]xffffffc0x03/3
> [ 95.940096] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxffffffe9ixffffff80]xffffffc0x03/3
> [root@localhost ~]#
>
> ===============8<================================= ===
> On the successful boots dmesg ends with the "no IPv6 routers present"
> line at around 44s.
>
> Is this even anything to do with SEL?
>
> Even if it isn't, can any of the gurus here suggest how to proceed
> towards fixing it?
>
> I originally thought that this was a NFS mounting problem and posted a
> thread in the Fedora Users list as can be seen here:
> http://lists.fedoraproject.org/pipermail/users/2011-December/409137.html
> but I now think that that was a red-herring.
>
> Thanks in advance for any help or suggestions...

I'd start by removing the "rhgb" and "quiet" options from the boot
command line (edit /boot/grub2/grub.cfg), which will give you a lot more
detail about what's going on and may help you to identify where the
delay is.

Paul.
--
selinux mailing list
selinux@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/selinux

drago01 12-06-2011 06:38 PM

Long Boot times
 
On Tue, Dec 6, 2011 at 5:44 PM, Paul Howarth <paul@city-fan.org> wrote:
> On 12/06/2011 04:26 PM, Arthur Dent wrote:
>> Hello all,
>>
>> I have just upgraded my F14 desktop system to F16 (fresh install
>> with /home partition maintained from previous Fedora install and some
>> config files copied across). Now about 50% of boot times are acceptable
>> (sub 1 minute even with a 5s grub delay) and others take around 2
>> minutes with a rather alarming black screen for much of that time.
>>
>> I have no idea if this is caused by SEL, but when i look at dmesg for
>> the "slow" boots it shows this at the very end:
>>
>> ===============8<================================= ===
>> [root@localhost ~]# dmesg
>> [ * * * snip ]
>> [ * 32.248789] e1000e 0000:00:19.0: em1: 10/100 speed: disabling TSO
>> [ * 32.248955] ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
>> [ * 42.354015] em1: no IPv6 routers present
>> [ * 90.858903] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
>> [ * 90.863622] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
>> [ * 90.867429] SELinux: initialized (dev 0:23, type nfs4), uses genfs_contexts
>> [ * 90.868787] SELinux: initialized (dev 0:24, type nfs4), uses genfs_contexts
>> [ * 90.872920] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
>> [ * 90.877188] SELinux: initialized (dev 0:25, type nfs4), uses genfs_contexts
>> [ * 90.878883] mount[998]: mount.nfs: /mnt/NFSmark is busy or already mounted
>> [ * 90.887451] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
>> [ * 90.927896] SELinux: initialized (dev 0:21, type nfs4), uses genfs_contexts
>> [ * 90.932400] SELinux: initialized (dev 0:22, type nfs4), uses genfs_contexts
>> [ * 92.714872] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxfffffff0ixffffff80]xffffffc0x03/3
>> [ * 95.940096] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channelxffffffe9ixffffff80]xffffffc0x03/3
>> [root@localhost ~]#
>>
>> ===============8<================================= ===
>> On the successful boots dmesg ends with the "no IPv6 routers present"
>> line at around 44s.
>>
>> Is this even anything to do with SEL?
>>
>> Even if it isn't, can any of the gurus here suggest how to proceed
>> towards fixing it?
>>
>> I originally thought that this was a NFS mounting problem and posted a
>> thread in the Fedora Users list as can be seen here:
>> http://lists.fedoraproject.org/pipermail/users/2011-December/409137.html
>> but I now think that that was a red-herring.
>>
>> Thanks in advance for any help or suggestions...
>
> I'd start by removing the "rhgb" and "quiet" options from the boot
> command line (edit /boot/grub2/grub.cfg), which will give you a lot more
> detail about what's going on and may help you to identify where the
> delay is.

Or try

systemd-analyze blame

Which should show some interessting data too ...
--
selinux mailing list
selinux@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/selinux


All times are GMT. The time now is 12:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.