FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora SELinux Support

 
 
LinkBack Thread Tools
 
Old 01-07-2008, 11:10 PM
Gene Heskett
 
Default su user -c problem

On Monday 07 January 2008, Davide Bolcioni wrote:
>On Monday 07 January 2008 05:23:20 pm Gene Heskett wrote:
>> I boot and login at runlevel 3, the everything but X, then run startx by
>> hand. I'm a big dummy maybe, and an old fart, but *I* can run it by using
>> the S99local link exactly the same as it real name, so why doesn't init
>> run it?
>
>I had something similar happen to me some time in the past, say about Fedora
>Core 3, and my init script was hanging (I could see it with pstree) asking
>for user input. I would pepper the script with
>
> echo $$ so far so good >> /tmp/cursed-initscript.log
>
>to see if it is started at all and then hangs or exits somewhere.

Interesting idea Davide
according to pstree, init is indeed still present, top of the list in fact:

init─┬─/usr/bin/sealer
├─acpid
├─artsd
├─atd
├─auditd─┬─audispd───{audispd}
│ └─{auditd}
├─automount───4*[{automount}]
├─avahi-daemon───avahi-daemon
├─console-kit-dae───61*[{console-kit-dae}]
├─crond
├─cupsd
├─2*[dbus-daemon───{dbus-daemon}]
├─dbus-launch
├─dcopserver
├─drift-checker───sleep
├─fetchmail
├─gam_server
├─gconfd-2
├─gpg-agent
├─gpm
├─hald───hald-runner─┬─hald-addon-acpi
│ ├─hald-addon-hid-
│ ├─hald-addon-inpu
│ ├─hald-addon-stor
│ └─hald-addon-usb-
├─hcid
├─2*[heyu]
├─kaccess
├─kded
├─kdeinit─┬─gkrellm───{gkrellm}
│ ├─kio_file
│ ├─klauncher
│ ├─konsole─┬─su───bash───amre cover
│ │ ├─su───bash───pstree
│ │ └─2*[su───bash]
│ ├─konsole───2*[su───bash]
│ ├─konsole─┬─su───bash
│ │ └─su───bash───htop
│ ├─konsole───4*[su───bash───tail]
│ ├─kwin
│ ├─nm-applet
│ ├─puplet
│ └─python
├─kdesktop
├─kgpg
├─kicker
├─kio_uiserver
├─kmail───4*[{kmail}]
├─kmix
├─knotify
├─ksensors
├─ksmserver
├─kwalletmanager
├─login───bash───startx───xi nit─┬─X
│ └─ck-xinit-sessio───startkde─┬─kwrapper
│ └─ssh-agent
├─login───bash
├─4*[mingetty]
├─notification-da
├─ntpd
├─pcscd
├─restorecond
├─rklogd
├─rpc.idmapd
├─rpc.statd
├─rpcbind
├─rsyslogd───{rsyslogd}
├─2*[sendmail]
├─setroubleshootd───2*[{setroubleshootd}]
├─spamd───2*[spamd]
├─sshd
├─start_kdeinit
├─udevd
├─xinetd───amandad───amindexd
└─yum-updatesd

OTOH, I have NDI if that is normal. It is also sitting there in an htop
screen showing "init(3)" which I assume is the runlevel. I'll pepper the
last S## before that and see if its hung, and the top of rc.local, but that
doesn't show anyplace, and if I run it by hand, it does everything and exits
cleanly.

Many thanks for the hint.

>Davide Bolcioni



--
Cheers, Gene
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Artistic ventures highlighted. Rob a museum.

--
fedora-selinux-list mailing list
fedora-selinux-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-selinux-list
 
Old 01-07-2008, 11:31 PM
Gene Heskett
 
Default su user -c problem

On Monday 07 January 2008, Davide Bolcioni wrote:
>On Monday 07 January 2008 05:23:20 pm Gene Heskett wrote:
>> I boot and login at runlevel 3, the everything but X, then run startx by
>> hand. I'm a big dummy maybe, and an old fart, but *I* can run it by using
>> the S99local link exactly the same as it real name, so why doesn't init
>> run it?
>
>I had something similar happen to me some time in the past, say about Fedora
>Core 3, and my init script was hanging (I could see it with pstree) asking
>for user input. I would pepper the script with
>
> echo $$ so far so good >> /tmp/cursed-initscript.log
>
And would you believe, it all worked on this reboot. I think I'll go shoot
the neighbors worthless tomcat. This is frustrating, it failed absolutely on
the last 3 reboots.

I put that echo in S98wine, S99anacron, S99 firstboot and S99local, and while
init is still visible in a pstree output, that file looks like this:

2563 so far so good, start of wine
2563 so far so good, end of wine startup
2571 so far so good, start of anacron
2571 so far so good, end of anacron
2581 so far so good, start of firstboot
2581 so far so good, firstboot should exit here
2588 so far so good, start of rc.local

>to see if it is started at all and then hangs or exits somewhere.
>
>Davide Bolcioni



--
Cheers, Gene
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
QOTD:
"A child of 5 could understand this! Fetch me a child of 5."

--
fedora-selinux-list mailing list
fedora-selinux-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-selinux-list
 
Old 01-08-2008, 01:13 AM
Gene Heskett
 
Default su user -c problem

On Monday 07 January 2008, Gene Heskett wrote:
>On Monday 07 January 2008, Davide Bolcioni wrote:
>>On Monday 07 January 2008 05:23:20 pm Gene Heskett wrote:
>>> I boot and login at runlevel 3, the everything but X, then run startx by
>>> hand. I'm a big dummy maybe, and an old fart, but *I* can run it by using
>>> the S99local link exactly the same as it real name, so why doesn't init
>>> run it?
>>
>>I had something similar happen to me some time in the past, say about
>> Fedora Core 3, and my init script was hanging (I could see it with pstree)
>> asking for user input. I would pepper the script with
>>
>> echo $$ so far so good >> /tmp/cursed-initscript.log
>
>And would you believe, it all worked on this reboot. I think I'll go shoot
>the neighbors worthless tomcat. This is frustrating, it failed absolutely
> on the last 3 reboots.
>
>I put that echo in S98wine, S99anacron, S99 firstboot and S99local, and
> while init is still visible in a pstree output, that file looks like this:
>
>2563 so far so good, start of wine
>2563 so far so good, end of wine startup
>2571 so far so good, start of anacron
>2571 so far so good, end of anacron
>2581 so far so good, start of firstboot
>2581 so far so good, firstboot should exit here
>2588 so far so good, start of rc.local
>
>>to see if it is started at all and then hangs or exits somewhere.
>>
>>Davide Bolcioni

And a PS to the PS if you will. That boot above had an selinux=0 on the grub
kernel line that I had forgot adding earlier this day. I obviously have a
bad case of CRS. So I took it out and rebooted again. Of course it had to
relabel everything, but this time S99local ran just fine including getting
fetchmail started. Repeatable? Damnifiknow.

Thanks for the hints though, that might come in handy yet. Humm, I should
take the double >> back to a single > for the first one, else that file will
get pretty big in a few years.

--
Cheers, Gene
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Fortune and love befriend the bold.
-- Ovid

--
fedora-selinux-list mailing list
fedora-selinux-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-selinux-list
 

Thread Tools




All times are GMT. The time now is 11:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org