FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Packaging

 
 
LinkBack Thread Tools
 
Old 08-07-2012, 04:41 PM
Tom Callaway
 
Default Change to the Packaging Guidelines

Here is one late change to the Fedora Packaging Guidelines:

---

The systemd scriptlet guidelines have been updated for Fedora 18. In
Fedora 18, the systemd package now provides helper macros to simplify
%post, %preun, and %postun invocations in packages with systemd unit
files. Additionally, these macros enable support for systemd "profiles",
a Fedora 18 Feature.

​https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

---

This guideline change was approved by the Fedora Packaging
Committee (FPC), but was delayed until recently, pending Feature
approval of the systemd "profiles" feature.

Many thanks to Lennart Poettering, and all of the members of
the FPC, for assisting in drafting, refining, and passing these guidelines.

As a reminder: The Fedora Packaging Guidelines are living documents! If
you find something missing, incorrect, or in need of revision, you can
suggest a draft change. The procedure for this is documented here:
https://fedoraproject.org/wiki/Packaging/Committee#GuidelineChangeProcedure

Thanks,

~tom
--
packaging mailing list
packaging@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/packaging
 
Old 10-08-2012, 05:35 PM
Tom Callaway
 
Default Change to the Packaging Guidelines

A few minor changes to the Fedora Packaging Guidelines have been made:

---

The Ruby Packaging guidelines were updated to reflect the fact that
rubygem packages must have a Requires: rubygems, because that package
(rubygems) owns the RubyGems? directory structure.

https://fedoraproject.org/wiki/Packaging:Ruby#RubyGems

---

The systemd Scriptlets for Fedora 18+ have had their corresponding
scriptlet Requires adjusted from "systemd-units" to "systemd", since
"systemd-units" is provided by the "systemd" package in Fedora 18+.
There is still a separation in previous releases of Fedora (16/17), so
packagers can choose to continue using the old Requires (systemd-units)
if they are targeting multiple versions of Fedora with a single spec file.

https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Macroized_scriptlets_. 28Fedora_18.2B.29

---

This guideline change was approved by the Fedora Packaging
Committee (FPC).

Many thanks to Vit Ondruch, Lennart Poettering, and all of the members
of the FPC, for assisting in drafting, refining, and passing these
guidelines.

As a reminder: The Fedora Packaging Guidelines are living documents! If
you find something missing, incorrect, or in need of revision, you can
suggest a draft change. The procedure for this is documented here:
https://fedoraproject.org/wiki/Packaging/Committee#GuidelineChangeProcedure

Thanks,

~tom
--
packaging mailing list
packaging@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/packaging
 

Thread Tools




All times are GMT. The time now is 10:40 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org