Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Packaging (http://www.linux-archive.org/fedora-packaging/)
-   -   Automatic detection of Requires and versions (http://www.linux-archive.org/fedora-packaging/33223-automatic-detection-requires-versions.html)

Rex Dieter 01-09-2008 06:14 PM

Automatic detection of Requires and versions
 
Axel Thimm wrote:

On Wed, Jan 09, 2008 at 11:58:23AM -0500, Bill Nottingham wrote:
Patrice Dumas (pertusus@free.fr) said:
If something is added between 2.8 and 2.10 while ABI is kept compatible
and the soname isn't changed, and that new thing is needed, then the
soname is not enough.

Only in the case when you're running something built against, say
Fedora 8, on Fedora < 8. (Or Fedora 8 from some number of months
ago, I suppose, if people are gratuitously upgrading libraries.)


As said this has happened with real life use cases:


But these cases are (should be!) much the exception, and not the rule.

-- Rex

--
Fedora-packaging mailing list
Fedora-packaging@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-packaging


All times are GMT. The time now is 06:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.