I'm attempting to package a program I wrote, that uses the GTK+
libraries. It uses features first found in the 2.10.X series, so I
BuildRequires: gtk2-devel >= 2.10.0
(and similar lines for glib and other required libraries). All this is
OK. The problem is regarding the Requires for the generated .rpm. I
Requires: gtk2 >= 2.10.0
but apparently this is bad style and bad for maintenance, because
dependencies are found automatically on build time. However, without
manually adding the requires, the generated .rpm contains (with regard
to GTK+) this:
that is, no mention of the version, and I expect that even a GTK+ 2.8
package (old as that may be) should provide that file with that name.
What is the best way to handle that? Include the Require manually?
Leave this as-is?
Thanks in advance,
Fedora-packaging mailing list