FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora/Linux Management Tools

 
 
LinkBack Thread Tools
 
Old 11-21-2007, 03:58 PM
Tom Brown
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

Hi

Just trying to setup a new machine and this is my first attempt at a
cobbler server. I installed what i need i think but running a cobbler
check gives me the folowing error.


Can anyone give me hints to this error??

thanks

# cobbler check
Traceback (most recent call last):
File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 719,
in main

BootCLI(sys.argv).run()
File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 42,
in __init__

self.api = api.BootAPI()
File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 40, in
__init__

self.deserialize()
File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 170, in
deserialize

return self._config.deserialize()
File "/usr/lib/python2.3/site-packages/cobbler/config.py", line 169,
in deserialize

if not serializer.deserialize(x,topological=True):
File "/usr/lib/python2.3/site-packages/cobbler/serializer.py", line
79, in deserialize

datastruct.sort(cmp=__depth_cmp)
TypeError: sort() takes no keyword arguments

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 05:37 PM
Tom Brown
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

Just trying to setup a new machine and this is my first attempt at a
cobbler server. I installed what i need i think but running a cobbler
check gives me the folowing error.


Can anyone give me hints to this error??

thanks

# cobbler check
Traceback (most recent call last):
File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 719,
in main

BootCLI(sys.argv).run()
File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 42,
in __init__

self.api = api.BootAPI()
File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 40, in
__init__

self.deserialize()
File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 170, in
deserialize

return self._config.deserialize()
File "/usr/lib/python2.3/site-packages/cobbler/config.py", line 169,
in deserialize

if not serializer.deserialize(x,topological=True):
File "/usr/lib/python2.3/site-packages/cobbler/serializer.py", line
79, in deserialize

datastruct.sort(cmp=__depth_cmp)
TypeError: sort() takes no keyword arguments


anyone help here? This seems to be a similar issue

http://www.redhat.com/archives/et-mgmt-tools/2007-July/msg00023.html

but i installed from romforge rpm's and so i am unsure about the fix?

thanks for any assistance


_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 06:08 PM
"Patrick Nixon"
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

I know that 0.5 is a very old version, I think it's up to 0.6.3
Check the website, there may be newer packages someplace.

On Nov 21, 2007 1:37 PM, Tom Brown <tom@ng23.net> wrote:
>
>
> >
> >
> > Just trying to setup a new machine and this is my first attempt at a
> > cobbler server. I installed what i need i think but running a cobbler
> > check gives me the folowing error.
> >
> > Can anyone give me hints to this error??
> >
> > thanks
> >
> > # cobbler check
> > Traceback (most recent call last):
> > File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 719,
> > in main
> > BootCLI(sys.argv).run()
> > File "/usr/lib/python2.3/site-packages/cobbler/cobbler.py", line 42,
> > in __init__
> > self.api = api.BootAPI()
> > File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 40, in
> > __init__
> > self.deserialize()
> > File "/usr/lib/python2.3/site-packages/cobbler/api.py", line 170, in
> > deserialize
> > return self._config.deserialize()
> > File "/usr/lib/python2.3/site-packages/cobbler/config.py", line 169,
> > in deserialize
> > if not serializer.deserialize(x,topological=True):
> > File "/usr/lib/python2.3/site-packages/cobbler/serializer.py", line
> > 79, in deserialize
> > datastruct.sort(cmp=__depth_cmp)
> > TypeError: sort() takes no keyword arguments
>
> anyone help here? This seems to be a similar issue
>
> http://www.redhat.com/archives/et-mgmt-tools/2007-July/msg00023.html
>
> but i installed from romforge rpm's and so i am unsure about the fix?
>
> thanks for any assistance
>
>
>
> _______________________________________________
> et-mgmt-tools mailing list
> et-mgmt-tools@redhat.com
> https://www.redhat.com/mailman/listinfo/et-mgmt-tools
>

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 06:18 PM
Johnny Tan
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

Patrick Nixon wrote:

I know that 0.5 is a very old version, I think it's up to 0.6.3
Check the website, there may be newer packages someplace.


Yeah I agree. I'm a big fan of rpmforge and use them
whenever possible, but epel does have a newer cobbler --
version 0.6.2, hopefully they'll get 0.6.3 soon.


johnn

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 08:45 PM
Tom Brown
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

I know that 0.5 is a very old version, I think it's up to 0.6.3
Check the website, there may be newer packages someplace.


Yeah I agree. I'm a big fan of rpmforge and use them whenever
possible, but epel does have a newer cobbler -- version 0.6.2,
hopefully they'll get 0.6.3 soon.





thanks - i cant find newer for CentOS 4.x so i am trying to build my own.

It bombs out here

Processing files: cobbler-0.6.4-1
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.53447
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd cobbler-0.6.4
+ DOCDIR=/var/tmp/cobbler-0.6.4-1-root/usr/share/doc/cobbler-0.6.4
+ export DOCDIR
+ rm -rf /var/tmp/cobbler-0.6.4-1-root/usr/share/doc/cobbler-0.6.4
+ /bin/mkdir -p /var/tmp/cobbler-0.6.4-1-root/usr/share/doc/cobbler-0.6.4
+ cp -pr AUTHORS CHANGELOG COPYING README
/var/tmp/cobbler-0.6.4-1-root/usr/share/doc/cobbler-0.6.4

+ exit 0
warning: File listed twice:
/usr/lib/python2.3/site-packages/cobbler/__init__.pyo
warning: File listed twice:
/usr/lib/python2.3/site-packages/cobbler/action_check.pyo
warning: File listed twice:
/usr/lib/python2.3/site-packages/cobbler/action_import.pyo
warning: File listed twice:
/usr/lib/python2.3/site-packages/cobbler/action_litesync.pyo
warning: File listed twice:
/usr/lib/python2.3/site-packages/cobbler/action_reposync.pyo


-- snip --

and then

Provides: config(cobbler) = 0.6.4-1
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires(postun): /bin/sh
Requires: /bin/sh /usr/bin/python config(cobbler) = 0.6.4-1 createrepo
httpd mod_python python-cheetah python-devel >= 2.3 tftp-server yum-utils
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/cobbler-0.6.4-1-root

error: Installed (but unpackaged) file(s) found:
/etc/logrotate.d/cobblerd_rotate
/usr/share/cobbler/webui_templates/blank.tmpl
/usr/share/cobbler/webui_templates/distro_edit.tmpl
/usr/share/cobbler/webui_templates/distro_list.tmpl

etc

Any thoughts?

thanks

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 09:24 PM
Matt Hyclak
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

On Wed, Nov 21, 2007 at 09:45:28PM +0000, Tom Brown enlightened us:
> >>I know that 0.5 is a very old version, I think it's up to 0.6.3
> >>Check the website, there may be newer packages someplace.
> >
> >Yeah I agree. I'm a big fan of rpmforge and use them whenever
> >possible, but epel does have a newer cobbler -- version 0.6.2,
> >hopefully they'll get 0.6.3 soon.
> >
>
>
> thanks - i cant find newer for CentOS 4.x so i am trying to build my own.
>

I have packages available at http://www.math.ohiou.edu/pub/casit/et-tools/

These will eventually make it into CentOS Extras or rpmrepo, after 4.6 and
5.1 are out the door.

Currently 0.6.2 is up there, but I'm updating to 0.6.4 now.

Matt

--
Matt Hyclak
Department of Mathematics
Department of Social Work
Ohio University
(740) 593-1263

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 11-21-2007, 09:34 PM
Tom Brown
 
Default [et-mgmt-tools] CentOS 4.5 - cobbler-0.5.0-1.el4.rf - check error

I have packages available at http://www.math.ohiou.edu/pub/casit/et-tools/

These will eventually make it into CentOS Extras or rpmrepo, after 4.6 and
5.1 are out the door.

Currently 0.6.2 is up there, but I'm updating to 0.6.4 now.





thanks - i used git to get the latest source and built that OK

# rpm -qa | grep cobbler
cobbler-0.6.5-1

I just grabbed your latest koan though thanks!

Tom


_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 

Thread Tools




All times are GMT. The time now is 10:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org