FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 10-09-2008, 08:55 PM
Martial Paupe
 
Default Try to use cft ...

Hi,

I'm trying to use cft but I've got that error when I begin a session.

# cft begin httpd
/usr/lib/ruby/site_ruby/1.8/puppet/parameter.rb:403:in
`unsafe_validate': Invalid 'failovermethod' value "priorit". Valid
values are absent. Valid values match (?-mix:roundrobin|priority).
(ArgumentError)
from /usr/lib/ruby/site_ruby/1.8/puppet/parameter.rb:159:in
`validate'
from /usr/lib/ruby/site_ruby/1.8/puppet/property.rb:395:in
`should='
from /usr/lib/ruby/site_ruby/1.8/puppet/property.rb:394:in
`each'
from /usr/lib/ruby/site_ruby/1.8/puppet/property.rb:394:in
`should='
from /usr/lib/ruby/site_ruby/1.8/puppet/type/yumrepo.rb:94:in
`instances'

from /usr/lib/ruby/site_ruby/1.8/puppet/metatype/attributes.rb:530:in
`eachproperty'

from /usr/lib/ruby/site_ruby/1.8/puppet/metatype/attributes.rb:529:in
`each'

from /usr/lib/ruby/site_ruby/1.8/puppet/metatype/attributes.rb:529:in
`eachproperty'
... 9 levels...
from /usr/lib/ruby/site_ruby/1.8/cft/puppet.rb:8:in `genstate'
from /usr/lib/ruby/site_ruby/1.8/cft/commands.rb:178:in
`execute'
from /usr/lib/ruby/site_ruby/1.8/cft/commands.rb:148:in
`execute'
from /usr/sbin/cft:7

#

My config is as follow :

rhel 5.2
puppet-0.24.5-1.el5
cft-0.2.2-1.el5
ruby-1.8.5-5.el5_1.1
ruby-fam-0.2.0-4.el5
ruby-rpm-1.2.3-4.el5

Thanks for any help
Martial

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 
Old 10-17-2008, 01:04 AM
David Lutterkort
 
Default Try to use cft ...

On Fri, 2008-10-10 at 09:55 +1300, Martial Paupe wrote:
> I'm trying to use cft but I've got that error when I begin a session.
>
> # cft begin httpd
> /usr/lib/ruby/site_ruby/1.8/puppet/parameter.rb:403:in
> `unsafe_validate': Invalid 'failovermethod' value "priorit". Valid
> values are absent. Valid values match (?-mix:roundrobin|priority).

It seems that you havea yumrepo on that machine with a failovermethod
that is neither 'roundrobin' nor 'priority' - the only valid values
according to yum.conf(5)

David


_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@redhat.com
https://www.redhat.com/mailman/listinfo/et-mgmt-tools
 

Thread Tools




All times are GMT. The time now is 11:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org