FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Laptop

 
 
LinkBack Thread Tools
 
Old 05-21-2008, 02:30 PM
Mike Heffner
 
Default No sound (speakers nor headphones) on Toshiba Tecra A8-S8314 w/ FC9

With attachments this time.

Mike Heffner wrote:

Hi,

I've installed the FC 9 x86 release from DVD onto a Toshiba Tecra
A8-S8314 laptop, but I can't seem to get sound to work through the
speakers nor the headphone jack on the front.


The sound card is an ALC262 chip using the snd-hda-intel driver. I've
followed the suggestions at:


http://ubuntuforums.org/showthread.php?t=330763

(add: options snd-hda-intel model=hippo)

and:

http://goonanism.com/blog/2007/12/02/sound-on-a-toshiba-tecra-a8-with-ubuntu-710/



(add: options snd-hda-intel enable=1 index=0 model=basic)

However, neither of these approaches worked at getting sound out of
either the headphones or the speakers. I've also run alsaunmute and
alsamixer to unmute the various channels without any luck.



This is from dmesg with the hippo model:

ALSA sound/pci/hda/hda_intel.c:1810: chipset global capabilities = 0x4401
firewire_ohci: Added fw-ohci device 0000:03:0b.1, OHCI version 1.10
ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x3
ALSA sound/pci/hda/hda_codec.c:2211: hda_codec: model 'hippo' is selected
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Speaker Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Line-Out Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Speaker Playback
Switch, skipped


and lspci:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller (rev 02)

Subsystem: Toshiba America Info Systems Unknown device 0001


I've attached gzipped versions of both in full.


I have also tested with various permutations of "noapic" and "acpi=off"
given that there are of APIC error messages in dmesg:


APIC error on CPU0: 40(40)
APIC error on CPU1: 40(40)



Anyone have suggestions or hit similar problems? Willing to test various
workarounds and/or patches.



Cheers,

Mike





Mike

--

Mike Heffner <mheffner@[acm.]vt.edu>
<mikeh@FreeBSD.org>

_______________________________________________
Fedora-laptop-list mailing list
Fedora-laptop-list@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-laptop-list
 
Old 05-21-2008, 02:39 PM
Sean Madden
 
Default No sound (speakers nor headphones) on Toshiba Tecra A8-S8314 w/ FC9

Mike,
Take a look at my bug report here:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3856 . I have a
Lenovo laptop with the same audio chipset. See if this fix doesn't work
for you as well.


-Sean

Mike Heffner wrote:

With attachments this time.

Mike Heffner wrote:

Hi,

I've installed the FC 9 x86 release from DVD onto a Toshiba Tecra
A8-S8314 laptop, but I can't seem to get sound to work through the
speakers nor the headphone jack on the front.


The sound card is an ALC262 chip using the snd-hda-intel driver. I've
followed the suggestions at:


http://ubuntuforums.org/showthread.php?t=330763

(add: options snd-hda-intel model=hippo)

and:

http://goonanism.com/blog/2007/12/02/sound-on-a-toshiba-tecra-a8-with-ubuntu-710/



(add: options snd-hda-intel enable=1 index=0 model=basic)

However, neither of these approaches worked at getting sound out of
either the headphones or the speakers. I've also run alsaunmute and
alsamixer to unmute the various channels without any luck.



This is from dmesg with the hippo model:

ALSA sound/pci/hda/hda_intel.c:1810: chipset global capabilities =
0x4401

firewire_ohci: Added fw-ohci device 0000:03:0b.1, OHCI version 1.10
ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x3
ALSA sound/pci/hda/hda_codec.c:2211: hda_codec: model 'hippo' is
selected
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround
Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center
Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback
Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Speaker
Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Line-Out
Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Surround
Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Center
Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave LFE Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Side Playback
Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1073: Cannot find slave Speaker
Playback Switch, skipped


and lspci:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller (rev 02)

Subsystem: Toshiba America Info Systems Unknown device 0001


I've attached gzipped versions of both in full.


I have also tested with various permutations of "noapic" and
"acpi=off" given that there are of APIC error messages in dmesg:


APIC error on CPU0: 40(40)
APIC error on CPU1: 40(40)



Anyone have suggestions or hit similar problems? Willing to test
various workarounds and/or patches.



Cheers,

Mike





Mike

------------------------------------------------------------------------

_______________________________________________
Fedora-laptop-list mailing list
Fedora-laptop-list@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-laptop-list



_______________________________________________
Fedora-laptop-list mailing list
Fedora-laptop-list@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-laptop-list
 

Thread Tools




All times are GMT. The time now is 05:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org