FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Laptop

 
 
LinkBack Thread Tools
 
Old 08-13-2012, 07:45 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

Hi all,
Just wondering if anyone else experienced this problem in the last week or so with Fedora 17.
My machine notified my of updates last Wednesday. *I went ahead with the updates. Without warning my screen sort-of flashed and then the machine rebooted. However it would not boot but instead hung (right after the common bad font type message). *My machine will boot in level 3 mode and I can run startx in that mode - though it doesn't manage to run the gnome 3 interface. *
I've tried several pretty useless changes - useless in that though they came up in google searches they really don't seem to have anything to do with the issue.*I've looked at /var/log/messages with some other experts and we can't see anything that stands out.*The issue seems to be an Xorg problem and I'm not sure how I can reconfigure. *I've tried running: "Xorg :1 configure" but that didn't do anything. I don't see any system-config-monitor or anything like that anymore. So I'm not sure what to do to get gnome 3 back working.
Anyone any ideas/similar issues? *As I said I can boot in level 3 and run startx but I still hang on a normal boot.*
Lenovo X220
Best,William______________________________________ _________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-13-2012, 08:51 PM
Ian Malone
 
Default Last weeks F17 updates and problems with booting

On 13 August 2012 20:45, William Henry <whenry@redhat.com> wrote:
> Hi all,
>
> Just wondering if anyone else experienced this problem in the last week or
> so with Fedora 17.
>
> My machine notified my of updates last Wednesday. I went ahead with the
> updates. Without warning my screen sort-of flashed and then the machine
> rebooted. However it would not boot but instead hung (right after the common

That's not a great sign, I don't think doing an update is supposed to
reboot the machine automatically. It's likely your system crashed
(either hardware or software) and if that happened during an update
you might be in an awkward place. Alternatively something got
installed that was sufficiently broken that it caused a crash (though
I don't think that would affect X until you restarted X). Or it just
happens that one of the updates doesn't work for you and the restart
was incidental.

> bad font type message). My machine will boot in level 3 mode and I can run
> startx in that mode - though it doesn't manage to run the gnome 3 interface.
>
> I've tried several pretty useless changes - useless in that though they came
> up in google searches they really don't seem to have anything to do with the
> issue. I've looked at /var/log/messages with some other experts and we can't
> see anything that stands out. The issue seems to be an Xorg problem and I'm
> not sure how I can reconfigure. I've tried running: "Xorg :1 configure" but
> that didn't do anything. I don't see any system-config-monitor or anything
> like that anymore. So I'm not sure what to do to get gnome 3 back working.
>
> Anyone any ideas/similar issues? As I said I can boot in level 3 and run
> startx but I still hang on a normal boot.
>

I'd look at the yum log (/var/log/yum.log) for the update and try
reinstalling all implicated packages (assuming you have a network
connection available). If there are X related packages upgraded try
rolling them back if possible (I'm assuming that if there's a kernel
update in the window you've already tried booting the previous one).
Might also be worth finding the /var/log/boot.log that corresponds to
one of the failed boots.

--
imalone
http://ibmalone.blogspot.co.uk
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-13-2012, 09:21 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

----- Original Message -----
> On 13 August 2012 20:45, William Henry <whenry@redhat.com> wrote:
> > Hi all,
> >
> > Just wondering if anyone else experienced this problem in the last
> > week or
> > so with Fedora 17.
> >
> > My machine notified my of updates last Wednesday. I went ahead
> > with the
> > updates. Without warning my screen sort-of flashed and then the
> > machine
> > rebooted. However it would not boot but instead hung (right after
> > the common
>
> That's not a great sign, I don't think doing an update is supposed to
> reboot the machine automatically. It's likely your system crashed
> (either hardware or software) and if that happened during an update
> you might be in an awkward place. Alternatively something got
> installed that was sufficiently broken that it caused a crash (though
> I don't think that would affect X until you restarted X). Or it just
> happens that one of the updates doesn't work for you and the restart
> was incidental.

That's funny - when I used the word "crash" with some others they didn't like me using that word. I'm glad someone else sees this as a crash. (cause it was.). But you bring up an interesting point below.

>
> > bad font type message). My machine will boot in level 3 mode and I
> > can run
> > startx in that mode - though it doesn't manage to run the gnome 3
> > interface.
> >
> > I've tried several pretty useless changes - useless in that though
> > they came
> > up in google searches they really don't seem to have anything to do
> > with the
> > issue. I've looked at /var/log/messages with some other experts and
> > we can't
> > see anything that stands out. The issue seems to be an Xorg problem
> > and I'm
> > not sure how I can reconfigure. I've tried running: "Xorg :1
> > configure" but
> > that didn't do anything. I don't see any system-config-monitor or
> > anything
> > like that anymore. So I'm not sure what to do to get gnome 3 back
> > working.
> >
> > Anyone any ideas/similar issues? As I said I can boot in level 3
> > and run
> > startx but I still hang on a normal boot.
> >
>
> I'd look at the yum log (/var/log/yum.log) for the update and try
> reinstalling all implicated packages (assuming you have a network
> connection available). If there are X related packages upgraded try
> rolling them back if possible (I'm assuming that if there's a kernel
> update in the window you've already tried booting the previous one).
> Might also be worth finding the /var/log/boot.log that corresponds to
> one of the failed boots.

I looked in the yum.log file and there is NOT entry for Aug 8th the day it happened.

BTW I did try and use the older F17 entries in grub but it didn't help.

I've done an update since. There was new stuff today. Perhaps a reboot will fix things.

I will look at some of the packages and try and look in some of the corresponding boot.logs. But I don't see any other boot.log file besides the one from the last boot whihc of course is always ok because me only successful boots are with level 3 and are therefore successful.

William

>
> --
> imalone
> http://ibmalone.blogspot.co.uk
> _______________________________________________
> laptop mailing list
> laptop@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/laptop
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-13-2012, 10:01 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

One interesting difference between level 3 and default boot.

With default boot and quiet etc off I see a iscsi failure that I don't see in level 3:

[Failed] Failed to start LSB: Starts and Stops login and scanning of iscsi devices. Asks to run systemctl status iscsi.service for details.

But of course when I run this in level 3 I don't see the problem because I never see that failure message on. Lot in level 3.

I wonder if I just need to reinstall Fedora 17 at this stage. It's very disappointing that there isn't some sort of diagnostic tool that I could run to solve and fix this issue. F17 has been the most troublesome for me. I started at F7 and don't remember anything like the issues I've had this time around. (my preupgrade failed and I had to install from scratch and now this from-scratch install had a problem with an update.) /me looks forward to F18 (I think). (or maybe it's my Lenovo x220)

William


On Aug 13, 2012, at 2:51 PM, Ian Malone <ibmalone@gmail.com> wrote:

> On 13 August 2012 20:45, William Henry <whenry@redhat.com> wrote:
>> Hi all,
>>
>> Just wondering if anyone else experienced this problem in the last week or
>> so with Fedora 17.
>>
>> My machine notified my of updates last Wednesday. I went ahead with the
>> updates. Without warning my screen sort-of flashed and then the machine
>> rebooted. However it would not boot but instead hung (right after the common
>
> That's not a great sign, I don't think doing an update is supposed to
> reboot the machine automatically. It's likely your system crashed
> (either hardware or software) and if that happened during an update
> you might be in an awkward place. Alternatively something got
> installed that was sufficiently broken that it caused a crash (though
> I don't think that would affect X until you restarted X). Or it just
> happens that one of the updates doesn't work for you and the restart
> was incidental.
>
>> bad font type message). My machine will boot in level 3 mode and I can run
>> startx in that mode - though it doesn't manage to run the gnome 3 interface.
>>
>> I've tried several pretty useless changes - useless in that though they came
>> up in google searches they really don't seem to have anything to do with the
>> issue. I've looked at /var/log/messages with some other experts and we can't
>> see anything that stands out. The issue seems to be an Xorg problem and I'm
>> not sure how I can reconfigure. I've tried running: "Xorg :1 configure" but
>> that didn't do anything. I don't see any system-config-monitor or anything
>> like that anymore. So I'm not sure what to do to get gnome 3 back working.
>>
>> Anyone any ideas/similar issues? As I said I can boot in level 3 and run
>> startx but I still hang on a normal boot.
>>
>
> I'd look at the yum log (/var/log/yum.log) for the update and try
> reinstalling all implicated packages (assuming you have a network
> connection available). If there are X related packages upgraded try
> rolling them back if possible (I'm assuming that if there's a kernel
> update in the window you've already tried booting the previous one).
> Might also be worth finding the /var/log/boot.log that corresponds to
> one of the failed boots.
>
> --
> imalone
> http://ibmalone.blogspot.co.uk
> _______________________________________________
> laptop mailing list
> laptop@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/laptop
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-14-2012, 01:10 PM
"Steven Grunza"
 
Default Last weeks F17 updates and problems with booting

> -----Original Message-----
> From: laptop-bounces@lists.fedoraproject.org [mailto:laptop-
> bounces@lists.fedoraproject.org] On Behalf Of William Henry
> Sent: Monday, August 13, 2012 6:02 PM
> To: Ian Malone
> Cc: laptop
> Subject: Re: Last weeks F17 updates and problems with booting
>
> One interesting difference between level 3 and default boot.
>
> With default boot and quiet etc off I see a iscsi failure that I
> don't see in level 3:
>
> [Failed] Failed to start LSB: Starts and Stops login and scanning
> of iscsi devices. Asks to run systemctl status iscsi.service for
> details.
>
> But of course when I run this in level 3 I don't see the problem
> because I never see that failure message on. Lot in level 3.
>
> I wonder if I just need to reinstall Fedora 17 at this stage. It's
> very disappointing that there isn't some sort of diagnostic tool
> that I could run to solve and fix this issue. F17 has been the most
> troublesome for me. I started at F7 and don't remember anything
> like the issues I've had this time around. (my preupgrade failed
> and I had to install from scratch and now this from-scratch install
> had a problem with an update.) /me looks forward to F18 (I think).
> (or maybe it's my Lenovo x220)
>
> William
>
If it was my laptop then before a complete re-install I would boot into level 3 (non-graphical) and try to un-install all the X11 packages. I would then try to re-install the packages I normally use which would most likely bring in X11 because of dependencies. It might not get you back to running but if you're going to re-install it's worth a shot. Just a thought...

_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-14-2012, 02:26 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

Thanks. Great idea.

Sent from my iPhone

On Aug 14, 2012, at 7:10 AM, "Steven Grunza" <sgrunza@ctdi.com> wrote:

>> -----Original Message-----
>> From: laptop-bounces@lists.fedoraproject.org [mailto:laptop-
>> bounces@lists.fedoraproject.org] On Behalf Of William Henry
>> Sent: Monday, August 13, 2012 6:02 PM
>> To: Ian Malone
>> Cc: laptop
>> Subject: Re: Last weeks F17 updates and problems with booting
>>
>> One interesting difference between level 3 and default boot.
>>
>> With default boot and quiet etc off I see a iscsi failure that I
>> don't see in level 3:
>>
>> [Failed] Failed to start LSB: Starts and Stops login and scanning
>> of iscsi devices. Asks to run systemctl status iscsi.service for
>> details.
>>
>> But of course when I run this in level 3 I don't see the problem
>> because I never see that failure message on. Lot in level 3.
>>
>> I wonder if I just need to reinstall Fedora 17 at this stage. It's
>> very disappointing that there isn't some sort of diagnostic tool
>> that I could run to solve and fix this issue. F17 has been the most
>> troublesome for me. I started at F7 and don't remember anything
>> like the issues I've had this time around. (my preupgrade failed
>> and I had to install from scratch and now this from-scratch install
>> had a problem with an update.) /me looks forward to F18 (I think).
>> (or maybe it's my Lenovo x220)
>>
>> William
>>
> If it was my laptop then before a complete re-install I would boot into level 3 (non-graphical) and try to un-install all the X11 packages. I would then try to re-install the packages I normally use which would most likely bring in X11 because of dependencies. It might not get you back to running but if you're going to re-install it's worth a shot. Just a thought...
>
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-14-2012, 07:03 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

Tried it and felt I was getting close. But then I hit other issues trying to get things back.

Downloaded the DVD ISO to reinstall from fedora project and that failed. Got pushed into dracut (?). Not sure why that image doesn't work for me.

So then I went live cd and that worked. I installed from there. And currently resorting the backup of my home dir.

So I basically gave up and reinstalled. Wasted several days. Very disappointed.

Thanks for you help guys. The effort was much appreciated.

William


On Aug 14, 2012, at 8:26 AM, William Henry <whenry@redhat.com> wrote:

> Thanks. Great idea.
>
> Sent from my iPhone
>
> On Aug 14, 2012, at 7:10 AM, "Steven Grunza" <sgrunza@ctdi.com> wrote:
>
>>> -----Original Message-----
>>> From: laptop-bounces@lists.fedoraproject.org [mailto:laptop-
>>> bounces@lists.fedoraproject.org] On Behalf Of William Henry
>>> Sent: Monday, August 13, 2012 6:02 PM
>>> To: Ian Malone
>>> Cc: laptop
>>> Subject: Re: Last weeks F17 updates and problems with booting
>>>
>>> One interesting difference between level 3 and default boot.
>>>
>>> With default boot and quiet etc off I see a iscsi failure that I
>>> don't see in level 3:
>>>
>>> [Failed] Failed to start LSB: Starts and Stops login and scanning
>>> of iscsi devices. Asks to run systemctl status iscsi.service for
>>> details.
>>>
>>> But of course when I run this in level 3 I don't see the problem
>>> because I never see that failure message on. Lot in level 3.
>>>
>>> I wonder if I just need to reinstall Fedora 17 at this stage. It's
>>> very disappointing that there isn't some sort of diagnostic tool
>>> that I could run to solve and fix this issue. F17 has been the most
>>> troublesome for me. I started at F7 and don't remember anything
>>> like the issues I've had this time around. (my preupgrade failed
>>> and I had to install from scratch and now this from-scratch install
>>> had a problem with an update.) /me looks forward to F18 (I think).
>>> (or maybe it's my Lenovo x220)
>>>
>>> William
>>>
>> If it was my laptop then before a complete re-install I would boot into level 3 (non-graphical) and try to un-install all the X11 packages. I would then try to re-install the packages I normally use which would most likely bring in X11 because of dependencies. It might not get you back to running but if you're going to re-install it's worth a shot. Just a thought...
>>
> _______________________________________________
> laptop mailing list
> laptop@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/laptop
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-14-2012, 07:08 PM
"Steven Grunza"
 
Default Last weeks F17 updates and problems with booting

> -----Original Message-----
> From: William Henry [mailto:whenry@redhat.com]
> Sent: Tuesday, August 14, 2012 3:03 PM
> To: William Henry
> Cc: Steven Grunza; laptop
> Subject: Re: Last weeks F17 updates and problems with booting
>
> Tried it and felt I was getting close. But then I hit other issues
> trying to get things back.
>
> Downloaded the DVD ISO to reinstall from fedora project and that
> failed. Got pushed into dracut (?). Not sure why that image doesn't
> work for me.
>
> So then I went live cd and that worked. I installed from there. And
> currently resorting the backup of my home dir.
>
> So I basically gave up and reinstalled. Wasted several days. Very
> disappointed.
>
> Thanks for you help guys. The effort was much appreciated.
>
> William
>
I almost went the same path except my problem was in the ACPI code. An
update had the nasty side effect of turning the CPU fan on full speed
all the time. About a week before I was going to have an opportunity to
re-image and switch to a different OS another update fixed the issue.
Fedora is awesome when it works but when it gets broken it can be really
difficult to fix...


_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 
Old 08-14-2012, 07:12 PM
William Henry
 
Default Last weeks F17 updates and problems with booting

Sorry for the top reply - on my iPad.

I'm disappointed there isn't more diagnostic tools and self repairing tools. I'd have expected that I could have run something that would tell me what was wrong and ask if I would allow the tool to repair.

William


On Aug 14, 2012, at 1:09 PM, "Steven Grunza" <sgrunza@ctdi.com> wrote:

>> -----Original Message-----
>> From: William Henry [mailto:whenry@redhat.com]
>> Sent: Tuesday, August 14, 2012 3:03 PM
>> To: William Henry
>> Cc: Steven Grunza; laptop
>> Subject: Re: Last weeks F17 updates and problems with booting
>>
>> Tried it and felt I was getting close. But then I hit other issues
>> trying to get things back.
>>
>> Downloaded the DVD ISO to reinstall from fedora project and that
>> failed. Got pushed into dracut (?). Not sure why that image doesn't
>> work for me.
>>
>> So then I went live cd and that worked. I installed from there. And
>> currently resorting the backup of my home dir.
>>
>> So I basically gave up and reinstalled. Wasted several days. Very
>> disappointed.
>>
>> Thanks for you help guys. The effort was much appreciated.
>>
>> William
>>
> I almost went the same path except my problem was in the ACPI code. An
> update had the nasty side effect of turning the CPU fan on full speed
> all the time. About a week before I was going to have an opportunity to
> re-image and switch to a different OS another update fixed the issue.
> Fedora is awesome when it works but when it gets broken it can be really
> difficult to fix...
>
>
_______________________________________________
laptop mailing list
laptop@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/laptop
 

Thread Tools




All times are GMT. The time now is 05:08 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org