FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Laptop

 
 
LinkBack Thread Tools
 
Old 12-05-2007, 08:10 PM
"Erez Hadad"
 
Default Problem with mode switching on ATI 7500

Hi all,

I have a laptop (Compaq Evo N1000v) with a graphics card of ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] with 32MB memory. I'm running Fedora 8, and the auto-installed X driver is "radeon".


My problem is that whenever I switch from the default graphics mode (1400x1050@60Hz) to any other mode, and specifically to text mode, the LCD screen displays a white stain that expands and engulfs the entire screen, making it completely white. However, when I switch back to graphics mode, the display is resumed perfectly with the graphic desktop environment.


To make sure this is not a hardware problem, I ran X with the "vesa" driver, and it worked smoothly for all mode switch operations, although this driver yields (not surprisingly) lower performance in 3D, as I measured with the glxgears app.


I attached the configuration and the log files of both vesa and radeon. One thing I noted is that the radeon driver operates on all 3 outputs of the card: the LVDS (which I believe is the LCD screen), the CRT (the external VGA connector) and the TV (which is the external S-Video connector). I also inserted "@@@@@" strings in the logs at the places where the mode-switch took place. It seems that the "radeon" driver performs "RESTORE" operations on all the outputs when it comes back to graphics mode. However, when it switches to text mode, it does not "RESTORE" the LVDS, just the TV and CRT outputs (I think). Can this be somehow attributed to the fade-to-white problem I mentioned above? Alternatively, can anyone suggest a way to make the "radeon" driver work properly?


Note that the "vesa" driver does not log any meaningful operation on the graphics card at all during mode switch - just switch the Synaptics touchpad on and off.

I have also tried various combinations (from man-pages and web sites) of both radeon-specific and generic options in the
xorg.conf. None of these combinations solved my problem.

Regards,
Erez Hadad


_______________________________________________
Fedora-laptop-list mailing list
Fedora-laptop-list@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-laptop-list
 

Thread Tools




All times are GMT. The time now is 09:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org