FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Infrastructure

 
 
LinkBack Thread Tools
 
Old 11-15-2010, 07:18 AM
Adrian Reber
 
Default Mirrormanager's crawler not running

According to a few hosts I checked in Mirrormanager's web frontend the
crawler has not been running for at least three days. Last run was on
2010-11-12.

Adrian
_______________________________________________
infrastructure mailing list
infrastructure@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/infrastructure
 
Old 11-15-2010, 08:32 AM
Ricky Zhou
 
Default Mirrormanager's crawler not running

On 2010-11-15 09:18:05 AM, Adrian Reber wrote:
> According to a few hosts I checked in Mirrormanager's web frontend the
> crawler has not been running for at least three days. Last run was on
> 2010-11-12.
Hi, this was due to a stuck lockfile - I've restarted the crawler now.

This happened earlier today with update-master-directory-list too, which
caused people to get hash mismatches with yum. What happened was that
/var/run/mirrormanager/crawler.pid and /var/run/mirrormanager/umdl.pid
were empty, which prevented both of these processes from running since
sometime on the 13th.

I'm not sure how this condition occurs - maybe the process updating the
pidfile somehow got killed before it wrote the pid in? It is strange to
see the exact same problem with two different jobs though.

Thanks,
Ricky
_______________________________________________
infrastructure mailing list
infrastructure@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/infrastructure
 
Old 11-15-2010, 02:07 PM
 
Default Mirrormanager's crawler not running

Ugh, that's twice recently then. I need to revisit that pid handling code in MM. It looks like it does open()/write()/close(), so not a lot of room for error, but who knows...

--
Matt Domsch
Technology Strategist
Dell | Office of the CTO


-----Original Message-----
From: infrastructure-bounces@lists.fedoraproject.org [mailto:infrastructure-bounces@lists.fedoraproject.org] On Behalf Of Ricky Zhou
Sent: Monday, November 15, 2010 3:33 AM
To: infrastructure@lists.fedoraproject.org
Subject: Re: Mirrormanager's crawler not running

On 2010-11-15 09:18:05 AM, Adrian Reber wrote:
> According to a few hosts I checked in Mirrormanager's web frontend the
> crawler has not been running for at least three days. Last run was on
> 2010-11-12.
Hi, this was due to a stuck lockfile - I've restarted the crawler now.

This happened earlier today with update-master-directory-list too, which caused people to get hash mismatches with yum. What happened was that /var/run/mirrormanager/crawler.pid and /var/run/mirrormanager/umdl.pid were empty, which prevented both of these processes from running since sometime on the 13th.

I'm not sure how this condition occurs - maybe the process updating the pidfile somehow got killed before it wrote the pid in? It is strange to see the exact same problem with two different jobs though.

Thanks,
Ricky
_______________________________________________
infrastructure mailing list
infrastructure@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/infrastructure
 

Thread Tools




All times are GMT. The time now is 03:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org