FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Directory

 
 
LinkBack Thread Tools
 
Old 08-01-2012, 03:17 AM
Rich Megginson
 
Default Directory server not restarting

On 07/31/2012 08:05 PM, 389@noboost.org wrote:

Hi All,

Spec:
Redhat Enterprise Linux 6.3 x64

- ipa-server-2.2.0-16.el6.x86_64
- 389-ds-base-1.2.10.2-18.el6_3.x86_64
- 389-ds-base-libs-1.2.10.2-18.el6_3.x86_64

We had a simple (but quite drammatic) issue the other day. Our backup
script simply does a cold backup of the 389 Directory Server, however
this time it didn't start back up.

[31/Jul/2012:02:00:38 +1000] - slapd stopped.
[31/Jul/2012:02:00:43 +1000] createprlistensockets - PR_Bind() on All
Interfaces port 636 failed: Netscape Portable Runtime error -5982 (Local
Network address is in use.)

Is there anyway to work out why this happened?
When I did a manual restart in the morning it was fine. The backups even
worked perfectly last night too. Sounds like a bug in the ipa shutdown
script?

ps -ef|grep ns-slapd
netstat -an |grep 636

What process is listening on 636 when you attempt to startup directory
server?


cya

Craig

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users


--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 08-01-2012, 03:23 AM
 
Default Directory server not restarting

[root@server1 init.d]# ps -ef|grep ns-slapd
pkisrv 12939 1 0 02:00 ? 00:00:23 /usr/sbin/ns-slapd -D
/etc/dirsrv/slapd-PKI-IPA -i /var/run/dirsrv/slapd-PKI-IPA.pid -w
/var/run/dirsrv/slapd-PKI-IPA.startpid
dirsrv 13008 1 0 02:00 ? 00:00:57 /usr/sbin/ns-slapd -D
/etc/dirsrv/slapd-example-DOMAIN-COM-AU -i
/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.pid -w
/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.startpid
root 14985 14844 0 13:21 pts/0 00:00:00 grep ns-slapd

[root@sysvm-ipa init.d]# netstat -anp |grep 636
tcp 0 0 :::636 :::* LISTEN 13008/ns-slapd

cya

Craig


On Tue, Jul 31, 2012 at 09:17:30PM -0600, Rich Megginson wrote:
> On 07/31/2012 08:05 PM, 389@noboost.org wrote:
> >Hi All,
> >
> >Spec:
> >Redhat Enterprise Linux 6.3 x64
> >
> >- ipa-server-2.2.0-16.el6.x86_64
> >- 389-ds-base-1.2.10.2-18.el6_3.x86_64
> >- 389-ds-base-libs-1.2.10.2-18.el6_3.x86_64
> >
> >We had a simple (but quite drammatic) issue the other day. Our backup
> >script simply does a cold backup of the 389 Directory Server, however
> >this time it didn't start back up.
> >
> >[31/Jul/2012:02:00:38 +1000] - slapd stopped.
> >[31/Jul/2012:02:00:43 +1000] createprlistensockets - PR_Bind() on All
> >Interfaces port 636 failed: Netscape Portable Runtime error -5982 (Local
> >Network address is in use.)
> >
> >Is there anyway to work out why this happened?
> >When I did a manual restart in the morning it was fine. The backups even
> >worked perfectly last night too. Sounds like a bug in the ipa shutdown
> >script?
> ps -ef|grep ns-slapd
> netstat -an |grep 636
>
> What process is listening on 636 when you attempt to startup
> directory server?
> >
> >cya
> >
> >Craig
> >
> >--
> >389 users mailing list
> >389-users@lists.fedoraproject.org
> >https://admin.fedoraproject.org/mailman/listinfo/389-users
>
--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 08-01-2012, 03:28 AM
Rich Megginson
 
Default Directory server not restarting

On 07/31/2012 09:23 PM, 389@noboost.org wrote:

[root@server1 init.d]# ps -ef|grep ns-slapd
pkisrv 12939 1 0 02:00 ? 00:00:23 /usr/sbin/ns-slapd -D
/etc/dirsrv/slapd-PKI-IPA -i /var/run/dirsrv/slapd-PKI-IPA.pid -w
/var/run/dirsrv/slapd-PKI-IPA.startpid
dirsrv 13008 1 0 02:00 ? 00:00:57 /usr/sbin/ns-slapd -D
/etc/dirsrv/slapd-example-DOMAIN-COM-AU -i
/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.pid -w
/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.startpid
root 14985 14844 0 13:21 pts/0 00:00:00 grep ns-slapd

[root@sysvm-ipa init.d]# netstat -anp |grep 636
tcp 0 0 :::636 :::* LISTEN 13008/ns-slapd

cya

Craig


How are you stopping/starting/restarting directory server? Why is it
already running when you attempt to start it? Are you using ipactl? Is
this an IPA problem?





On Tue, Jul 31, 2012 at 09:17:30PM -0600, Rich Megginson wrote:

On 07/31/2012 08:05 PM, 389@noboost.org wrote:

Hi All,

Spec:
Redhat Enterprise Linux 6.3 x64

- ipa-server-2.2.0-16.el6.x86_64
- 389-ds-base-1.2.10.2-18.el6_3.x86_64
- 389-ds-base-libs-1.2.10.2-18.el6_3.x86_64

We had a simple (but quite drammatic) issue the other day. Our backup
script simply does a cold backup of the 389 Directory Server, however
this time it didn't start back up.

[31/Jul/2012:02:00:38 +1000] - slapd stopped.
[31/Jul/2012:02:00:43 +1000] createprlistensockets - PR_Bind() on All
Interfaces port 636 failed: Netscape Portable Runtime error -5982 (Local
Network address is in use.)

Is there anyway to work out why this happened?
When I did a manual restart in the morning it was fine. The backups even
worked perfectly last night too. Sounds like a bug in the ipa shutdown
script?

ps -ef|grep ns-slapd
netstat -an |grep 636

What process is listening on 636 when you attempt to startup
directory server?

cya

Craig

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users


--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 08-01-2012, 03:51 AM
 
Default Directory server not restarting

Answers below:
On Tue, Jul 31, 2012 at 09:28:45PM -0600, Rich Megginson wrote:
> On 07/31/2012 09:23 PM, 389@noboost.org wrote:
> >[root@server1 init.d]# ps -ef|grep ns-slapd
> >pkisrv 12939 1 0 02:00 ? 00:00:23 /usr/sbin/ns-slapd -D
> >/etc/dirsrv/slapd-PKI-IPA -i /var/run/dirsrv/slapd-PKI-IPA.pid -w
> >/var/run/dirsrv/slapd-PKI-IPA.startpid
> >dirsrv 13008 1 0 02:00 ? 00:00:57 /usr/sbin/ns-slapd -D
> >/etc/dirsrv/slapd-example-DOMAIN-COM-AU -i
> >/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.pid -w
> >/var/run/dirsrv/slapd-example-DOMAIN-COM-AU.startpid
> >root 14985 14844 0 13:21 pts/0 00:00:00 grep ns-slapd
> >
> >[root@sysvm-ipa init.d]# netstat -anp |grep 636
> >tcp 0 0 :::636 :::* LISTEN 13008/ns-slapd
> >
> >cya
> >
> >Craig
>
> How are you stopping/starting/restarting directory server?
from a remote ssh script, which is using "/etc/init.d/ipa stop"

> Why is it already running when you attempt to start it?
It should not have been running, the error occured during a
shutdown/cold backup/startup script we run at 2am.

> Are you using ipactl? Is this an IPA problem?
Yes and most probably yes.
>
> >
> >
> >On Tue, Jul 31, 2012 at 09:17:30PM -0600, Rich Megginson wrote:
> >>On 07/31/2012 08:05 PM, 389@noboost.org wrote:
> >>>Hi All,
> >>>
> >>>Spec:
> >>>Redhat Enterprise Linux 6.3 x64
> >>>
> >>>- ipa-server-2.2.0-16.el6.x86_64
> >>>- 389-ds-base-1.2.10.2-18.el6_3.x86_64
> >>>- 389-ds-base-libs-1.2.10.2-18.el6_3.x86_64
> >>>
> >>>We had a simple (but quite drammatic) issue the other day. Our backup
> >>>script simply does a cold backup of the 389 Directory Server, however
> >>>this time it didn't start back up.
> >>>
> >>>[31/Jul/2012:02:00:38 +1000] - slapd stopped.
> >>>[31/Jul/2012:02:00:43 +1000] createprlistensockets - PR_Bind() on All
> >>>Interfaces port 636 failed: Netscape Portable Runtime error -5982 (Local
> >>>Network address is in use.)
> >>>
> >>>Is there anyway to work out why this happened?
> >>>When I did a manual restart in the morning it was fine. The backups even
> >>>worked perfectly last night too. Sounds like a bug in the ipa shutdown
> >>>script?
> >>ps -ef|grep ns-slapd
> >>netstat -an |grep 636
> >>
> >>What process is listening on 636 when you attempt to startup
> >>directory server?
> >>>cya
> >>>
> >>>Craig
> >>>
> >>>--
> >>>389 users mailing list
> >>>389-users@lists.fedoraproject.org
> >>>https://admin.fedoraproject.org/mailman/listinfo/389-users
>
--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 

Thread Tools




All times are GMT. The time now is 12:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org