FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Directory

 
 
LinkBack Thread Tools
 
Old 02-14-2011, 09:46 AM
Gerrard Geldenhuis
 
Default replicating netscaperoot, server2 not in server1 console

Hi
If you can see two servers on one but not on the other it is most likely that you don't have replication setup on the server that shows two servers back to the other.

Check your logs for errors and 1.2.5 looks rather old, it might be worthwhile going to a newer version.

Regards

> -----Original Message-----
> From: 389-users-bounces@lists.fedoraproject.org [mailto:389-users-
> bounces@lists.fedoraproject.org] On Behalf Of Beamon, John
> Sent: 11 February 2011 20:44
> To: 389-users@lists.fedoraproject.org
> Subject: [389-users] replicating netscaperoot, server2 not in server1 console
>
> Running 389-ds 1.2.5 on two servers. I followed the techniques in this link,
> which uses setup-ds.pl and postpones registering until after the config has
> been built from LDIF and o=netscaperoot has been initialized.
>
> http://sinodun.com/howto/replicating-netscaperoot-on-fedora-ds/
>
> Connecting the console to server2, I find both server1 and server2 listed.
>
> Connecting the console to server1, only server1 is listed.
>
> This is not a failover design yet. I've tried running register-ds.pl to register
> server2 at server1's CDS, but the script does not ask where you want to
> register.
>
> >
> ================================================== =================
> ===========
> Candidate servers to register:
> /etc/dirsrv/slapd-chi01osi112
>
> ================================================== =================
> ===========
> Do you want to use this server as Configuration Directory Server?
>
> Directory server identifier [chi01osi112]:
>
> >
>
> What might I have missed? Thanks.
>
> -j
>


__________________________________________________ ______________________
In order to protect our email recipients, Betfair Group use SkyScan from
MessageLabs to scan all Incoming and Outgoing mail for viruses.

__________________________________________________ ______________________
--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 02-15-2011, 01:36 PM
"Beamon, John"
 
Default replicating netscaperoot, server2 not in server1 console

1.2.5 is two releases behind, but our deployment of 1.2.7 was obstructed by a segfault bug listed in bugzilla. Every time we replicated, the consumer died without logging or removing its PID file. We found 1.2.5 to be stable.

The document I linked postpones the admin server setup on "CDS #2" until after netscaperoot initialization. The problem is that CDS #2 ends up only registered to itself. Initializing its contents does not represent a "change" that would be back-replicated to CDS #1. This document seems incomplete to me, but I don't know the process well enough to critique it.



-----Original Message-----
From: 389-users-bounces@lists.fedoraproject.org [mailto:389-users-bounces@lists.fedoraproject.org] On Behalf Of Gerrard Geldenhuis
Sent: Monday, February 14, 2011 5:47 AM
To: 'General discussion list for the 389 Directory server project.'
Subject: Re: [389-users] replicating netscaperoot,server2 not in server1 console

Hi
If you can see two servers on one but not on the other it is most likely that you don't have replication setup on the server that shows two servers back to the other.

Check your logs for errors and 1.2.5 looks rather old, it might be worthwhile going to a newer version.

Regards

> -----Original Message-----
> From: 389-users-bounces@lists.fedoraproject.org [mailto:389-users-
> bounces@lists.fedoraproject.org] On Behalf Of Beamon, John
> Sent: 11 February 2011 20:44
> To: 389-users@lists.fedoraproject.org
> Subject: [389-users] replicating netscaperoot, server2 not in server1 console
>
> Running 389-ds 1.2.5 on two servers. I followed the techniques in this link,
> which uses setup-ds.pl and postpones registering until after the config has
> been built from LDIF and o=netscaperoot has been initialized.
>
> http://sinodun.com/howto/replicating-netscaperoot-on-fedora-ds/
>
> Connecting the console to server2, I find both server1 and server2 listed.
>
> Connecting the console to server1, only server1 is listed.
>
> This is not a failover design yet. I've tried running register-ds.pl to register
> server2 at server1's CDS, but the script does not ask where you want to
> register.
>
> >
> ================================================== =================
> ===========
> Candidate servers to register:
> /etc/dirsrv/slapd-chi01osi112
>
> ================================================== =================
> ===========
> Do you want to use this server as Configuration Directory Server?
>
> Directory server identifier [chi01osi112]:
>
> >
>
> What might I have missed? Thanks.
>
> -j
>


__________________________________________________ ______________________
In order to protect our email recipients, Betfair Group use SkyScan from
MessageLabs to scan all Incoming and Outgoing mail for viruses.

__________________________________________________ ______________________
--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 

Thread Tools




All times are GMT. The time now is 01:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org