FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Directory

 
 
LinkBack Thread Tools
 
Old 08-05-2010, 04:57 PM
Jonathan Boulle
 
Default replica/rdn problems with 1.2.6 rc6

When trying to enable consumer replication on a database/root suffix, we get an “operations error” (in the GUI or command line with ldapmodify) and the following in the log:
*
[05/Aug/2010:17:35:20 +0100] entryrdn-index - _entryrdn_insert_key: Suffix "dc=example" not found: DB_NOTFOUND: No matching key/data pair found(-30989)
[05/Aug/2010:17:35:20 +0100] - add: attempt to index 1 failed
[05/Aug/2010:17:35:20 +0100] NSMMReplicationPlugin - _replica_configure_ruv: failed to create replica ruv tombstone entry (dc=example); LDAP error – 1
*
However, the exact same procedure works fine on 1.2.5 (haven’t tested with earlier RC versions of 1.2.6)
*
When trying to troubleshoot - if I manually add the following to the directory:
* dn: dc=betfair
* dc: betfair
* objectClass: top
* objectClass: domain
I no longer get the above error, and the “Enable Replica” step succeeds, but I see this in the log:
*
[05/Aug/2010:17:45:14 +0100] NSMMReplicationPlugin - replica_add_by_dn: replica with dn (dc=example) already in the hash
[05/Aug/2010:17:45:14 +0100] NSMMReplicationPlugin - replica_add_by_dn: replica with dn (dc=example) already in the hash
*
Haven’t tested past this point – although this was definitely not necessary on e.g. 1.2.5. I suspect it’s related to the RDN shift mentioned in the changelogs, but I’ve reproduced the same issue with
a) upgrades from previous versions of the packages (e.g. 1.2.5)
b) clean installs of the above packages on a completely fresh CentOS 5.5 build

Package versions:
389-ds-1.2.1-1.el5
389-admin-1.1.11-0.6.rc2.el5
389-ds-base-1.2.6-0.9.rc6.el5
*
Bugzilla time?
*
Cheers


__________________________________________________ ______________________

In order to protect our email recipients, Betfair Group use SkyScan from

MessageLabs to scan all Incoming and Outgoing mail for viruses.



__________________________________________________ ______________________

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 08-05-2010, 05:07 PM
Rich Megginson
 
Default replica/rdn problems with 1.2.6 rc6

Jonathan Boulle wrote:
>
> When trying to enable consumer replication on a database/root suffix,
> we get an “operations error” (in the GUI or command line with
> ldapmodify) and the following in the log:
>
> [05/Aug/2010:17:35:20 +0100] entryrdn-index - _entryrdn_insert_key:
> Suffix "dc=example" not found: DB_NOTFOUND: No matching key/data pair
> found(-30989)
>
> [05/Aug/2010:17:35:20 +0100] - add: attempt to index 1 failed
>
> [05/Aug/2010:17:35:20 +0100] NSMMReplicationPlugin -
> _replica_configure_ruv: failed to create replica ruv tombstone entry
> (dc=example); LDAP error – 1
>
Can you post the following:
ldapsearch -LLL -x -D "cn=directory manager" -w yourpassword -s one -b
"cn=mapping tree,cn=config"
and
ldapsearch -LLL -x -D "cn=directory manager" -w yourpassword -s one -b
"cn=ldbm database,cn=plugins,cn=config"

Be sure to obscure any sensitive information.
>
> However, the exact same procedure works fine on 1.2.5 (haven’t tested
> with earlier RC versions of 1.2.6)
>
> When trying to troubleshoot - if I manually add the following to the
> directory:
>
> dn: dc=betfair
>
> dc: betfair
>
> objectClass: top
>
> objectClass: domain
>
> I no longer get the above error, and the “Enable Replica” step
> succeeds, but I see this in the log:
>
> [05/Aug/2010:17:45:14 +0100] NSMMReplicationPlugin -
> replica_add_by_dn: replica with dn (dc=example) already in the hash
>
> [05/Aug/2010:17:45:14 +0100] NSMMReplicationPlugin -
> replica_add_by_dn: replica with dn (dc=example) already in the hash
>
> Haven’t tested past this point – although this was definitely not
> necessary on e.g. 1.2.5. I suspect it’s related to the RDN shift
> mentioned in the changelogs, but I’ve reproduced the same issue with
>
> a) upgrades from previous versions of the packages (e.g. 1.2.5)
>
> b) clean installs of the above packages on a completely fresh CentOS
> 5.5 build
>
>
> Package versions:
>
> 389-ds-1.2.1-1.el5
>
> 389-admin-1.1.11-0.6.rc2.el5
>
> 389-ds-base-1.2.6-0.9.rc6.el5
>
> Bugzilla time?
>
> Cheers
>
>
> __________________________________________________ ______________________
> In order to protect our email recipients, Betfair Group use SkyScan from
> MessageLabs to scan all Incoming and Outgoing mail for viruses.
>
> __________________________________________________ ______________________
> ------------------------------------------------------------------------
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 

Thread Tools




All times are GMT. The time now is 09:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org