FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Directory

 
 
LinkBack Thread Tools
 
Old 07-12-2010, 11:19 AM
Juan Asensio Sánchez
 
Default Error initializing server

Hi

I am having trouble initializaing a server. That server has some replicas in r/o mode, as hub, and one as multimaster. When I try to initialize the multimaster database of this server from another server that has also that database in multimaster mode, I get these errors:



[12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin - multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going offline; disabling replication
[12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with nsslapd-db-private-import-mem on; No other process is allowed to access the database


[12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned
[12/Jul/2010:13:09:26 +0200] - import o_XXXX_dc_XXXX_dc_es: Aborting all import threads...
[12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import threads aborted.


[12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Closing files...
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/mail.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/member.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/cn.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/aci.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/sn.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uid.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such file or directory


[12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No such file or directory
[12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import failed.
[12/Jul/2010:13:09:33 +0200] - process_bulk_import_op: NULL backend


[12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin - replica_replace_ruv_tombstone: failed to update replication update vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
[12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin - replica_replace_ruv_tombstone: failed to update replication update vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1


[12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin - replica_replace_ruv_tombstone: failed to update replication update vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1


And the last message is repeating continiously. Also, the folder for that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is removed, although is recreated when the server is restarted. So I can not initialize that database (the other hub replicas work fine).



It looks the same as http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html, which has not any definitive solution.



Using CentOS 5.4 and 389 DS 1.2.5.

Regards.

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 07-14-2010, 09:44 PM
Rich Megginson
 
Default Error initializing server

Juan Asensio Sánchez wrote:
> Hi
>
> I am having trouble initializaing a server. That server has some
> replicas in r/o mode, as hub, and one as multimaster. When I try to
> initialize the multimaster database of this server from another server
> that has also that database in multimaster mode, I get these errors:
>
> [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -
> multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going
> offline; disabling replication
> [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with
> nsslapd-db-private-import-mem on; No other process is allowed to
> access the database
> [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned
What is your nsslapd-timelimit set to?
Are you using a load balancer or some other networking device like a BigIP?

> [12/Jul/2010:13:09:26 +0200] - import o_XXXX_dc_XXXX_dc_es: Aborting
> all import threads...
> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import
> threads aborted.
> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Closing
> files...
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/mail.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/member.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No such file
> or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/cn.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/aci.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/sn.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush: No such
> file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uid.db4:
> unable to flush: No such file or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No such file
> or directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No such file or
> directory
> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import failed.
> [12/Jul/2010:13:09:33 +0200] - process_bulk_import_op: NULL backend
> [12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin -
> replica_replace_ruv_tombstone: failed to update replication update
> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> [12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin -
> replica_replace_ruv_tombstone: failed to update replication update
> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> [12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin -
> replica_replace_ruv_tombstone: failed to update replication update
> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
>
>
> And the last message is repeating continiously. Also, the folder for
> that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is removed,
> although is recreated when the server is restarted. So I can not
> initialize that database (the other hub replicas work fine).
>
> It looks the same as
> http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html,
> which has not any definitive solution.
>
> Using CentOS 5.4 and 389 DS 1.2.5.
>
> Regards.
> ------------------------------------------------------------------------
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 07-15-2010, 07:43 AM
Juan Asensio Sánchez
 
Default Error initializing server

Hi

2010/7/14 Rich Megginson <rmeggins@redhat.com>


Juan Asensio Sánchez wrote:

> Hi

>

> I am having trouble initializaing a server. That server has some

> replicas in r/o mode, as hub, and one as multimaster. When I try to

> initialize the multimaster database of this server from another server

> that has also that database in multimaster mode, I get these errors:

>

> [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -

> multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going

> offline; disabling replication

> [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with

> nsslapd-db-private-import-mem on; No other process is allowed to

> access the database

> [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned

What is your nsslapd-timelimit set to?

Are you using a load balancer or some other networking device like a BigIP?

The attribute nsslapd-timelimit in cn=default instance config,cn=chaining database,cn=plugins,cn=config is 3600, and there is no such attribute in cn=config, (this is the default configuration).



The two servers are behind a hardware balancer, but the communication between them is direct.

I have created a new virtual machine, reinstalling the OS, Centos 5.5, and configuring everythin again, and I get the same error again.



Any idea?
*
> [12/Jul/2010:13:09:26 +0200] - import o_XXXX_dc_XXXX_dc_es: Aborting

> all import threads...

> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import

> threads aborted.

> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Closing

> files...

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/mail.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/member.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No such file

> or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/cn.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/aci.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/sn.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush: No such

> file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uid.db4:

> unable to flush: No such file or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No such file

> or directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - libdb:

> o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No such file or

> directory

> [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import failed.

> [12/Jul/2010:13:09:33 +0200] - process_bulk_import_op: NULL backend

> [12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin -

> replica_replace_ruv_tombstone: failed to update replication update

> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

> [12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin -

> replica_replace_ruv_tombstone: failed to update replication update

> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

> [12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin -

> replica_replace_ruv_tombstone: failed to update replication update

> vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

>

>

> And the last message is repeating continiously. Also, the folder for

> that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is removed,

> although is recreated when the server is restarted. So I can not

> initialize that database (the other hub replicas work fine).

>

> It looks the same as

> http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html,

> which has not any definitive solution.

>

> Using CentOS 5.4 and 389 DS 1.2.5.

>

> Regards.

> ------------------------------------------------------------------------

>

> --

> 389 users mailing list

> 389-users@lists.fedoraproject.org

> https://admin.fedoraproject.org/mailman/listinfo/389-users



--

389 users mailing list

389-users@lists.fedoraproject.org

https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 07-15-2010, 03:17 PM
Rich Megginson
 
Default Error initializing server

Juan Asensio Sánchez wrote:
> Hi
>
> 2010/7/14 Rich Megginson <rmeggins@redhat.com
> <mailto:rmeggins@redhat.com>>
>
> Juan Asensio Sánchez wrote:
> > Hi
> >
> > I am having trouble initializaing a server. That server has some
> > replicas in r/o mode, as hub, and one as multimaster. When I try to
> > initialize the multimaster database of this server from another
> server
> > that has also that database in multimaster mode, I get these errors:
> >
> > [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -
> > multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going
> > offline; disabling replication
> > [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with
> > nsslapd-db-private-import-mem on; No other process is allowed to
> > access the database
> > [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned
> What is your nsslapd-timelimit set to?
> Are you using a load balancer or some other networking device like
> a BigIP?
>
>
> The attribute nsslapd-timelimit in cn=default instance
> config,cn=chaining database,cn=plugins,cn=config is 3600, and there is
> no such attribute in cn=config, (this is the default configuration).
>
> The two servers are behind a hardware balancer, but the communication
> between them is direct.
>
> I have created a new virtual machine, reinstalling the OS, Centos 5.5,
> and configuring everythin again, and I get the same error again.
If this is easy to reproduce, please provide the exact steps, along with
relevant configuration.
>
> Any idea?
>
>
> > [12/Jul/2010:13:09:26 +0200] - import o_XXXX_dc_XXXX_dc_es: Aborting
> > all import threads...
> > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import
> > threads aborted.
> > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Closing
> > files...
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such
> file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/mail.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such
> file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such
> file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/member.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No
> such file
> > or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such
> file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/cn.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/aci.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/sn.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush: No such
> > file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uid.db4:
> > unable to flush: No such file or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No such file
> > or directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No such file or
> > directory
> > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es:
> Import failed.
> > [12/Jul/2010:13:09:33 +0200] - process_bulk_import_op: NULL backend
> > [12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin -
> > replica_replace_ruv_tombstone: failed to update replication update
> > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> > [12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin -
> > replica_replace_ruv_tombstone: failed to update replication update
> > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> > [12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin -
> > replica_replace_ruv_tombstone: failed to update replication update
> > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> >
> >
> > And the last message is repeating continiously. Also, the folder for
> > that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is
> removed,
> > although is recreated when the server is restarted. So I can not
> > initialize that database (the other hub replicas work fine).
> >
> > It looks the same as
> >
> http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html,
> > which has not any definitive solution.
> >
> > Using CentOS 5.4 and 389 DS 1.2.5.
> >
> > Regards.
> >
> ------------------------------------------------------------------------
> >
> > --
> > 389 users mailing list
> > 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> > https://admin.fedoraproject.org/mailman/listinfo/389-users
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> https://admin.fedoraproject.org/mailman/listinfo/389-users
>
>
> ------------------------------------------------------------------------
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 07-21-2010, 09:08 AM
Juan Asensio Sánchez
 
Default Error initializing server

Well, it is not easy to reproduce, because i don't know why it did happen. The only way i made it work was exporting the replica from the console of source server, and importing the data to the database of the destination server. This makes everything work fine again. But if I try to reinitialize the database from the console, (using the conext menu of a replication agreement), the error happens again. I think this is problem more of the supplier than the consumer, because I have had also problems reinitializing the same database from the same source/supplier to other different destination/consumer server.



2010/7/15 Rich Megginson <rmeggins@redhat.com>


Juan Asensio Sánchez wrote:

> Hi

>

> 2010/7/14 Rich Megginson <rmeggins@redhat.com

> <mailto:rmeggins@redhat.com>>

>

> * * Juan Asensio Sánchez wrote:

> * * > Hi

> * * >

> * * > I am having trouble initializaing a server. That server has some

> * * > replicas in r/o mode, as hub, and one as multimaster. When I try to

> * * > initialize the multimaster database of this server from another

> * * server

> * * > that has also that database in multimaster mode, I get these errors:

> * * >

> * * > [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -

> * * > multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going

> * * > offline; disabling replication

> * * > [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with

> * * > nsslapd-db-private-import-mem on; No other process is allowed to

> * * > access the database

> * * > [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned

> * * What is your nsslapd-timelimit set to?

> * * Are you using a load balancer or some other networking device like

> * * a BigIP?

>

>

> The attribute nsslapd-timelimit in cn=default instance

> config,cn=chaining database,cn=plugins,cn=config is 3600, and there is

> no such attribute in cn=config, (this is the default configuration).

>

> The two servers are behind a hardware balancer, but the communication

> between them is direct.

>

> I have created a new virtual machine, reinstalling the OS, Centos 5.5,

> and configuring everythin again, and I get the same error again.

If this is easy to reproduce, please provide the exact steps, along with

relevant configuration.

>

> Any idea?

>

>

> * * > [12/Jul/2010:13:09:26 +0200] - import o_XXXX_dc_XXXX_dc_es: Aborting

> * * > all import threads...

> * * > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Import

> * * > threads aborted.

> * * > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es: Closing

> * * > files...

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such

> * * file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/mail.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such

> * * file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such

> * * file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * o_XXXX_dc_XXXX_dc_es/member.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No

> * * such file

> * * > or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such

> * * file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/cn.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/aci.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/sn.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush: No such

> * * > file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb: o_XXXX_dc_XXXX_dc_es/uid.db4:

> * * > unable to flush: No such file or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No such file

> * * > or directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - libdb:

> * * > o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No such file or

> * * > directory

> * * > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es:

> * * Import failed.

> * * > [12/Jul/2010:13:09:33 +0200] - process_bulk_import_op: NULL backend

> * * > [12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin -

> * * > replica_replace_ruv_tombstone: failed to update replication update

> * * > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

> * * > [12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin -

> * * > replica_replace_ruv_tombstone: failed to update replication update

> * * > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

> * * > [12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin -

> * * > replica_replace_ruv_tombstone: failed to update replication update

> * * > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1

> * * >

> * * >

> * * > And the last message is repeating continiously. Also, the folder for

> * * > that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is

> * * removed,

> * * > although is recreated when the server is restarted. So I can not

> * * > initialize that database (the other hub replicas work fine).

> * * >

> * * > It looks the same as

> * * >

> * * http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html,

> * * > which has not any definitive solution.

> * * >

> * * > Using CentOS 5.4 and 389 DS 1.2.5.

> * * >

> * * > Regards.

> * * >

> * * ------------------------------------------------------------------------

> * * >

> * * > --

> * * > 389 users mailing list

> * * > 389-users@lists.fedoraproject.org

> * * <mailto:389-users@lists.fedoraproject.org>

> * * > https://admin.fedoraproject.org/mailman/listinfo/389-users

>

> * * --

> * * 389 users mailing list

> * * 389-users@lists.fedoraproject.org

> * * <mailto:389-users@lists.fedoraproject.org>

> * * https://admin.fedoraproject.org/mailman/listinfo/389-users

>

>

> ------------------------------------------------------------------------

>

> --

> 389 users mailing list

> 389-users@lists.fedoraproject.org

> https://admin.fedoraproject.org/mailman/listinfo/389-users



--

389 users mailing list

389-users@lists.fedoraproject.org

https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 
Old 07-21-2010, 01:54 PM
Rich Megginson
 
Default Error initializing server

Juan Asensio Sánchez wrote:
> Well, it is not easy to reproduce, because i don't know why it did
> happen. The only way i made it work was exporting the replica from the
> console of source server, and importing the data to the database of
> the destination server. This makes everything work fine again. But if
> I try to reinitialize the database from the console, (using the conext
> menu of a replication agreement), the error happens again. I think
> this is problem more of the supplier than the consumer, because I have
> had also problems reinitializing the same database from the same
> source/supplier to other different destination/consumer server.
This is very, very similar to this bug
https://bugzilla.redhat.com/show_bug.cgi?id=547503 this bug also causes
online init to stop with a bulk import abandoned error.

I would like to see the access log from the consumer showing the
disconnection. If you're not sure when that is - for example, in the
error log you posted:
> > [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -
> > multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es is going
> > offline; disabling replication
> > [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with
> > nsslapd-db-private-import-mem on; No other process is allowed to
> > access the database
> > [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned
Check the access log from between [12/Jul/2010:13:08:52 +0200] and
[12/Jul/2010:13:09:26 +0200] - there should be a line in the access log
showing the connection disconnected like this:
[19/Jul/2010:13:33:49 -0600] conn=2 op=6675 fd=65 closed - U1

In the bug case, the tag at the end is a T1 meaning idle timeout
exceeded. I would like to see what it is in your case when you get the
bulk import abandoned error.
>
> 2010/7/15 Rich Megginson <rmeggins@redhat.com
> <mailto:rmeggins@redhat.com>>
>
> Juan Asensio Sánchez wrote:
> > Hi
> >
> > 2010/7/14 Rich Megginson <rmeggins@redhat.com
> <mailto:rmeggins@redhat.com>
> > <mailto:rmeggins@redhat.com <mailto:rmeggins@redhat.com>>>
> >
> > Juan Asensio Sánchez wrote:
> > > Hi
> > >
> > > I am having trouble initializaing a server. That server
> has some
> > > replicas in r/o mode, as hub, and one as multimaster. When
> I try to
> > > initialize the multimaster database of this server from
> another
> > server
> > > that has also that database in multimaster mode, I get
> these errors:
> > >
> > > [12/Jul/2010:13:08:52 +0200] NSMMReplicationPlugin -
> > > multimaster_be_state_change: replica o=XXX,dc=XXXX,dc=es
> is going
> > > offline; disabling replication
> > > [12/Jul/2010:13:09:20 +0200] - WARNING: Import is running with
> > > nsslapd-db-private-import-mem on; No other process is
> allowed to
> > > access the database
> > > [12/Jul/2010:13:09:26 +0200] - ERROR bulk import abandoned
> > What is your nsslapd-timelimit set to?
> > Are you using a load balancer or some other networking
> device like
> > a BigIP?
> >
> >
> > The attribute nsslapd-timelimit in cn=default instance
> > config,cn=chaining database,cn=plugins,cn=config is 3600, and
> there is
> > no such attribute in cn=config, (this is the default configuration).
> >
> > The two servers are behind a hardware balancer, but the
> communication
> > between them is direct.
> >
> > I have created a new virtual machine, reinstalling the OS,
> Centos 5.5,
> > and configuring everythin again, and I get the same error again.
> If this is easy to reproduce, please provide the exact steps,
> along with
> relevant configuration.
> >
> > Any idea?
> >
> >
> > > [12/Jul/2010:13:09:26 +0200] - import
> o_XXXX_dc_XXXX_dc_es: Aborting
> > > all import threads...
> > > [12/Jul/2010:13:09:32 +0200] - import
> o_XXXX_dc_XXXX_dc_es: Import
> > > threads aborted.
> > > [12/Jul/2010:13:09:32 +0200] - import
> o_XXXX_dc_XXXX_dc_es: Closing
> > > files...
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/nscpEntryDN.db4: unable to flush: No such
> > file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/mail.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/givenName.db4: unable to flush: No
> such file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/nsuniqueid.db4: unable to flush: No such
> > file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/memberOf.db4: unable to flush: No
> such file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/ntUniqueId.db4: unable to flush: No such
> > file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > o_XXXX_dc_XXXX_dc_es/member.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/ntUserDomainId.db4: unable to flush: No
> > such file
> > > or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/objectclass.db4: unable to flush: No such
> > file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/cn.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/aci.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/seeAlso.db4: unable to flush: No such
> file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/sn.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/telephoneNumber.db4: unable to flush:
> No such
> > > file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> o_XXXX_dc_XXXX_dc_es/uid.db4:
> > > unable to flush: No such file or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/uniquemember.db4: unable to flush: No
> such file
> > > or directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/parentid.db4: unable to flush: No
> such file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/entrydn.db4: unable to flush: No such
> file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - libdb:
> > > o_XXXX_dc_XXXX_dc_es/id2entry.db4: unable to flush: No
> such file or
> > > directory
> > > [12/Jul/2010:13:09:32 +0200] - import o_XXXX_dc_XXXX_dc_es:
> > Import failed.
> > > [12/Jul/2010:13:09:33 +0200] - process_bulk_import_op:
> NULL backend
> > > [12/Jul/2010:13:09:34 +0200] NSMMReplicationPlugin -
> > > replica_replace_ruv_tombstone: failed to update
> replication update
> > > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> > > [12/Jul/2010:13:09:38 +0200] NSMMReplicationPlugin -
> > > replica_replace_ruv_tombstone: failed to update
> replication update
> > > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> > > [12/Jul/2010:13:09:41 +0200] NSMMReplicationPlugin -
> > > replica_replace_ruv_tombstone: failed to update
> replication update
> > > vector for replica o=XXXX,dc=XXXX,dc=es: LDAP error - 1
> > >
> > >
> > > And the last message is repeating continiously. Also, the
> folder for
> > > that database in /var/lib/dirsrv/db/o_XXXX_dc_XXXX_dc_es, is
> > removed,
> > > although is recreated when the server is restarted. So I
> can not
> > > initialize that database (the other hub replicas work fine).
> > >
> > > It looks the same as
> > >
> >
> http://www.redhat.com/archives/fedora-directory-users/2007-March/msg00100.html,
> > > which has not any definitive solution.
> > >
> > > Using CentOS 5.4 and 389 DS 1.2.5.
> > >
> > > Regards.
> > >
> >
> ------------------------------------------------------------------------
> > >
> > > --
> > > 389 users mailing list
> > > 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> > <mailto:389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>>
> > > https://admin.fedoraproject.org/mailman/listinfo/389-users
> >
> > --
> > 389 users mailing list
> > 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> > <mailto:389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>>
> > https://admin.fedoraproject.org/mailman/listinfo/389-users
> >
> >
> >
> ------------------------------------------------------------------------
> >
> > --
> > 389 users mailing list
> > 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> > https://admin.fedoraproject.org/mailman/listinfo/389-users
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> <mailto:389-users@lists.fedoraproject.org>
> https://admin.fedoraproject.org/mailman/listinfo/389-users
>
>
> ------------------------------------------------------------------------
>
> --
> 389 users mailing list
> 389-users@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/389-users

--
389 users mailing list
389-users@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
 

Thread Tools




All times are GMT. The time now is 01:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org