Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Directory (http://www.linux-archive.org/fedora-directory/)
-   -   udev rules (http://www.linux-archive.org/fedora-directory/254206-udev-rules.html)

Ramiro Fabricio Pulgar Montero 02-28-2009 02:58 AM

udev rules
 
Hi,

I want to know if I could assign udev rules through ldap / fedora directory server. I was looking for this information but I can't find it.

Thanks a lot for your help

*

Regards / Saludos

*

Ramiro Fabricio Pulgar M.

Mobile: (593 9) 2751705

Office: (593 2) 6007777 ext 206

MSN: milovisho@hotmail.com

Skype: milovisho

*

“An expert is a man who has made all the mistakes which can be made in a narrow field” – Niels Bohr

*

Disclaimer: The information contained in this e-mail is confidential and intended only for the use of the person or company to which it is addressed. This information is considered provisional and referential; it can not be totally or partially distributed nor copied by any media without the authorization from the sender. The sender does not assume responsibility about this information, opinions or criteria contented in this e-mail.

*



Invite your mail contacts to join your friends list with Windows Live Spaces. It's easy! Try it!
--
Fedora-directory-users mailing list
Fedora-directory-users@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-directory-users

"Majikinszzz" 12-17-2009 12:27 PM

Udev rules
 
Hi

I'm coming from an ubuntu background where this line in the udev.rule
file worked.
SUBSYSTEMS=="usb", ATTR{idVendor}=="0fd1", ATTR{idProduct}=="1000",
ATTR{bConfigurationValue}=="1",RUN+="/bin/bash -c 'echo 3 >
/sys/bus/usb/devices/%b/bConfigurationValue'"

However this does not work in Arch and I'm really struggling to
understand the udev wiki and udev rules - its going a bit over my head
at the moment. I have experimented with trying this line from looking
at other udev rules:

SUBSYSTEM=="usb", SYSFS{idProduct}=="1000", SYSFS{idVendor}=="0fd1",
RUN+="/bin/bash -c 'echo 3 > /sys/bus/usb/devices/%b/bConfigurationValue'"

the device is then recognised but /var/log/messages then shows and
endless looping of the device be connected and disconnected.

I'm not sure what to do.

Please can someone help?

M

Sent via my BlackBerry from Vodacom - let your email find you!

"Majikinszzz" 12-17-2009 03:10 PM

Udev rules
 
Hi

I'm coming from an ubuntu background where this line in the udev.rule
file worked.
SUBSYSTEMS=="usb", ATTR{idVendor}=="0fd1", ATTR{idProduct}=="1000",
ATTR{bConfigurationValue}=="1",RUN+="/bin/bash -c 'echo 3 >
/sys/bus/usb/devices/%b/bConfigurationValue'"

However this does not work in Arch and I'm really struggling to
understand the udev wiki and udev rules - its going a bit over my head
at the moment. I have experimented with trying this line from looking
at other udev rules:

SUBSYSTEM=="usb", SYSFS{idProduct}=="1000", SYSFS{idVendor}=="0fd1",
RUN+="/bin/bash -c 'echo 3 > /sys/bus/usb/devices/%b/bConfigurationValue'"

the device is then recognised but /var/log/messages then shows and
endless looping of the device be connected and disconnected.

I'm not sure what to do.

Please can someone help?

M

Sent via my BlackBerry from Vodacom - let your email find you!

David Relson 09-30-2012 03:29 PM

udev rules
 
Good morning!

I have a Rosewill 75 in 1 card reader with slots for USB, SATA, SD,
microSD, etc. udev recognizes USB devices and mounts them
as /media/<whatever>.

However, when SD and microSD cards are inserted, /var/log/messages
doesn't report anything and the cards aren't mounted.

Any suggestions where to look? what to fix?

I'm running kernel 3.2.11 on an AMD64 with udev-171.

Here's a link to the card reader
http://rosewill.com/products/1610/ProductDetail_Overview.htm

Regards,

David

Dale 09-30-2012 03:58 PM

udev rules
 
David Relson wrote:
> Good morning!
>
> I have a Rosewill 75 in 1 card reader with slots for USB, SATA, SD,
> microSD, etc. udev recognizes USB devices and mounts them
> as /media/<whatever>.
>
> However, when SD and microSD cards are inserted, /var/log/messages
> doesn't report anything and the cards aren't mounted.
>
> Any suggestions where to look? what to fix?
>
> I'm running kernel 3.2.11 on an AMD64 with udev-171.
>
> Here's a link to the card reader
> http://rosewill.com/products/1610/ProductDetail_Overview.htm
>
> Regards,
>
> David
>
>

Have you tried those cards on a different system to see if they work?
If they do, then the reader may be bad. May want to look for dust but
if it is new, surely not. ;-) Packing peanut maybe? o_O

I have bought a couple thinks made by Rosewill. Neither of them worked
for long. I sent one back for repair/replacement and got a new one with
about the same problem. I didn't send it back again because it wasn't
worth shipping back again plus I was expecting it to work at least for a
little while. It lasted overnight My new policy, don't buy Rosewill
products. They may work fine for someone else but they don't for me.

Dale

:-) :-)

--
I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

David Relson 09-30-2012 04:47 PM

udev rules
 
On Sun, 30 Sep 2012 10:58:42 -0500
Dale wrote:

> David Relson wrote:
> > Good morning!
> >
> > I have a Rosewill 75 in 1 card reader with slots for USB, SATA, SD,
> > microSD, etc. udev recognizes USB devices and mounts them
> > as /media/<whatever>.
> >
> > However, when SD and microSD cards are inserted, /var/log/messages
> > doesn't report anything and the cards aren't mounted.
> >
> > Any suggestions where to look? what to fix?
> >
> > I'm running kernel 3.2.11 on an AMD64 with udev-171.
> >
> > Here's a link to the card reader
> > http://rosewill.com/products/1610/ProductDetail_Overview.htm
> >
> > Regards,
> >
> > David
> >
> >
>
> Have you tried those cards on a different system to see if they work?
> If they do, then the reader may be bad. May want to look for dust but
> if it is new, surely not. ;-) Packing peanut maybe? o_O
>
> I have bought a couple thinks made by Rosewill. Neither of them
> worked for long. I sent one back for repair/replacement and got a
> new one with about the same problem. I didn't send it back again
> because it wasn't worth shipping back again plus I was expecting it
> to work at least for a little while. It lasted overnight My new
> policy, don't buy Rosewill products. They may work fine for someone
> else but they don't for me.
>
> Dale

Actually what I've got is a SanDisk 16GB microSD with an SD adapter.
Using my wife's windoze laptop, the SD/microSD combo works fine.

My initial use of the card is for Ubuntu linux for a MK802+ mini-pc.
The MK802+ boots Android off its internal storage or Ubuntu off of the
microSD. So, yes, the card appears to work.

David

Mick 09-30-2012 06:08 PM

udev rules
 
On Sunday 30 Sep 2012 17:47:45 David Relson wrote:
> On Sun, 30 Sep 2012 10:58:42 -0500
>
> Dale wrote:
> > David Relson wrote:
> > > Good morning!
> > >
> > > I have a Rosewill 75 in 1 card reader with slots for USB, SATA, SD,
> > > microSD, etc. udev recognizes USB devices and mounts them
> > > as /media/<whatever>.
> > >
> > > However, when SD and microSD cards are inserted, /var/log/messages
> > > doesn't report anything and the cards aren't mounted.
> > >
> > > Any suggestions where to look? what to fix?
> > >
> > > I'm running kernel 3.2.11 on an AMD64 with udev-171.
> > >
> > > Here's a link to the card reader
> > > http://rosewill.com/products/1610/ProductDetail_Overview.htm
> > >
> > > Regards,
> > >
> > > David
> >
> > Have you tried those cards on a different system to see if they work?
> > If they do, then the reader may be bad. May want to look for dust but
> > if it is new, surely not. ;-) Packing peanut maybe? o_O
> >
> > I have bought a couple thinks made by Rosewill. Neither of them
> > worked for long. I sent one back for repair/replacement and got a
> > new one with about the same problem. I didn't send it back again
> > because it wasn't worth shipping back again plus I was expecting it
> > to work at least for a little while. It lasted overnight My new
> > policy, don't buy Rosewill products. They may work fine for someone
> > else but they don't for me.
> >
> > Dale
>
> Actually what I've got is a SanDisk 16GB microSD with an SD adapter.
> Using my wife's windoze laptop, the SD/microSD combo works fine.
>
> My initial use of the card is for Ubuntu linux for a MK802+ mini-pc.
> The MK802+ boots Android off its internal storage or Ubuntu off of the
> microSD. So, yes, the card appears to work.
>
> David

Have you enabled the necessary drivers in your kernel?

Boot off a live CD that detects the USB controller and your MicroSD drive and
then check what kernel drivers are being used. When you boot back into Gentoo
you can enable the same and roll a new kernel.
--
Regards,
Mick

Neil Bothwick 09-30-2012 06:09 PM

udev rules
 
On Sun, 30 Sep 2012 11:29:09 -0400, David Relson wrote:

> I have a Rosewill 75 in 1 card reader with slots for USB, SATA, SD,
> microSD, etc. udev recognizes USB devices and mounts them
> as /media/<whatever>.
>
> However, when SD and microSD cards are inserted, /var/log/messages
> doesn't report anything and the cards aren't mounted.

I've just replaced my internal card reader had had a similar experience.
It turned out I'd forgotten to connect the power connector. The USB ports
work on a pass-through, so they were unaffected, but the cards appear to
connect to an internal powered hub, which wasn't powered.


--
Neil Bothwick

I'll be Bach.
-- Johann Sebastian Swartzenegger


All times are GMT. The time now is 04:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.