FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 05-19-2008, 10:35 PM
"Nicolas Mailhot"
 
Default yum --skip-boken not work

Le Lun 19 mai 2008 23:30, Oscar Victorio Calixto Bacho a écrit :
> Hi Guy
>
> yum --skip-broken update no work in today rawhide.
>
> exit said Skip-broken could not solve problems. It is totem problem.

you need to use something like

# yum --skip-broken -y update -x totem-pl-parser -x
evolution-data-server -x evolution -x openssh-server -x rhythmbox -x
ekiga -x evolution-webcal -x brasero -x pidgin -x gnome-panel -x
control-center

in rawhide like now. How did I arrive there? Because I'm smarter than
the skip-broken algorithm.

skip-broken is too dumb to realise that since totem-pl-parser can't be
updated (because totem depends on the old version) it needs to be
excluded. And once it's excluded all the new packages that depended
directly or indirectly on totem-pl-parser need to be excluded too.

So skip broken probably needs enhancing. I should do

"if new bar can not be installed because foo(installed) depends on old
bar exclude bar from the transaction ; if new baz can not be installed
because it depended on now excluded new bar exclude it too. etc"

Real-world non-cooked example:

# yum --skip-broken -y update

Skip-broken could not solve problems
Error: Missing Dependency: pam >= 1.0.1-3 is needed by package
openssh-server-5.0p1-2.fc10.x86_64 (rawhide)
Error: Missing Dependency: libtotem-plparser.so.10()(64bit) is needed
by package totem-2.23.2-3.fc9.x86_64 (installed)
Error: Missing Dependency: libtotem-plparser.so.10()(64bit) is needed
by package totem-nautilus-2.23.2-3.fc9.x86_64 (installed)

Focus on (installed) conflicts first

# rpm -q --whatprovides /usr/lib64/libtotem-plparser.so.10
totem-pl-parser-2.22.2-1.fc9.x86_64

# yum --skip-broken -y update -x totem-pl-parser

Skip-broken could not solve problems
Error: Missing Dependency: pam >= 1.0.1-3 is needed by package
openssh-server-5.0p1-2.fc10.x86_64 (rawhide)
Error: Missing Dependency: libcamel-1.2.so.11()(64bit) is needed by
package totem-pl-parser-2.22.2-1.fc9.x86_64 (installed)
Error: Missing Dependency: libtotem-plparser.so.12()(64bit) is needed
by package brasero-0.7.1-4.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.9()(64bit) is needed
by package totem-pl-parser-2.22.2-1.fc9.x86_64 (installed)
Error: Missing Dependency: libtotem-plparser.so.12()(64bit) is needed
by package rhythmbox-0.11.5-14.fc10.x86_64 (rawhide)

# rpm -q --whatprovides /usr/lib64/libcamel-1.2.so.11
evolution-data-server-2.22.1-2.fc9.x86_64

# yum --skip-broken -y update -x totem-pl-parser -x evolution-data-server

Skip-broken could not solve problems
Error: Missing Dependency: libcamel-provider-1.2.so.12()(64bit) is
needed by package evolution-2.23.2-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: pam >= 1.0.1-3 is needed by package
openssh-server-5.0p1-2.fc10.x86_64 (rawhide)
Error: Missing Dependency: libtotem-plparser.so.12()(64bit) is needed
by package rhythmbox-0.11.5-14.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package ekiga-2.0.12-2.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package evolution-webcal-2.21.92-2.fc10.x86_64 (rawhide)
Error: Missing Dependency: libtotem-plparser.so.12()(64bit) is needed
by package brasero-0.7.1-4.fc10.x86_64 (rawhide)
Error: Missing Dependency: libebackend-1.2.so.0()(64bit) is needed by
package pidgin-2.4.2-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: evolution-data-server >= 2.23.1 is needed
by package evolution-2.23.2-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package gnome-panel-2.23.2.1-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package evolution-2.23.2-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: libcamel-1.2.so.12()(64bit) is needed by
package evolution-2.23.2-1.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package 1:control-center-2.23.1-4.fc10.x86_64 (rawhide)
Error: Missing Dependency: libedataserver-1.2.so.11()(64bit) is needed
by package pidgin-2.4.2-1.fc10.x86_64 (rawhide)

No remaining (installed) problems. Time to kill the new stuff

# yum --skip-broken -y update -x totem-pl-parser -x
evolution-data-server -x evolution -x openssh-server -x rhythmbox -x
ekiga -x evolution-webcal -x brasero -x pidgin -x gnome-panel -x
control-center

Packages skipped because of dependency problems:
1:control-center-filesystem-2.23.1-4.fc10.x86_64 from rawhide
1:gnome-applets-2.23.2-1.fc10.x86_64 from rawhide
gnome-screensaver-2.23.3-0.2008.05.14.1.fc10.x86_64 from rawhide
gnome-settings-daemon-2.23.2-0.2008.05.14.2.fc10.x86_64 from rawhide
libgnomekbd-2.23.2-1.fc10.x86_64 from rawhide
libgnomekbd-2.23.2-1.fc10.x86_64 from rawhide
libpurple-2.4.2-1.fc10.x86_64 from rawhide
openssh-5.0p1-2.fc10.x86_64 from rawhide
openssh-askpass-5.0p1-2.fc10.x86_64 from rawhide
openssh-clients-5.0p1-2.fc10.x86_64 from rawhide

Transaction Summary
================================================== ===========================
Install 9 Package(s)
Update 18 Package(s)
Remove 0 Package(s)

It works!

--
Nicolas Mailhot

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 05-19-2008, 10:51 PM
"Oscar Victorio Calixto Bacho"
 
Default yum --skip-boken not work

It works!


*Thanks ..


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 05-20-2008, 08:15 AM
Jos Matos
 
Default yum --skip-boken not work

On Monday 19 May 2008 23:35:03 Nicolas Mailhot wrote:
> Le Lun 19 mai 2008 23:30, Oscar Victorio Calixto Bacho a crit :
> > Hi Guy
> >
> > yum --skip-broken update no work in today rawhide.
> >
> > exit said Skip-broken could not solve problems. It is totem problem.
>
> you need to use something like
>
> # yum --skip-broken -y update -x totem-pl-parser -x
> evolution-data-server -x evolution -x openssh-server -x rhythmbox -x
> ekiga -x evolution-webcal -x brasero -x pidgin -x gnome-panel -x
> control-center
>
> in rawhide like now. How did I arrive there? Because I'm smarter than
> the skip-broken algorithm.
>
> skip-broken is too dumb to realise that since totem-pl-parser can't be
> updated (because totem depends on the old version) it needs to be
> excluded. And once it's excluded all the new packages that depended
> directly or indirectly on totem-pl-parser need to be excluded too.

Actually if you update some packages in a separate transaction, and repeat
this procedure, at a certain point --skip-broken will correctly exclude all
those packages that you have excluded manually.

So there is here some kind of threshold but I was unable to determine which
one or what package was the culprit.

> --
> Nicolas Mailhot

--
Jos Ablio

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 10:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org