FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 05-14-2008, 11:19 PM
Orion Poplawski
 
Default mock/yum issues

Updated my F8 builder to mock-0.9.9-1.fc8. Did an x86_64 rawhide
--no-clean build for a package that added openssl-devel to the BR list,
and the following was installed:


DEBUG util.py:250: Installing:
DEBUG util.py:250: openssl-devel i386 0.9.8g-6.fc9
fedora 1.9 M
DEBUG util.py:250: openssl-devel x86_64 0.9.8g-6.fc9
fedora 1.9 M

DEBUG util.py:250: Installing for dependencies:
DEBUG util.py:250: device-mapper-devel i386 1.02.24-11.fc9
fedora 31 k
DEBUG util.py:250: e2fsprogs-devel i386 1.40.9-2.fc10
fedora 638 k
DEBUG util.py:250: keyutils-libs-devel i386 1.2-3.fc9
fedora 27 k
DEBUG util.py:250: krb5-devel i386 1.6.3-10.fc9
fedora 1.1 M
DEBUG util.py:250: libselinux-devel i386 2.0.64-2.fc10
fedora 108 k
DEBUG util.py:250: libsepol-devel i386 2.0.26-1.fc9
fedora 59 k

DEBUG util.py:250: Transaction Summary

Why the i386 packages?

--
Orion Poplawski
Technical Manager 303-415-9701 x222
NWRA/CoRA Division FAX: 303-415-9702
3380 Mitchell Lane orion@cora.nwra.com
Boulder, CO 80301 http://www.cora.nwra.com

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 05-14-2008, 11:44 PM
"Colin Walters"
 
Default mock/yum issues

On Wed, May 14, 2008 at 7:19 PM, Orion Poplawski <orion@cora.nwra.com> wrote:
> Updated my F8 builder [...]
> Why the i386 packages?

That's the default multilib policy in Fedora 8. It was switched for Fedora 9.

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 05-15-2008, 03:14 AM
 
Default mock/yum issues

> On Wed, May 14, 2008 at 7:19 PM, Orion Poplawski <orion@cora.nwra.com>
> wrote:
>> Updated my F8 builder [...]
>> Why the i386 packages?
>
> That's the default multilib policy in Fedora 8. It was switched for
> Fedora 9.

So the new mock package for F8 is wrong then:

# grub/syslinux on x86_64 need glibc-devel.i386 which pulls in glibc.i386,
need to exclude all
# .i?86 packages except these.
#exclude=[0-9A-Za-fh-z]*.i?86 g[0-9A-Za-km-z]*.i?86 gl[0-9A-Za-hj-z]*.i?86
gli[0-9A-Zac-z]*.i?86 glib[0-9A-Za-bd-z]*.i?86
# The above is not needed anymore with yum multilib policy of "best" which
is the default in Fedora.

But this is only on F9+. F8 should still have it.

https://bugzilla.redhat.com/show_bug.cgi?id=446556

- Orion

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 10:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org