FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 04-28-2008, 12:19 AM
Callum Lerwick
 
Default Intel xorg driver bug

On Sun, 2008-04-27 at 16:51 +0200, Nicolas Mailhot wrote:
> Le dimanche 27 avril 2008 18:01 +0400, Peter Lemenkov a crit :
>
> > I can't fill bugzilla ticket because I just don't know exactly to what
> > component this issue must be assigned - xorg-x11, some particular
> > driver, some middleware layer as pango/gtk/qt/etc, maybe this is bug
> > in freetype or somethere - I don't know.
>
> BTW could you specify what xorg driver you use please? Someone posted a
> mail on the xorg lists recently complaining the intel driver broke font
> rendering
>
> http://lists.freedesktop.org/archives/xorg/2008-April/034940.html

I updated my laptop a few days ago (F9/rawhide) and now I'm getting
corrupted fonts. It has an Intel 830M using the "intel" driver. It
starts out okay but grows worse every few minutes or so. It seems to
happen a few characters at a time. It's not just limited to fonts,
bitmaps seem to be affected too. So some kind of bug in the pixmap
caching? Flipping to a text console and back to X fixes it, but only
temporarily. Here's a screenshot after letting it get particularly bad:

http://www.flickr.com/photos/ninjaseg/2447596526/

... While I'm at it, OpenGL no longer works in F9. It used to work
beautifully, which was with the "i810" driver mind you, but now OpenGL
apps just segfault on startup. On the other hand, 2D works beautifully
(other than this new corruption bug). Previously (F8) the "intel" driver
didn't work at all with this hardware.
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-28-2008, 10:33 AM
Matej Cepl
 
Default Intel xorg driver bug

On Sun, 27 Apr 2008 19:19:36 -0500, Callum Lerwick scripst:
> I updated my laptop a few days ago (F9/rawhide) and now I'm getting

And bugs numbers are? Please, do file those bugs.

Matěj

--
The content of this message is licensed under a Creative Commons
Attribution 3.0 License, Some Rights Reserved.
http://creativecommons.org/licenses/by/3.0/us/

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-28-2008, 10:35 AM
Matej Cepl
 
Default Intel xorg driver bug

On Sun, 27 Apr 2008 19:19:36 -0500, Callum Lerwick scripst:
>> http://lists.freedesktop.org/archives/xorg/2008-April/034940.html

Just for the sake of bug triage -- could you please try again with Deja
fonts? Both you and Peter seem to have some non-standard fonts. Nothing
against, it should work anyway, but just to find out more about the nature
of the bug.

And of course, please, attach your /etc/X11/xorg.conf and /var/log/
Xorg.0.log to the bug. And try to run with /etc/X11/xorg.conf at all and
let us know what happens then.

Thank you very much in advance,

Matěj Cepl

--
The content of this message is licensed under a Creative Commons
Attribution 3.0 License, Some Rights Reserved.
http://creativecommons.org/licenses/by/3.0/us/

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-28-2008, 06:09 PM
Ralf Ertzinger
 
Default Intel xorg driver bug

Hi.

On Sun, 27 Apr 2008 19:19:36 -0500, Callum Lerwick wrote

> I updated my laptop a few days ago (F9/rawhide) and now I'm getting
> corrupted fonts. It has an Intel 830M using the "intel" driver. It
> starts out okay but grows worse every few minutes or so. It seems to
> happen a few characters at a time. It's not just limited to fonts,
> bitmaps seem to be affected too.

Could that be https://bugzilla.redhat.com/show_bug.cgi?id=441665 ?

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-29-2008, 05:49 AM
Callum Lerwick
 
Default Intel xorg driver bug

On Mon, 2008-04-28 at 20:09 +0200, Ralf Ertzinger wrote:
> Hi.
>
> On Sun, 27 Apr 2008 19:19:36 -0500, Callum Lerwick wrote
>
> > I updated my laptop a few days ago (F9/rawhide) and now I'm getting
> > corrupted fonts. It has an Intel 830M using the "intel" driver. It
> > starts out okay but grows worse every few minutes or so. It seems to
> > happen a few characters at a time. It's not just limited to fonts,
> > bitmaps seem to be affected too.
>
> Could that be https://bugzilla.redhat.com/show_bug.cgi?id=441665 ?

Hmm, possibly. I piled on there for now but I can open my own bug if
that's easier on people.

I was suspecting EXA. Did the default change? I switched it to XAA and
that seems to work for me, as a work-around. Still no OpenGL though...
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-29-2008, 05:57 AM
Callum Lerwick
 
Default Intel xorg driver bug

On Mon, 2008-04-28 at 12:35 +0200, Matej Cepl wrote:
> On Sun, 27 Apr 2008 19:19:36 -0500, Callum Lerwick scripst:
> >> http://lists.freedesktop.org/archives/xorg/2008-April/034940.html
>
> Just for the sake of bug triage -- could you please try again with Deja
> fonts? Both you and Peter seem to have some non-standard fonts. Nothing
> against, it should work anyway, but just to find out more about the nature
> of the bug.

Nope, in my case it's Deja. The font size may appear a bit small due to
being an old-ish laptop with a 91dpi screen. (I measured!) But it
affects all fonts, everywhere in all applications. And icons/images too.
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 10:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org