FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 04-25-2008, 04:12 PM
Lubomir Kundrak
 
Default preupgrade - what would it take to provide packages for unsupported fedora releases ?

On Sat, 2008-04-26 at 02:09 +1000, David Timms wrote:
> I thought I might try preupgrade out on Fedora Core 3:
> =====
> # rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm
> error: Failed dependencies:
> python(abi) = 2.5 is needed by preupgrade-0.9.2-1.fc8.noarch
> yum >= 3.2.8 is needed by preupgrade-0.9.2-1.fc8.noarch
> yum-metadata-parser is needed by preupgrade-0.9.2-1.fc8.noarch
>
> [root@f3 davidt]# rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm --nodeps
> Preparing... ########################################### [100%]
> 1reupgrade ########################################### [100%]

Try rebuilding it in mock. You will probably have to create the config
file yourself, you can base it on existing ones.

Also newer yum might be needed, but maybe it can be also built on fc3.

--
Lubomir Kundrak (Red Hat Security Response Team)

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-25-2008, 04:14 PM
seth vidal
 
Default preupgrade - what would it take to provide packages for unsupported fedora releases ?

On Sat, 2008-04-26 at 02:09 +1000, David Timms wrote:
> I thought I might try preupgrade out on Fedora Core 3:
> =====
> # rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm
> error: Failed dependencies:
> python(abi) = 2.5 is needed by preupgrade-0.9.2-1.fc8.noarch
> yum >= 3.2.8 is needed by preupgrade-0.9.2-1.fc8.noarch
> yum-metadata-parser is needed by preupgrade-0.9.2-1.fc8.noarch
>
> [root@f3 davidt]# rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm --nodeps
> Preparing... ########################################### [100%]
> 1reupgrade ########################################### [100%]
>
> [root@f3 davidt]# preupgrade
> Traceback (most recent call last):
> File "/usr/share/preupgrade/preupgrade-gtk.py", line 23, in ?
> import preupgrade
> ImportError: No module named preupgrade
>
> [root@f3 davidt]# rpm -q python yum yum-metadata-parser
> python-2.3.4-11
> yum-2.1.11-3
> package yum-metadata-parser is not installed
> =====
> Is there actually python 2.5 constructs used ?
no, but definitely python 2.4isms


> Could it be built for an earlier release like fc3 ?
no - that's python 2.3 and too much pain.


> This would have to circumvent the maintained distributions policy, but
> for good reason; weaning our upgrade adverse users off the no longer
> maintained old F2,3,4,5,6 releases.

We have to let them go sometime, now is good.

-sv


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 01:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org