FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 04-14-2008, 04:30 PM
Kevin Kofler
 
Default Broken deps ( rawhide report: 20080414 changes)

> evolution-brutus-1.1.28.7-2.fc8.i386 requires libcamel-1.2.so.10

The build which should fix this failed due to strict-aliasing warnings which
are being turned into errors with -Werror. Please rebuild
with -fno-strict-aliasing.

> fedora-ds-dsgw-1.1.0-1.fc9.i386 requires /etc/dirsrv/admin-serv/httpd.conf

This is an invalid explicit Requires, this must be removed or replaced with
something sane (maybe Requires: httpd).

> kazehakase-0.5.0-1.fc9.2.i386 requires gecko-libs = 0:1.8.1.10

Given that this still doesn't work with xulrunner, I'd suggest building only
the WebKit version in F9 and obsoleting the Gecko-based one. What does the
maintainer think?

> mediawiki-openid-0.7.0-5.noarch requires php-pear-Auth-OpenID
> mediawiki-openid-0.7.0-5.noarch requires php-pear-Services-Yadis

What's up with this one? If the deps can't be satisfied in time for F9, I'd
suggest blocking the package from f9-final, it can be pushed as an update
together with the dependencies once they are there.

> perl-clearsilver-0.10.4-5.fc8.i386 requires perl(:MODULE_COMPAT_5.8.8)

This failed to build because 2 of the files in the file list aren't actually
being installed:
| RPM build errors:
| File not found:
| /var/tmp/clearsilver-0.10.5-3.fc9-root-mockbuild/usr/bin/cs
| File not found:
| /var/tmp/clearsilver-0.10.5-3.fc9-root-mockbuild/usr/bin/cstest
As these are the 2 main executables of this package, this looks really broken
to me!

> util-vserver-build-0.30.214-2.fc8.i386 requires libbeecrypt.so.6

This one has been fixed by Alex Lancaster today.

Kevin Kofler

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-14-2008, 04:58 PM
Kevin Kofler
 
Default Broken deps ( rawhide report: 20080414 changes)

> > perl-clearsilver-0.10.4-5.fc8.i386 requires perl(:MODULE_COMPAT_5.8.8)
>
> This failed to build because 2 of the files in the file list aren't actually
> being installed:

I tracked this one down:
https://bugzilla.redhat.com/show_bug.cgi?id=434141#c4

Kevin Kofler

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-14-2008, 05:38 PM
"Jeffrey Ollie"
 
Default Broken deps ( rawhide report: 20080414 changes)

On Mon, Apr 14, 2008 at 11:58 AM, Kevin Kofler <kevin.kofler@chello.at> wrote:
> > > perl-clearsilver-0.10.4-5.fc8.i386 requires perl(:MODULE_COMPAT_5.8.8)
> >
> > This failed to build because 2 of the files in the file list aren't actually
> > being installed:
>
> I tracked this one down:
> https://bugzilla.redhat.com/show_bug.cgi?id=434141#c4

Thanks for the patch... this one has puzzled me for a while. Built a
new version:

http://koji.fedoraproject.org/koji/taskinfo?taskID=565495

Jeff

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 04-14-2008, 05:44 PM
Andrew Farris
 
Default Broken deps ( rawhide report: 20080414 changes)

Kevin Kofler wrote:

mediawiki-openid-0.7.0-5.noarch requires php-pear-Auth-OpenID
mediawiki-openid-0.7.0-5.noarch requires php-pear-Services-Yadis


What's up with this one? If the deps can't be satisfied in time for F9, I'd
suggest blocking the package from f9-final, it can be pushed as an update
together with the dependencies once they are there.


I've noticed that one in broken deps for many months now, it does seem like its
just not going to happen for f9?


--
Andrew Farris <lordmorgul@gmail.com> www.lordmorgul.net
gpg 0x8300BF29 fingerprint 071D FFE0 4CBC 13FC 7DEB 5BD5 5F89 8E1B 8300 BF29

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 10:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org