Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Development (http://www.linux-archive.org/fedora-development/)
-   -   PDF printouts with no top margin? (http://www.linux-archive.org/fedora-development/580899-pdf-printouts-no-top-margin.html)

Tomasz Torcz 09-27-2011 10:14 PM

PDF printouts with no top margin?
 
On Tue, Sep 27, 2011 at 04:40:00PM -0300, Horst H. von Brand wrote:
> I'm running Fedora 15 on x86_64, up to date, with JNovy's TeXlive (but that
> one doesn't seem to be at fault).
>
> Printing PDFs created by pdflatex (even oldish ones) on a HP LaserJet
> m1522nf MFP over the 'net gives me pages that start on flush top, any top
> margin setting via the geometry package has no visible efect. A very old
> PDF generated by OOo 1.1.0 in 2004 shows a similar lack of top margin when
> printed (an inch or so loped off the top). evince or xpdf show the PDF
> files with normal top margins.


Oh wow, and I thought my old printer started to load paper incorrectly.
I see the same symptom with HP LaserJet 6L. Printer is net shared from
F15. Documents are printed from F16 (PDFs from Evince) and Ubuntu 11.04
(documents from LibreOffice). Top margin is missing.

--
Tomasz Torcz Only gods can safely risk perfection,
xmpp: zdzichubg@chrome.pl it's a dangerous thing for a man. -- Alia

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

"Horst H. von Brand" 09-28-2011 12:01 AM

PDF printouts with no top margin?
 
Horst H. von Brand <vonbrand@inf.utfsm.cl> wrote:
> I'm running Fedora 15 on x86_64, up to date, with JNovy's TeXlive (but that
> one doesn't seem to be at fault).
>
> Printing PDFs created by pdflatex (even oldish ones) on a HP LaserJet
> m1522nf MFP over the 'net gives me pages that start on flush top, any top
> margin setting via the geometry package has no visible efect. A very old
> PDF generated by OOo 1.1.0 in 2004 shows a similar lack of top margin when
> printed (an inch or so loped off the top). evince or xpdf show the PDF
> files with normal top margins.
>
> A CUPS test page prints its black frame almost perfectly centered on the
> paper.
>
> cups-1.4.8-2.fc15.x86_64
> ghostscript-9.04-3.fc15.x86_64
> hplip-3.11.7-2.fc15.x86_64
>
> I'm at a loss on how to debug this further.

Came home and printed the same file that came out wron on my Epson Stylus
CX7700, connected via USB. There it printed fine.

Somebody asked if I printed via evince or lpr. Using xpdf the files look
fine, but print out wrong. Printing via lpr also gets them wrong.
--
Dr. Horst H. von Brand User #22616 counter.li.org
Departamento de Informatica Fono: +56 32 2654431
Universidad Tecnica Federico Santa Maria +56 32 2654239
Casilla 110-V, Valparaiso, Chile 2340000 Fax: +56 32 2797513

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Domingo Becker 09-28-2011 02:15 PM

PDF printouts with no top margin?
 
2011/9/27 Tomasz Torcz <tomek@pipebreaker.pl>:
> On Tue, Sep 27, 2011 at 04:40:00PM -0300, Horst H. von Brand wrote:
>> I'm running Fedora 15 on x86_64, up to date, with JNovy's TeXlive (but that
>> one doesn't seem to be at fault).
>>
>> Printing PDFs created by pdflatex (even oldish ones) on a HP LaserJet
>> m1522nf MFP over the 'net gives me pages that start on flush top, any top
>> margin setting via the geometry package has no visible efect. A very old
>> PDF generated by OOo 1.1.0 in 2004 shows a similar lack of top margin when
>> printed (an inch or so loped off the top). evince or xpdf show the PDF
>> files with normal top margins.
>
>
> *Oh wow, and I thought my old printer started to load paper incorrectly.
> I see the same symptom with HP LaserJet 6L. *Printer is net shared from
> F15. *Documents are printed from F16 (PDFs from Evince) and Ubuntu 11.04
> (documents from LibreOffice). *Top margin is missing.
>

Not only top margin, but whatever whitespace you put in the document
at the beginning.
I tried adding new lines in a writer document at the beginning and the
printer ignores them too.

I saw it in a F15 i686 with an HP LaserJet 1150 using hplip.
Then I took the printer to an F14 i686 and I've got the same results.
It is strange that from the F14 printing through the network to an F13
with HP LaserJet M1120 using hplip prints well the same document.

I'll comment in the bug.

Domingo Becker
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel


All times are GMT. The time now is 11:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.