Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Development (http://www.linux-archive.org/fedora-development/)
-   -   GDBM upgrade in F17 (http://www.linux-archive.org/fedora-development/578314-gdbm-upgrade-f17.html)

Petr Pisar 09-21-2011 10:59 AM

GDBM upgrade in F17
 
Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
in F17. Because rel-engs refused to provide dedicated build root, the
upgrade will be performed in F17 directly.

That means Perl, Pyhon and other default-build-root packages will
disable support for GDBM temporarily. So if your package needs GDBM
support in those languages, please wait until new GDMB and other
packages (Perl, Python and similar) get recompiled again against this
new GDBM.

-- Petr

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Nils Philippsen 09-21-2011 11:14 AM

GDBM upgrade in F17
 
On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
> in F17. Because rel-engs refused to provide dedicated build root, the
> upgrade will be performed in F17 directly.
>
> That means Perl, Pyhon and other default-build-root packages will
> disable support for GDBM temporarily. So if your package needs GDBM
> support in those languages, please wait until new GDMB and other
> packages (Perl, Python and similar) get recompiled again against this
> new GDBM.

Have you tried building gdbm, creating the buildroot in bodhi, then
untagging gdbm from f17 instead?

Nils
--
Nils Philippsen "Those who would give up Essential Liberty to purchase
Red Hat a little Temporary Safety, deserve neither Liberty
nils@redhat.com nor Safety." -- Benjamin Franklin, 1759
PGP fingerprint: C4A8 9474 5C4C ADE3 2B8F 656D 47D8 9B65 6951 3011

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Petr Pisar 09-21-2011 11:29 AM

GDBM upgrade in F17
 
On 2011-09-21, Nils Philippsen <nils@redhat.com> wrote:
> On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
>> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
>> in F17. Because rel-engs refused to provide dedicated build root, the
>> upgrade will be performed in F17 directly.
>>
>> That means Perl, Pyhon and other default-build-root packages will
>> disable support for GDBM temporarily. So if your package needs GDBM
>> support in those languages, please wait until new GDMB and other
>> packages (Perl, Python and similar) get recompiled again against this
>> new GDBM.
>
> Have you tried building gdbm, creating the buildroot in bodhi, then
> untagging gdbm from f17 instead?
>
Bodhi and F17?

-- Petr

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Nils Philippsen 09-21-2011 11:32 AM

GDBM upgrade in F17
 
On Wed, 2011-09-21 at 11:29 +0000, Petr Pisar wrote:
> On 2011-09-21, Nils Philippsen <nils@redhat.com> wrote:
> > On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
> >> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
> >> in F17. Because rel-engs refused to provide dedicated build root, the
> >> upgrade will be performed in F17 directly.
> >>
> >> That means Perl, Pyhon and other default-build-root packages will
> >> disable support for GDBM temporarily. So if your package needs GDBM
> >> support in those languages, please wait until new GDMB and other
> >> packages (Perl, Python and similar) get recompiled again against this
> >> new GDBM.
> >
> > Have you tried building gdbm, creating the buildroot in bodhi, then
> > untagging gdbm from f17 instead?
> >
> Bodhi and F17?

Why not, you're not trying to submit an update, are you ;-)? As of
buildroot overrides, bodhi isn't used solely for updates anymore (even
though the URL ends in /updates/). The buildroot override document[1]
doesn't mention that this would be limited to branches.

Nils

[1]: http://fedoraproject.org/wiki/Bodhi/BuildRootOverrides
--
Nils Philippsen "Those who would give up Essential Liberty to purchase
Red Hat a little Temporary Safety, deserve neither Liberty
nils@redhat.com nor Safety." -- Benjamin Franklin, 1759
PGP fingerprint: C4A8 9474 5C4C ADE3 2B8F 656D 47D8 9B65 6951 3011

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Honza Horak 09-21-2011 11:45 AM

GDBM upgrade in F17
 
On 09/21/2011 01:14 PM, Nils Philippsen wrote:
> On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
>> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
>> in F17. Because rel-engs refused to provide dedicated build root, the
>> upgrade will be performed in F17 directly.
>>
>> That means Perl, Pyhon and other default-build-root packages will
>> disable support for GDBM temporarily. So if your package needs GDBM
>> support in those languages, please wait until new GDMB and other
>> packages (Perl, Python and similar) get recompiled again against this
>> new GDBM.
>
> Have you tried building gdbm, creating the buildroot in bodhi, then
> untagging gdbm from f17 instead?
>
> Nils

I understand that buildroot override in bodhi works for f16 and lower
only, am I wrong? I wanted to create a new target to make it safe, but
after a discussion with rel-engs it appears to be too big hammer for
such a few of packages. A temporary perl built without gdbm seems to be
fine enough for this purpose.

Honza
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Vít Ondruch 09-21-2011 11:53 AM

GDBM upgrade in F17
 
Dne 21.9.2011 13:45, Honza Horak napsal(a):
> On 09/21/2011 01:14 PM, Nils Philippsen wrote:
>> On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
>>> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
>>> in F17. Because rel-engs refused to provide dedicated build root, the
>>> upgrade will be performed in F17 directly.
>>>
>>> That means Perl, Pyhon and other default-build-root packages will
>>> disable support for GDBM temporarily. So if your package needs GDBM
>>> support in those languages, please wait until new GDMB and other
>>> packages (Perl, Python and similar) get recompiled again against this
>>> new GDBM.
>> Have you tried building gdbm, creating the buildroot in bodhi, then
>> untagging gdbm from f17 instead?
>>
>> Nils
> I understand that buildroot override in bodhi works for f16 and lower
> only, am I wrong? I wanted to create a new target to make it safe, but
> after a discussion with rel-engs it appears to be too big hammer for
> such a few of packages. A temporary perl built without gdbm seems to be
> fine enough for this purpose.
>
> Honza

Its strange to me. There are concerns to have Rawhide usable but at the
end, if somebody wants to prevents problems using dedicated build root,
it is denied by Rel-Engs, because it is probably to much work. This is
disappointing.

Vit
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Petr Pisar 09-21-2011 01:58 PM

GDBM upgrade in F17
 
On 2011-09-21, Petr Pisar <ppisar@redhat.com> wrote:
>
> That means Perl, Pyhon and other default-build-root packages will
> disable support for GDBM temporarily. So if your package needs GDBM
> support in those languages, please wait until new GDMB and other
> packages (Perl, Python and similar) get recompiled again against this
> new GDBM.
>
State info: Because bug in glibc-2.14.90-9.x86_64
(https://bugzilla.redhat.com/show_bug.cgi?id=740235), perl cannot be
recompiled now, so you can still enjoy GDBM-featured Perl.

I will send another notification once pruned Perl reaches F17 build
root.

-- Petr

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Kevin Fenzi 09-21-2011 02:49 PM

GDBM upgrade in F17
 
On Wed, 21 Sep 2011 13:32:59 +0200
Nils Philippsen <nils@redhat.com> wrote:

> On Wed, 2011-09-21 at 11:29 +0000, Petr Pisar wrote:
> > On 2011-09-21, Nils Philippsen <nils@redhat.com> wrote:
> > > On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
> > >> Jan Horak (hhorak) is going to upgrade GDBM to version with new
> > >> SONAME in F17. Because rel-engs refused to provide dedicated
> > >> build root, the upgrade will be performed in F17 directly.
> > >>
> > >> That means Perl, Pyhon and other default-build-root packages will
> > >> disable support for GDBM temporarily. So if your package needs
> > >> GDBM support in those languages, please wait until new GDMB and
> > >> other packages (Perl, Python and similar) get recompiled again
> > >> against this new GDBM.
> > >
> > > Have you tried building gdbm, creating the buildroot in bodhi,
> > > then untagging gdbm from f17 instead?
> > >
> > Bodhi and F17?
>
> Why not, you're not trying to submit an update, are you ;-)? As of
> buildroot overrides, bodhi isn't used solely for updates anymore (even
> though the URL ends in /updates/). The buildroot override document[1]
> doesn't mention that this would be limited to branches.

It is. Bodhi doesn't operate on rawhide at all... and a buildroot
override makes no sense related to rawhide. When you build a package in
rawhide it's automatically added to the buildroot the next time it's
generated.

kevin
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

David Malcolm 09-21-2011 04:18 PM

GDBM upgrade in F17
 
On Wed, 2011-09-21 at 10:59 +0000, Petr Pisar wrote:
> Jan Horak (hhorak) is going to upgrade GDBM to version with new SONAME
> in F17. Because rel-engs refused to provide dedicated build root, the
> upgrade will be performed in F17 directly.
>
> That means Perl, Pyhon and other default-build-root packages will
> disable support for GDBM temporarily. So if your package needs GDBM
> support in those languages, please wait until new GDMB and other
> packages (Perl, Python and similar) get recompiled again against this
> new GDBM.

FWIW I added a "with_gdbm" boolean to the specfile for both python and
python3 and set it to 0, building them into rawhide as:
python-2.7.2-12.fc17 and python3-3.2.2-4.fc17 (fwiw, this was a week
ago, on 2011-09-13)

Let me know when the new gdbm is in the buildroot for f17, and we can
set those booleans to 1 and rebuild python/python3 (or some other python
maintainer/proven packager can do it).

Hope this is helpful
Dave

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Petr Pisar 09-29-2011 09:32 AM

GDBM upgrade in F17
 
On 2011-09-21, Petr Pisar <ppisar@redhat.com> wrote:
> On 2011-09-21, Petr Pisar <ppisar@redhat.com> wrote:
>>
>> That means Perl, Pyhon and other default-build-root packages will
>> disable support for GDBM temporarily. So if your package needs GDBM
>> support in those languages, please wait until new GDMB and other
>> packages (Perl, Python and similar) get recompiled again against this
>> new GDBM.
>>
> State info: Because bug in glibc-2.14.90-9.x86_64
> (https://bugzilla.redhat.com/show_bug.cgi?id=740235), perl cannot be
> recompiled now, so you can still enjoy GDBM-featured Perl.
>
Perl has been rebuilt _without_ GDBM in F17 as perl-5.14.1-190.fc17 and
it's available in build root now.

-- Petr

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel


All times are GMT. The time now is 03:00 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.