FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 09-09-2011, 04:40 PM
Kalev Lember
 
Default gnome-python2-gtkhtml2 and gnome-python2-gtkmozembed removed

Hello,

In order to make gnome-python2-extras build in F16+ and to clean up its
broken deps, I had to kill two of its subpackages.

- gnome-python2-gtkhtml2: needs gtkhtml2 to build, which is already
retired in F16+.
- gnome-python2-gtkmozembed: needs xulrunner's gtkmozembed support
which is disabled in F16+.

This will flag up the following packages in the Branched / rawhide
broken dep reports (they were broken before, just now showing up):

$ repoquery -q --whatrequires gnome-python2-gtkhtml2
gnochm-0:0.9.11-6.fc15.noarch
gscribble-0:0.1.2-1.fc16.noarch
pida-0:0.5.1-13.fc15.x86_64
solfege-0:3.20.1-1.fc16.x86_64
$ repoquery -q --whatrequires gnome-python2-gtkmozembed
awn-extras-applets-0:0.4.2-0.1.bzr1523.fc16.x86_64
awn-extras-applets-0:0.4.2-0.4.bzr1537.fc16.x86_64
pytrainer-0:1.7.2-2.fc15.noarch


--
Thanks,
Kalev
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 09-09-2011, 04:50 PM
Haïkel Guémar
 
Default gnome-python2-gtkhtml2 and gnome-python2-gtkmozembed removed

Le ven. 09 sept. 2011 18:40:34 CEST, Kalev Lember a écrit :
> Hello,
>
> In order to make gnome-python2-extras build in F16+ and to clean up its
> broken deps, I had to kill two of its subpackages.
>
> - gnome-python2-gtkhtml2: needs gtkhtml2 to build, which is already
> retired in F16+.
> - gnome-python2-gtkmozembed: needs xulrunner's gtkmozembed support
> which is disabled in F16+.
>
> This will flag up the following packages in the Branched / rawhide
> broken dep reports (they were broken before, just now showing up):
>
> $ repoquery -q --whatrequires gnome-python2-gtkhtml2
> gnochm-0:0.9.11-6.fc15.noarch
> gscribble-0:0.1.2-1.fc16.noarch
> pida-0:0.5.1-13.fc15.x86_64
> solfege-0:3.20.1-1.fc16.x86_64

Thank you Kalev for the heads-up.
I'm retiring gnochm since there's no reason to keep it around anymore,
upstream vanished for a long time.

As for gnochm users, i recommend either using xchm or chmsee,
kchmviewer-qt (non-kde variant) is also a good alternative.

H.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 09-10-2011, 09:17 AM
Christian Krause
 
Default gnome-python2-gtkhtml2 and gnome-python2-gtkmozembed removed

Hi,

On 09/09/2011 06:40 PM, Kalev Lember wrote:
> In order to make gnome-python2-extras build in F16+ and to clean up its
> broken deps, I had to kill two of its subpackages.
>
> - gnome-python2-gtkhtml2: needs gtkhtml2 to build, which is already
> retired in F16+.
> - gnome-python2-gtkmozembed: needs xulrunner's gtkmozembed support
> which is disabled in F16+.
>
> This will flag up the following packages in the Branched / rawhide
> broken dep reports (they were broken before, just now showing up):
>
> $ repoquery -q --whatrequires gnome-python2-gtkhtml2
[...]
> solfege-0:3.20.1-1.fc16.x86_64

Thanks for the heads up.

I have removed the superfluous requires for gnome-python2-gtkhtml2 in
solfege and built/pushed out new packages for rawhide and F16.

It looks like that upstream dropped the support for gtkhtml2 a while ago...

Best regards,
Christian
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 09-10-2011, 02:05 PM
Kalev Lember
 
Default gnome-python2-gtkhtml2 and gnome-python2-gtkmozembed removed

On 09/09/2011 07:50 PM, Haïkel Guémar wrote:
> Thank you Kalev for the heads-up.
> I'm retiring gnochm since there's no reason to keep it around anymore,
> upstream vanished for a long time.

Besides retiring the package in Bodhi, don't forget to also 'fedpkg
retire' the package (it removes all the files from git and adds a
dead.package instead) and file a ticket with rel-eng to get it blocked
from koji.

Without getting it blocked from koji it'll still show up in broken dep
reports.

http://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife

--
Thanks,
Kalev
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 09:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org