FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 07-05-2011, 12:42 PM
Neal Becker
 
Default Something wrong with atlas-3.8.3-18.fc14.src.rpm

0. F15 x86_64
1. yumdownloader --source atlas
2. rpmbuild -D 'enable_native_atlas 1' atlas.spec
error: line 75: Bad Requireflags: qualifiers: Requires(posttans):
chkconfig

How can it be that my system fails rpmbuild but fedora build is OK?

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 07-05-2011, 12:48 PM
Tom Hughes
 
Default Something wrong with atlas-3.8.3-18.fc14.src.rpm

On 05/07/11 13:42, Neal Becker wrote:
> 0. F15 x86_64
> 1. yumdownloader --source atlas
> 2. rpmbuild -D 'enable_native_atlas 1' atlas.spec
> error: line 75: Bad Requireflags: qualifiers: Requires(posttans):
> chkconfig
>
> How can it be that my system fails rpmbuild but fedora build is OK?

Because the Fedora build was done with an older version of rpmbuild that
didn't complain about the unrecognised qualifier on the Requires.

That complaint is a recent addition to rpmbuild.

No doubt it was meant to be Requires(posttrans) with an r.

Tom

--
Tom Hughes (tom@compton.nu)
http://compton.nu/
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 07-05-2011, 12:53 PM
Michael Schwendt
 
Default Something wrong with atlas-3.8.3-18.fc14.src.rpm

On Tue, 05 Jul 2011 08:42:57 -0400, NB (Neal) wrote:

> 0. F15 x86_64
> 1. yumdownloader --source atlas
> 2. rpmbuild -D 'enable_native_atlas 1' atlas.spec
> error: line 75: Bad Requireflags: qualifiers: Requires(posttans):
> chkconfig
>
> How can it be that my system fails rpmbuild but fedora build is OK?

It hasn't been built for F15, but for F14.

You could have found out some of this as an exercise, too:

* http://koji.fedoraproject.org/koji/packageinfo?packageID=1345
=> no fc15 build, last build inherited for F15 is from 2010-07-28

* Typo in the spec got fixed here in pkg git:
http://pkgs.fedoraproject.org/gitweb/?p=atlas.git;a=commitdiff;h=5d470356500fdfa68f1ea7 af0047046480e208c6
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 04:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org