FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 06-10-2011, 06:52 PM
Tom London
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 11:19 AM, Bruno Wolff III <bruno@wolff.to> wrote:
> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
> boot.) I am wondering if things are broken for everyone where I should
> probably just wait for updates and try again, or if I should get a picture
> of the traceback and file a bug?
> --

"Boots for me" on Thinkpad X200 with SELinux enforcing.

gdm-greeter screen is scrambled, but if I blindly enter
login/password, gnome comes up just fine.

tom
--
Tom London
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 06:54 PM
Jerry James
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 12:19 PM, Bruno Wolff III <bruno@wolff.to> wrote:
> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
> boot.) I am wondering if things are broken for everyone where I should
> probably just wait for updates and try again, or if I should get a picture
> of the traceback and file a bug?

I've been using today's x86_64 Rawhide kernel with no problems. I had
to attempt a boot 6 times before I finally got the i686 version off
the ground, though. Twice udev segfaulted during boot, and I got some
kind of lockup (perhaps what you are seeing) on the other 3 attempts.
But the 6th time, it worked great.

Unlike Tom's experience, the gdm login screen looked fine for me on
both x86_64 and i686.
--
Jerry James
http://www.jamezone.org/
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 07:08 PM
Tom London
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 11:54 AM, Jerry James <loganjerry@gmail.com> wrote:
> On Fri, Jun 10, 2011 at 12:19 PM, Bruno Wolff III <bruno@wolff.to> wrote:
>> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
>> boot.) I am wondering if things are broken for everyone where I should
>> probably just wait for updates and try again, or if I should get a picture
>> of the traceback and file a bug?
>
> I've been using today's x86_64 Rawhide kernel with no problems. *I had
> to attempt a boot 6 times before I finally got the i686 version off
> the ground, though. *Twice udev segfaulted during boot, and I got some
> kind of lockup (perhaps what you are seeing) on the other 3 attempts.
> But the 6th time, it worked great.
>
> Unlike Tom's experience, the gdm login screen looked fine for me on
> both x86_64 and i686.
> --
> Jerry James
> http://www.jamezone.org/

Didn't mention: exclusively using x86_64 version.

tom
--
Tom London
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 07:09 PM
"Clyde E. Kunkel"
 
Default Are 3.0 kernels working for anyone?

On 06/10/2011 02:19 PM, Bruno Wolff III wrote:
> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
> boot.) I am wondering if things are broken for everyone where I should
> probably just wait for updates and try again, or if I should get a picture
> of the traceback and file a bug?

Couldn't tell you about lockups since if root is on anything with raid
underlying, dracut drops to a shell. You are on the bz:

https://bugzilla.redhat.com/show_bug.cgi?id=710646

Hopefully, someone with apply the patch provided in the bz. I would if
I knew how and had access.


--
Regards,
OldFart

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 07:17 PM
"Richard W.M. Jones"
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 01:19:25PM -0500, Bruno Wolff III wrote:
> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
> boot.) I am wondering if things are broken for everyone where I should
> probably just wait for updates and try again, or if I should get a picture
> of the traceback and file a bug?

Works very well for me, but:

- Make sure you're running kernel-3.0-0.rc2.git0.2.fc16 with the
ftrace bug fixed (thanks Kyle).

- Make sure you upgrade module-init-tools *before* installing the 3.0
kernel.

- Make sure you've got the latest udev.

- I'm only running them under KVM, not on baremetal.

Rich.

--
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine. Supports Linux and Windows.
http://et.redhat.com/~rjones/virt-df/
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 08:04 PM
Bruno Wolff III
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 15:09:02 -0400,
"Clyde E. Kunkel" <clydekunkel7734@cox.net> wrote:
>
> Couldn't tell you about lockups since if root is on anything with raid
> underlying, dracut drops to a shell. You are on the bz:
>
> https://bugzilla.redhat.com/show_bug.cgi?id=710646
>
> Hopefully, someone with apply the patch provided in the bz. I would if
> I knew how and had access.

I did a local build with the patch, so I get past that point. The person
who made the patch requested commit access to mdadm, but it hasn't been
approved yet. The lvm2 fix is already in rawhide. mdadm really should
have a co-maintainer, this isn't the first time an important update
has been delayed because the owner wasn't available.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 08:06 PM
Bruno Wolff III
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 20:17:46 +0100,
"Richard W.M. Jones" <rjones@redhat.com> wrote:
>
> Works very well for me, but:
>
> - Make sure you're running kernel-3.0-0.rc2.git0.2.fc16 with the
> ftrace bug fixed (thanks Kyle).

Done.

> - Make sure you upgrade module-init-tools *before* installing the 3.0
> kernel.

Done.

> - Make sure you've got the latest udev.

Done.

Looks like I need to spend some time capturing the error and filling out
a bug report.

Thank you everyone, for the feedback.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-10-2011, 08:46 PM
Louis Lagendijk
 
Default Are 3.0 kernels working for anyone?

On Fri, 2011-06-10 at 15:06 -0500, Bruno Wolff III wrote:
> On Fri, Jun 10, 2011 at 20:17:46 +0100,
> "Richard W.M. Jones" <rjones@redhat.com> wrote:
> >
> > Works very well for me, but:
> >
> > - Make sure you're running kernel-3.0-0.rc2.git0.2.fc16 with the
> > ftrace bug fixed (thanks Kyle).
>
> Done.
>
> > - Make sure you upgrade module-init-tools *before* installing the 3.0
> > kernel.
>
> Done.
>
> > - Make sure you've got the latest udev.
>
> Done.
>
> Looks like I need to spend some time capturing the error and filling out
> a bug report.
>
> Thank you everyone, for the feedback.
I had problems too. I guess that is was something in the initramfs. I
ended up removing the 3.0 kernels and then re-install it (yum update).
That solved it for me

Louis

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-11-2011, 02:23 AM
John Dulaney
 
Default Are 3.0 kernels working for anyone?

It was for me until this morning.* Virtual box killed it (beware of vb).

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 06-11-2011, 01:14 PM
Matthew Miller
 
Default Are 3.0 kernels working for anyone?

On Fri, Jun 10, 2011 at 01:19:25PM -0500, Bruno Wolff III wrote:
> The 3.0 kernels are not working for me. (A cpu lockup is reporting during
> boot.) I am wondering if things are broken for everyone where I should
> probably just wait for updates and try again, or if I should get a picture
> of the traceback and file a bug?

Works for me, but crashes every night. (Automatic backups to a network drive
are happening at the time.) Haven't tried the latest
kernel-3.0-0.rc2.git0.2.fc16.x86_64 package though.

--
Matthew Miller <mattdm@mattdm.org>
Senior Systems Architect -- Instructional & Research Computing Services
Harvard School of Engineering & Applied Sciences
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 04:25 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org