FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 12-04-2010, 05:50 PM
Jonathan Dieter
 
Default F14 OOo deltarpms not being generated on releng2

I'm not sure if there's a better list for this to go to, but there seems
to be a problem generating deltarpms for F14 OOo (and a few other
packages) on releng2. Specifically, the updates->updates deltarpms
aren't being generated, while the GA->updates deltarpms are.

When I checked the mash.out log for the 101202.1757 push, there are
loads of error messages following the form of:
Error genDeltaRPM for openoffice.org-langpack-pt_PT: exitcode was 256 -
Reported Error: bad cpio archive

The problem is that this error normally comes up when one of the rpms is
corrupt, but manually running deltarpm between an rpm from the
101201.1909 push and the update from the 101202.1757 push results in a
proper drpm and no errors.

As far as I can see, this only affected the openoffice.org* and
autocorr* packages in the 101202 push, and the rest of the packages in
the push had all the proper deltarpms generated.

I'm not sure where to go from here. Any ideas on how to track this
down?

Jonathan
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 12-04-2010, 09:58 PM
Kevin Fenzi
 
Default F14 OOo deltarpms not being generated on releng2

On Sat, 04 Dec 2010 20:50:11 +0200
Jonathan Dieter <jdieter@lesbg.com> wrote:

...snip...

> As far as I can see, this only affected the openoffice.org* and
> autocorr* packages in the 101202 push, and the rest of the packages in
> the push had all the proper deltarpms generated.
>
> I'm not sure where to go from here. Any ideas on how to track this
> down?

FYI, I talked with Jonathan on irc and we added some debugging to the
deltarpms/createrepo code. Hopefully that will show us more where the
issue is so we can solve it.

> Jonathan

kevin
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 01-03-2011, 09:03 PM
Kevin Fenzi
 
Default F14 OOo deltarpms not being generated on releng2

On Sat, 4 Dec 2010 15:58:26 -0700
Kevin Fenzi <kevin@scrye.com> wrote:

> On Sat, 04 Dec 2010 20:50:11 +0200
> Jonathan Dieter <jdieter@lesbg.com> wrote:
>
> ...snip...
>
> > As far as I can see, this only affected the openoffice.org* and
> > autocorr* packages in the 101202 push, and the rest of the packages
> > in the push had all the proper deltarpms generated.
> >
> > I'm not sure where to go from here. Any ideas on how to track this
> > down?
>
> FYI, I talked with Jonathan on irc and we added some debugging to the
> deltarpms/createrepo code. Hopefully that will show us more where the
> issue is so we can solve it.

Just an update on this issue.

we added in debugging and finally tracked down the issue to a
createrepo bug. It was looking for anything ending in 'rpm' when
updating from an old repo, but '.drpm' ends that way, so sometimes it
was picking up the old drpms instead of the old rpm and failing to
generate a new drpm.

We have a fixed createrepo installed now, so hopefully from here on out
you will get deltas on everything that can generate them.

kevin
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 11:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org