FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 10-14-2010, 07:32 AM
"Paul F. Johnson"
 
Default Building mono-2.8 for 64 bit - possible solution to the problem

Hi,

> Hmm. I did a build with:
> mock -r fedora-rawhide-x86_64 mono-2.8-1.1.fc15.src.rpm
> on an f13/x86-64 host and it finished without complaint.

Removed the m32 hacks and submitted for a rebuild. Still dies in the
same place

> Perhaps something is indeed wonky in koji, or maybe some prerequisite just
> got broken and fixed since. You should try just resubmitting the package
> build.

It looks like glibc is missing TLS support. Do I submit a BZ against
glibc?

Paul

--
Vertraue mir, ich weiss, was ich mache...

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 10-14-2010, 07:36 AM
Roland McGrath
 
Default Building mono-2.8 for 64 bit - possible solution to the problem

> It looks like glibc is missing TLS support. Do I submit a BZ against
> glibc?

That is simply not the case and it's hard to see how you came to such
a conclusion.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 10-14-2010, 07:21 PM
"Paul F. Johnson"
 
Default Building mono-2.8 for 64 bit - possible solution to the problem

Hi,

> > It looks like glibc is missing TLS support. Do I submit a BZ against
> > glibc?
>
> That is simply not the case and it's hard to see how you came to such
> a conclusion.

Based on what I'm seeing from the error and getting from searching...

I've looked a bit deeper and there is nothing untoward being set in the
Makefile.in or Makefile.am files anywhere during the compilation - it's
picking things up in the configure script correctly and there is nothing
in the buildlog to say -m32 is being passed.

I'm going now to assume that CCASFLAGS on the x86_64 buildsys is
returning -m64 (is there a way to examine the root Makefiles generated
by the buildsys to ensure that this is happening?) and what does that
leave us with?

Help! I'm running around in circles!!!!

TTFN

Paul

--
Vertraue mir, ich weiss, was ich mache...

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 10-14-2010, 09:47 PM
"Paul F. Johnson"
 
Default Building mono-2.8 for 64 bit - possible solution to the problem

Hi,

Just an update...

I've looked and the x86 as well as x86_64 builds are failing on koji.
Something looks wrong in the rawhide koji buildsys...

TTFN

Paul

--
Vertraue mir, ich weiss, was ich mache...

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 10:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org