Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Development (http://www.linux-archive.org/fedora-development/)
-   -   FYI: rawhide now requires systemd to boot by default (http://www.linux-archive.org/fedora-development/428514-fyi-rawhide-now-requires-systemd-boot-default.html)

Jon Masters 09-17-2010 08:42 PM

FYI: rawhide now requires systemd to boot by default
 
On Fri, 2010-09-17 at 14:18 -0400, Bill Nottingham wrote:
> While upstart is still in the repo, the initscripts package now pulls
> in systemd and systemd-sysvinit.

Hey, thanks Bill.

Jon.


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Michał Piotrowski 09-17-2010 09:56 PM

FYI: rawhide now requires systemd to boot by default
 
Hi,

What are the current plans for SystemD in F14? Systemd is still listed
as F14 feature. Will it be developed in F14 or in external repo as
Rahul Sundaram suggested?

Regards,
Michal
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Bruno Wolff III 09-18-2010 05:10 PM

FYI: rawhide now requires systemd to boot by default
 
On Fri, Sep 17, 2010 at 23:56:54 +0200,
Michał Piotrowski <mkkp4x4@gmail.com> wrote:
> Hi,
>
> What are the current plans for SystemD in F14? Systemd is still listed
> as F14 feature. Will it be developed in F14 or in external repo as
> Rahul Sundaram suggested?

From what I have seen discussed, probably neither. Development will probably
proceed in F15 and the primary developers probably won't want to spend
extra time backporting stuff to F14. Someone could still volunteer to do
that, but I don't expect that to happen.

If you really want to help test it, staying on rawhide is probably the
place to do that.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Michał Piotrowski 09-18-2010 05:39 PM

FYI: rawhide now requires systemd to boot by default
 
W dniu 18 września 2010 19:10 użytkownik Bruno Wolff III
<bruno@wolff.to> napisał:
> On Fri, Sep 17, 2010 at 23:56:54 +0200,
> *Michał Piotrowski <mkkp4x4@gmail.com> wrote:
>> Hi,
>>
>> What are the current plans for SystemD in F14? Systemd is still listed
>> as F14 feature. Will it be developed in F14 or in external repo as
>> Rahul Sundaram suggested?
>
> From what I have seen discussed, probably neither. Development will probably
> proceed in F15 and the primary developers probably won't want to spend
> extra time backporting stuff to F14. Someone could still volunteer to do
> that, but I don't expect that to happen.
>
> If you really want to help test it, staying on rawhide is probably the
> place to do that.
>

I'm currently performing an update to rawhide on my laptop. I hope
that the system will be still useful for other things than systemd
testing :)

Regards,
Michal
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

"Clyde E. Kunkel" 09-18-2010 06:03 PM

FYI: rawhide now requires systemd to boot by default
 
On 09/17/2010 02:18 PM, Bill Nottingham wrote:
> While upstart is still in the repo, the initscripts package now pulls
> in systemd and systemd-sysvinit.
>
> Bill

from todays 201009218 rawhide update (bz'd on the yum site as #593):

sudo yum --enablerepo=mash --skip-broken update

.....

Updating for dependencies:

upstart x86_64 0.6.5-8.fc15 mash 149 k

Skipped (dependency problems):

initscripts x86_64 9.21-2.fc15 mash 951 k
systemd-sysvinit x86_64 10-3.fc15 mash 12 k
upstart-sysvinit x86_64 0.6.5-8.fc15 mash 15 k

Transaction Summary
================================================== ================================================== ============
Upgrade 1 Package(s)

Total size: 149 k Installed size: 498 k Is this ok [y/N]: y
Downloading Packages: Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve: upstart = 0.6.5-8.fc14 is needed
by (installed) upstart-sysvinit-0.6.5-8.fc14.x86_64
Please report this error in http://yum.baseurl.org/report

You could try running: rpm -Va --nofiles --nodigest
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Michał Piotrowski 09-19-2010 01:56 PM

FYI: rawhide now requires systemd to boot by default
 
2010/9/18 Clyde E. Kunkel <clydekunkel7734@cox.net>:
> Downloading Packages: Running rpm_check_debug
> ERROR with rpm_check_debug vs depsolve: upstart = 0.6.5-8.fc14 is needed
> by (installed) upstart-sysvinit-0.6.5-8.fc14.x86_64

The same problem here.

Here is a workaround
sudo rpm -e --nodeps upstart-sysvinit
sudo yum install systemd-sysvinit
sudo yum upgrade --skip-broken

Regards,
Michal
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Piscium 09-19-2010 03:53 PM

FYI: rawhide now requires systemd to boot by default
 
2010/9/19 Michał Piotrowski <mkkp4x4@gmail.com>:

> Here is a workaround
> sudo rpm -e --nodeps upstart-sysvinit
> sudo yum install systemd-sysvinit
> sudo yum upgrade --skip-broken
>

I installed rawhide yesterday. I solved this issue with a different
method: "yum shell". Basically you enter the commands you need to
install and remove packages, and finish with "run" and "exit". It
worked well for me. It is also possible to put the commands in a file.
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel


All times are GMT. The time now is 11:10 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.