Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Development (http://www.linux-archive.org/fedora-development/)
-   -   Problem with elipse in Fedora 13 (http://www.linux-archive.org/fedora-development/378701-problem-elipse-fedora-13-a.html)

Casimiro de Almeida Barreto 05-30-2010 01:31 PM

Problem with elipse in Fedora 13
 
Hello,



I've got the following problem with eclipse after update to F13: upon
launch it freezes at initial banner & uses about 80% of CPU time.



Console messages are:



[casimiro@localhost 155965261]$ eclipse&

[1] 24191

[casimiro@localhost 155965261]$ CompilerOracle: exclude
org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith

CompilerOracle: exclude
org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>

CompilerOracle: exclude
org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate

CompilerOracle: exclude
org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding

CompilerOracle: exclude
org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile

CompilerOracle: exclude
org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles



Here is the result of 'top' command:



top - 10:23:07 up 1 day, 20:28,* 8 users,* load average: 1.81,
1.66, 1.47

Tasks: 198 total,** 1 running, 197 sleeping,** 0 stopped,** 0 zombie

Cpu(s): 15.2%us,* 6.4%sy, 42.9%ni, 34.2%id,* 0.8%wa,* 0.3%hi,* 0.2%si,*
0.0%st

Mem:** 2061936k total,* 1997344k used,*** 64592k free,** 194724k buffers

Swap:* 4192276k total,*** 34440k used,* 4157836k free,** 836452k cached



* PID USER***** PR* NI* VIRT* RES* SHR S %CPU %MEM*** TIME+* COMMAND

24192 casimiro* 20** 0* 848m 126m* 12m S 95.2* 6.3* 10:16.65
eclipse************************

*8593 casimiro* 20** 0* 895m* 86m* 20m S 26.6* 4.3* 10:11.62
thunderbird-bin*******************************************

*5175 casimiro* 20** 0* 254m 174m* 12m S 15.2* 8.7 384:49.05
opera************************

24523 casimiro* 20** 0* 2692 1076* 776 R* 3.8* 0.1** 0:00.03 top

*4158 root***** 20** 0* 140m* 73m 4596 S* 1.9* 3.7 106:55.35 X****

*4410 casimiro* 20** 0* 318m* 41m* 13m S* 1.9* 2.1* 13:03.33
plasma-desktop

25908 casimiro** 9 -11* 164m 3840 2824 S* 1.9* 0.2* 28:58.92 pulseaudio

25961 casimiro* 20** 0* 895m 126m* 12m S* 1.9* 6.3* 39:05.34 firefox





And those are the installed eclipse packages:



[root@localhost Documentos]# rpm -qa | grep eclipse | sort

eclipse-anyedit-2.2.0-2.fc12.noarch

eclipse-birt-2.5.2-1.fc13.noarch

eclipse-callgraph-0.4.0-1.fc13.i686

eclipse-cdt-6.0.2-4.fc13.i686

eclipse-cdt-parsers-6.0.2-4.fc13.i686

eclipse-cdt-sdk-6.0.2-4.fc13.i686

eclipse-changelog-2.6.7-3.fc12.i686

eclipse-checkstyle-4.0.1-14.fc12.noarch

eclipse-cmakeed-1.1.5-1.fc13.noarch

eclipse-collabnet-merge-2.0.0-1.fc13.noarch

eclipse-demos-0.0.1-4.fc12.noarch

eclipse-dltk-1.0.2-1.fc13.noarch

eclipse-dltk-itcl-1.0.2-1.fc13.noarch

eclipse-dltk-mylyn-1.0.2-1.fc13.noarch

eclipse-dltk-rse-1.0.2-1.fc13.noarch

eclipse-dltk-ruby-1.0.2-1.fc13.noarch

eclipse-dltk-sdk-1.0.2-1.fc13.noarch

eclipse-dltk-tcl-1.0.2-1.fc13.noarch

eclipse-dltk-xotcl-1.0.2-1.fc13.noarch

eclipse-dtp-1.7.2-1.fc13.noarch

eclipse-eclemma-1.4.2-1.fc12.noarch

eclipse-eclox-0.8.0-4.20090616svn.fc13.noarch

eclipse-egit-0.7.1-2.fc13.noarch

eclipse-emf-2.5.0-4.fc12.noarch

eclipse-emf-examples-2.5.0-4.fc12.noarch

eclipse-emf-query-1.3.0-2.fc13.noarch

eclipse-emf-sdk-2.5.0-4.fc12.noarch

eclipse-emf-transaction-1.3.1-2.fc13.noarch

eclipse-emf-validation-1.3.1-2.fc13.noarch

eclipse-emf-xsd-2.5.0-4.fc12.noarch

eclipse-emf-xsd-sdk-2.5.0-4.fc12.noarch

eclipse-epic-0.6.35-2.fc12.noarch

eclipse-findbugs-1.3.9-2.fc13.noarch

eclipse-findbugs-contrib-4.2.0-1.fc13.noarch

eclipse-gef-3.5.2-1.fc13.noarch

eclipse-gef-examples-3.5.2-1.fc13.noarch

eclipse-gef-sdk-3.5.2-1.fc13.noarch

eclipse-jdt-3.5.2-1.fc13.i686

eclipse-jgit-0.7.1-1.fc13.noarch

eclipse-linuxprofilingframework-0.5.0-2.fc13.i686

eclipse-m2m-qvtoml-2.0.1-1.fc13.noarch

eclipse-manpage-0.0.1-0.svn24060.1.fc13.noarch

eclipse-mdt-ocl-1.3.0-2.fc13.noarch

eclipse-mdt-uml2-3.0.1-2.fc13.noarch

eclipse-moreunit-1.3.3-2.fc12.noarch

eclipse-mylyn-3.3.2-2.fc13.noarch

eclipse-mylyn-cdt-3.3.2-2.fc13.noarch

eclipse-mylyn-java-3.3.2-2.fc13.noarch

eclipse-mylyn-pde-3.3.2-2.fc13.noarch

eclipse-mylyn-trac-3.3.2-2.fc13.noarch

eclipse-mylyn-webtasks-3.3.2-2.fc13.noarch

eclipse-mylyn-wikitext-3.3.2-2.fc13.noarch

eclipse-nls-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-ar-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-bg-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-cs-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-da-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-de-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-el-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-en_AA-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-en_AU-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-es-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-et-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-fi-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-fr-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-he-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-hi-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-hu-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-it-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-ja-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-ko-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-mn-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-nl-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-no-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-pl-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-pt-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-pt_BR-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-ro-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-ru-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-sv-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-tr-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-uk-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-zh-3.5.0.v20090620043401-2.fc12.noarch

eclipse-nls-zh_TW-3.5.0.v20090620043401-2.fc12.noarch

eclipse-oprofile-0.4.0-1.fc13.i686

eclipse-pde-3.5.2-1.fc13.i686

eclipse-photran-5.0.0-0.4.200910081739.fc13.noarch

eclipse-photran-intel-5.0.0-0.4.200910081739.fc13.noarch

eclipse-photran-xlf-5.0.0-0.4.200910081739.fc13.noarch

eclipse-phpeclipse-1.2.3-1.fc13.noarch

eclipse-platform-3.5.2-1.fc13.i686

eclipse-pydev-1.5.5-1.fc13.i686

eclipse-pydev-mylyn-1.5.5-1.fc13.i686

eclipse-quickrex-3.5.0-12.fc12.noarch

eclipse-rcp-3.5.2-1.fc13.i686

eclipse-rpm-editor-0.5.0-1.fc13.i686

eclipse-rpmstubby-0.5.0-1.fc13.noarch

eclipse-rse-3.1.1-3.fc13.noarch

eclipse-setools-3.3.5.1-3.fc13.i686

eclipse-shelled-2.0.0-0.M2.1.fc13.noarch

eclipse-slice2java-3.3.1.20091005-1.fc13.noarch

eclipse-slide-1.3.14-1.fc13.noarch

eclipse-subclipse-1.6.8-1.fc13.noarch

eclipse-subclipse-graph-1.6.8-1.fc13.noarch

eclipse-svnkit-1.3.2-2.fc13.noarch

eclipse-swt-3.5.2-1.fc13.i686

eclipse-systemtapgui-1.0-8.fc12.noarch

eclipse-testframework-3.5.0-3.fc12.noarch

eclipse-texlipse-1.3.0-2.20090829cvs.fc12.noarch

eclipse-valgrind-0.4.1-1.fc13.i686

eclipse-veditor-0.6.3-4.fc12.noarch

icu4j-eclipse-4.0.1-5.fc13.i686

tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch



Any help appreciated !!!



Best regards,



Casimiro Barreto



--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Mat Booth 05-30-2010 10:20 PM

Problem with elipse in Fedora 13
 
On 30 May 2010 14:31, Casimiro de Almeida Barreto
<casimiro.barreto@gmail.com> wrote:
>
> Any help appreciated !!!
>
> Best regards,
>

Have you tried the usual "eclipse -clean" and/or removing your
~/.eclipse folder?

In fact, does it even get to the point where it asks you what
workspace you want to open?

You might try to narrow the problem area down by removing some
plug-ins. Do you really need *all* those installed? :-o

Regards,
Mat

--
Mat Booth
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Rakesh Pandit 05-31-2010 03:37 AM

Problem with elipse in Fedora 13
 
On 30 May 2010 19:01, Casimiro de Almeida Barreto wrote:
> Hello,
>
> I've got the following problem with eclipse after update to F13: upon launch
> it freezes at initial banner & uses about 80% of CPU time.
>
> Console messages are:

In case you haven't created a bug report against package component,
please do it.

Also report the messages you get from following command:
eclipse -consolelog -debug -data /tmp/testBug

Also run commands listed at:
http://fedoraproject.org/wiki/DebuggingEclipseProblems
and mention them in your report.

Thanks,

--
Rakesh Pandit
https://fedoraproject.org/wiki/User:Rakesh
freedom, friends, features, first
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Andrew Overholt 05-31-2010 12:33 PM

Problem with elipse in Fedora 13
 
Hi Casimiro,

> I've got the following problem with eclipse after update to F13: upon launch it
> freezes at initial banner & uses about 80% of CPU time.

Please file a bug at bugzilla.redhat.com and we can work through it there.

Thanks,

Andrew
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Casimiro de Almeida Barreto 05-31-2010 02:08 PM

Problem with elipse in Fedora 13
 
Em 31-05-2010 09:33, Andrew Overholt escreveu:

Hi Casimiro,



I've got the following problem with eclipse after update to F13: upon launch it
freezes at initial banner & uses about 80% of CPU time.



Please file a bug at bugzilla.redhat.com and we can work through it there.

Thanks,

Andrew


Hello,



Apparently I have the problem solved. First of all, the listing had all
that modules because when eclipse refused to start I assumed something
was lacking and behave just like a n00b (yum install "eclipse-*" kind
of thing). So, it happened prior of having all those modules installed.
Anyways, what I did was to uninstall eclipse & everything related,
to remove .eclipse and workspace (inherited from F12), re-install
eclipse and bring back old content. And it worked.



Apparently it was a problem with what was before & what was
updated. As error cannot be reproduced there's little sense in filling
a bug.



BTW, since I upgraded to F13 (from F12) I've had some abrtd anoying
error messages and they're related to access to USB . It has been
reported already but I'd like to know if someone else has had the same
problem. Transcript follows:



------------[ cut here ]------------

WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x202/0x30e()

Hardware name: System Product Name

Modules linked in: cbc cryptoloop vfat fat usb_storage tcp_lp fuse
ipt_MASQUERADE iptable_nat nf_nat bridge stp llc sunrpc p4_clockmod
xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables
ipv6 uinput nvidia(P) snd_intel8x0 snd_ac97_codec ac97_bus snd_seq ttm
snd_seq_device drm_kms_helper gspca_ov519 snd_pcm drm gspca_main ppdev
i2c_algo_bit parport_pc videodev snd_timer parport sis900 video
v4l1_compat mii output snd joydev i2c_core soundcore snd_page_alloc
microcode aes_i586 aes_generic xts gf128mul dm_crypt sata_sis
ata_generic pata_acpi pata_sis [last unloaded: nouveau]

Pid: 4402, comm: flush-253:2 Tainted: P******* W*
2.6.33.4-95.fc13.i686.PAE #1

Call Trace:

[<c043d629>] warn_slowpath_common+0x65/0x7c

[<c04e6dd9>] ? writeback_inodes_wb+0x202/0x30e

[<c043d64d>] warn_slowpath_null+0xd/0x10

[<c04e6dd9>] writeback_inodes_wb+0x202/0x30e

[<c04e6fe8>] wb_writeback+0x103/0x162

[<c0482e6d>] ? call_rcu+0x8/0xa

[<c04e70c4>] ? wb_clear_pending+0x6a/0x6f

[<c04e712e>] wb_do_writeback+0x65/0x128

[<c04e7219>] bdi_writeback_task+0x28/0x84

[<c04b0aed>] ? bdi_start_fn+0x0/0xa3

[<c04b0b42>] bdi_start_fn+0x55/0xa3

[<c04b0aed>] ? bdi_start_fn+0x0/0xa3

[<c045271f>] kthread+0x5f/0x64

[<c04526c0>] ? kthread+0x0/0x64

[<c0408dfe>] kernel_thread_helper+0x6/0x10



Also, upgrading from F12 to F13 messed with the network "connections
manager" applet both in KDE and GNOME... took a while to have it back.



Best regards,



Casimiro Barreto



PS: F13 looks really fine. Pitty kmod-nvidia-173xx -PAE still not
available.



--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

shmuel siegel 05-31-2010 02:54 PM

Problem with elipse in Fedora 13
 
On 5/31/2010 5:08 PM, Casimiro de Almeida Barreto wrote:



Em 31-05-2010 09:33, Andrew Overholt escreveu:

Hi Casimiro,



I've got the following problem with eclipse after update to F13: upon launch it
freezes at initial banner & uses about 80% of CPU time.


Please file a bug at bugzilla.redhat.com and we can work through it there.

Thanks,

Andrew


Hello,



Apparently I have the problem solved. First of all, the listing had all
that modules because when eclipse refused to start I assumed something
was lacking and behave just like a n00b (yum install "eclipse-*" kind
of thing). So, it happened prior of having all those modules installed.
Anyways, what I did was to uninstall eclipse & everything related,
to remove .eclipse and workspace (inherited from F12), re-install
eclipse and bring back old content. And it worked.



Apparently it was a problem with what was before & what was
updated. As error cannot be reproduced there's little sense in filling
a bug.


yes there is a reason to file the bug report. The upgrade should have
been seamless. Something like this has happened to many people on many
eclipse updates. Maybe there is something in your scenario that would
give the maintainer a clue. At worst, the bug will be closed as
insufficient information.



--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Michal Schmidt 05-31-2010 03:06 PM

Problem with elipse in Fedora 13
 
On Mon, 31 May 2010 11:08:53 -0300 Casimiro de Almeida Barreto wrote:
> BTW, since I upgraded to F13 (from F12) I've had some abrtd anoying
> error messages and they're related to access to USB . It has been
> reported already but I'd like to know if someone else has had the same
> problem. Transcript follows:
>
> ------------[ cut here ]------------
> WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x202/0x30e()
> [...]

Known bug, should be fixed in the kernel in updates-testing. Give it a
try.
https://bugzilla.redhat.com/show_bug.cgi?id=593669
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel


All times are GMT. The time now is 07:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.