FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 04-08-2010, 10:20 PM
Christoph Wickert
 
Default PolicyKit-authentication-agents in Fedora

Am Donnerstag, den 08.04.2010, 17:56 -0400 schrieb Matthias Clasen:

> First of all, the fear of GConf has really grown to quite irrational
> levels. Just look at
> http://wiki.lxde.org/en/Google_Summer_of_Code_2010#Fork_GVFS_to_provide_a_ more_lightweight.2C_stripped_down_version_without_ Gnome_dependency

It's not only GConf but also other things like gnome-keyring, libsoup,
or gnome-disk-utility with it's dependeny on nautilus and many more
things. The latter could be avoided with smarter packaging however.

As long as GNOME developers hardcode things like gnome-terminal or
gnome-mount in lowlevel stuff like GIO, there will always be people who
want to fork from that.

> Anyway, studying rpm -q --requires polkit-gnome, I have a really hard
> time coming up with anything that could be objectionable, bloated or
> unnecessary:

[snipped]

> Just what do you want to strip out here ?

Previous versions relied on GConf2 and I already asked if you or David
have any plans to bring this dependency back.

Regards,
Christoph

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-08-2010, 10:38 PM
Adam Williamson
 
Default PolicyKit-authentication-agents in Fedora

On Thu, 2010-04-08 at 17:56 -0400, Matthias Clasen wrote:

> Just what do you want to strip out here ?

Nothing; Christoph indicated his worry was not about current deps but
future ones, and my suggestion was just that the agent make an explicit
commitment to restricting itself to GTK+-level, not GNOME-level, deps
for the foreseeable future, so other desktops could choose it without
fear its deps may grow.
--
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-08-2010, 11:05 PM
Tony Nelson
 
Default PolicyKit-authentication-agents in Fedora

On 10-04-08 14:13:01, Christoph Wickert wrote:
> Am Donnerstag, den 08.04.2010, 13:37 -0400 schrieb Bill Nottingham:
> > Christoph Wickert (christoph.wickert@googlemail.com) said:
...
> > > 3. lxpolkit will be pulled in anyway due to the shortest
> > > name.
> >
> > That's not a useful decision rationale.
>
> I never said it is a useful decision rationale, it's something we
> cannot avoid. I agree it's not useful, but please address your
> complainants to the yum developers.
...

Would it work to change the name to "polkit-lxpolkit" and have it
Provide lxpolkit?

--
__________________________________________________ __________________
TonyN.:' <mailto:tonynelson@georgeanelson.com>
' <http://www.georgeanelson.com/>
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-08-2010, 11:53 PM
Christoph Wickert
 
Default PolicyKit-authentication-agents in Fedora

Am Donnerstag, den 08.04.2010, 19:05 -0400 schrieb Tony Nelson:
> On 10-04-08 14:13:01, Christoph Wickert wrote:

[snipped]

> > I never said it is a useful decision rationale, it's something we
> > cannot avoid. I agree it's not useful, but please address your
> > complainants to the yum developers.
> ...
>
> Would it work to change the name to "polkit-lxpolkit" and have it
> Provide lxpolkit?

Then polkit-kde would win and it has even more deps.

Not sure if we should change the name from what upstream uses. IMO first
of all yum's depsolver should be enhanced. Matthias already made an
important point here.

Regards,
Christoph

P.S. /me wonders what would happen if we had polkit-gtk and polkit-kde
with the same provides and the same length of the name..

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 12:01 AM
Jesse Keating
 
Default PolicyKit-authentication-agents in Fedora

On Fri, 2010-04-09 at 01:53 +0200, Christoph Wickert wrote:
> Am Donnerstag, den 08.04.2010, 19:05 -0400 schrieb Tony Nelson:
> > On 10-04-08 14:13:01, Christoph Wickert wrote:
>
> [snipped]
>
> > > I never said it is a useful decision rationale, it's something we
> > > cannot avoid. I agree it's not useful, but please address your
> > > complainants to the yum developers.
> > ...
> >
> > Would it work to change the name to "polkit-lxpolkit" and have it
> > Provide lxpolkit?
>
> Then polkit-kde would win and it has even more deps.
>
> Not sure if we should change the name from what upstream uses. IMO first
> of all yum's depsolver should be enhanced. Matthias already made an
> important point here.
>
> Regards,
> Christoph
>
> P.S. /me wonders what would happen if we had polkit-gtk and polkit-kde
> with the same provides and the same length of the name..
>

Part of the solution here is to not rely entirely on yum depsolving, and
instead add explicitly which polkit you want in the comps group, so that
a provider is already selected. Yum won't select an additional one.
This is what we should do for critpath as well, mark the gnome policy
kit explicitly as part of the critpath.

--
Jesse Keating
Fedora -- Freedom≤ is a feature!
identi.ca: http://identi.ca/jkeating
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 12:27 AM
Christoph Wickert
 
Default PolicyKit-authentication-agents in Fedora

Am Donnerstag, den 08.04.2010, 17:01 -0700 schrieb Jesse Keating:

> Part of the solution here is to not rely entirely on yum depsolving, and
> instead add explicitly which polkit you want in the comps group, so that
> a provider is already selected.

Yes, I already wrote that in my very first mail. Additionally one core
component of each desktop (e.g. gnome-session, kdebase-workspace,
xfce4-session and lxsession) should also explicitly require the agent

> This is what we should do for critpath as well, mark the gnome policy
> kit explicitly as part of the critpath.

+1

Regards,
Christoph

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 01:05 AM
Matthias Clasen
 
Default PolicyKit-authentication-agents in Fedora

On Thu, 2010-04-08 at 15:38 -0700, Adam Williamson wrote:
> On Thu, 2010-04-08 at 17:56 -0400, Matthias Clasen wrote:
>
> > Just what do you want to strip out here ?
>
> Nothing; Christoph indicated his worry was not about current deps but
> future ones, and my suggestion was just that the agent make an explicit
> commitment to restricting itself to GTK+-level, not GNOME-level, deps
> for the foreseeable future, so other desktops could choose it without
> fear its deps may grow.

I don't think that is reasonable at all. Dependencies are not added just
because we enjoy bloating our stack, but because they add functionality
that we deem useful.

Fear of future dependencies is a crazy reason to preemptively
reimplement something. If and when polkit-gnome grows a dependency that
you consider unacceptable, that is the right time to voice that concern,
and, in the worst case, consider forking off your own implementation.


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 01:07 AM
"Dariusz J. Garbowski"
 
Default PolicyKit-authentication-agents in Fedora

On 08/04/10 05:53 PM, Christoph Wickert wrote:
> Am Donnerstag, den 08.04.2010, 19:05 -0400 schrieb Tony Nelson:
>> On 10-04-08 14:13:01, Christoph Wickert wrote:
>
> [snipped]
>
>>> I never said it is a useful decision rationale, it's something we
>>> cannot avoid. I agree it's not useful, but please address your
>>> complainants to the yum developers.
>> ...
>>
>> Would it work to change the name to "polkit-lxpolkit" and have it
>> Provide lxpolkit?
>
> Then polkit-kde would win and it has even more deps.
>

polkit-lx then? ;-)


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 08:40 AM
Jaroslav Reznik
 
Default PolicyKit-authentication-agents in Fedora

On Friday 09 April 2010 02:27:59 Christoph Wickert wrote:
> Am Donnerstag, den 08.04.2010, 17:01 -0700 schrieb Jesse Keating:
> > Part of the solution here is to not rely entirely on yum depsolving, and
> > instead add explicitly which polkit you want in the comps group, so that
> > a provider is already selected.
>
> Yes, I already wrote that in my very first mail. Additionally one core
> component of each desktop (e.g. gnome-session, kdebase-workspace,
> xfce4-session and lxsession) should also explicitly require the agent

We explicitly require polkit-kde from F-12 in combination with polkit-1 (in
kdebase-workspace). F-11 still require PolicyKit-authentication-agent.

Library/desktop purist, don't read it : For non Gnome/KDE environments it
could be nice to have something less bloated but first criteria should be
quality of implementation and that's where -gnome one wins (I don't know how
mature is lxde one) - it's developed by polkit developers. We are on slip
while trying to catch current development.

Jaroslav

> > This is what we should do for critpath as well, mark the gnome policy
> > kit explicitly as part of the critpath.
>
> +1
>
> Regards,
> Christoph

--
Jaroslav Ňėezn√*k <jreznik@redhat.com>
Software Engineer - Base Operating Systems Brno

Office: +420 532 294 275
Mobile: +420 602 797 774
Red Hat, Inc. http://cz.redhat.com/
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 04-09-2010, 11:38 AM
Muayyad AlSadi
 
Default PolicyKit-authentication-agents in Fedora

> It's not only GConf but also other things like gnome-keyring, **libsoup**,

sorry for this off-topic,
is libsoup a light gtk library, or a deeply integrated gnome library
I'm asking this because webkitgtk depends on it
rpm -qR webkitgtk | grep libsoup
libsoup-2.4.so.1
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 06:49 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org