FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 03-25-2010, 02:19 PM
Jerry James
 
Default Comaintainers or maintainers sought

I changed jobs about a year ago and, as a result, no longer use a
number of packages that I maintain. (No more Java programming for me;
I'm a C coder now, with a little bit of Common Lisp thrown in just to
keep things interesting.) It would be good to have somebody who
actually uses these packages either maintain or comaintain them. I
won't orphan them if nobody is interested; I'll do my best to keep
maintaining them.

If you are interested in comaintaining, just apply for permission in
pkgdb. If you would like to maintain, let me know which packages and
I'll orphan them so you can pick them up. In that case, also let me
know if you want me to stay on as comaintainer. (I'm happy to answer
questions even if I don't comaintain.)

1. Findbugs packages: new releases about every 4-5 months. We're in a long
dry spell now leading up to a massively revamped 2.0.

eclipse-findbugs
findbugs
findbugs-bcel
findbugs-contrib (actually a separate project)
jFormatString (no activity since initial October 2008 release)
jcip-annotations (almost no activity since 2006)
jsr-305

Also, it would be good to package
http://mojo.codehaus.org/findbugs-maven-plugin/.

2. PMD packages: new releases about every 1-2 months. We're in a long dry
spell now leading up to a massively revamped 5.0.

emacs-common-pmd (upstream appears dead)
pmd

Also, it would be good to package more of these:
http://pmd.sourceforge.net/integrations.html (the maven2 plugin is already
packaged, just not owned by me)

3. Other packages

idw-gpl: this was originally needed by findbugs, but isn't anymore.
Repoquery says that nothing is using it, so I should probably
orphan this package.
latexmk: I don't use LaTeX anymore. This was my first package (*sniff*).
perl-Text-Aspell: last new version was released in Sep 2007. This is
required by acheck, moodle, perl-Text-SpellChecker, and xinha.

Thanks,
--
Jerry James
http://www.jamezone.org/
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 03-25-2010, 09:20 PM
Richard Fearn
 
Default Comaintainers or maintainers sought

Hi,

> I changed jobs about a year ago and, as a result, no longer use a
> number of packages that I maintain.

> * eclipse-findbugs
> * findbugs
> * findbugs-bcel
> * findbugs-contrib (actually a separate project)
> * jFormatString (no activity since initial October 2008 release)
> * jcip-annotations (almost no activity since 2006)
> * jsr-305

I do use FindBugs, so I'd be happy to take over as maintainer of these seven.

Regards

Rich
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 05:56 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org