Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Development (http://www.linux-archive.org/fedora-development/)
-   -   Help needed: patching EMBOSS to use system pcre, expat and zlib (http://www.linux-archive.org/fedora-development/331393-help-needed-patching-emboss-use-system-pcre-expat-zlib.html)

Julian Sikorski 02-24-2010 07:28 PM

Help needed: patching EMBOSS to use system pcre, expat and zlib
 
Hello,

EMBOSS 6.2.0 bundles zlib, expat and pcre. In the previous version, I
got help from a fellow packager to patch the pcre out, but that patch no
longer works. Thus, I'd like to ask for help in solving this problem,
which is unfortunately beyond my skills.
Ideally, I'd gladly accept a co-maintainer for this bioinformatics suite.
I have built the package with bundled libs for devel for the time being,
so that potential helpers have access to the latest spec file.

Regards,
Julian

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

"Chen Lei" 02-25-2010 03:18 AM

Help needed: patching EMBOSS to use system pcre, expat and zlib
 
Title: 错误:您所请求的网址(URL)*法获
Hi Julian,
I think you should first confirm if the bundled zlib,*expat*and*pcre was heavily changed compared to the system-wide libs. If they are heavily changed, you maybe need use bundled version. otherwise it must be patched to avoid using bundled libs.

在2010-02-25*04:28:33,"Julian*Sikorski"*<belegdol@gmail .com>*写道:
>Hello,
>
>EMBOSS*6.2.0*bundles*zlib,*expat*and*pcre. *In*the*previous*version,*I
>got*help*from*a*fellow*packager*to*patch* the*pcre*out,*but*that*patch*no
>longer*works.*Thus,*I'd*like*to*ask*for*h elp*in*solving*this*problem,
>which*is*unfortunately*beyond*my*skills.
>Ideally,*I'd*gladly*accept*a*co-maintainer*for*this*bioinformatics*suite.
>I*have*built*the*package*with*bundled*libs *for*devel*for*the*time*being,
>so*that*potential*helpers*have*access*to*t he*latest*spec*file.
>
>Regards,
>Julian
>
>--*
>devel*mailing*list
>devel@lists.fedoraproject.org
>https://admin.fedoraproject.org/mailman/listinfo/devel




错误
您所请求的网址(URL)*法获取



当尝试读取以下网址(URL)时:
http://popme.163.com/netease/mail/footer163.HTM


发生了下列的错误:



Connection Failed


连接失败





系统返回以下内容:
(110) Connection timed out



The remote host or network may be down. Please try the request again.


您要连结的网络服务器或网络可能发 故障。请稍后再试。



本缓*服务器管理员:webmaster





Generated Thu, 25 Feb 2010 04:17:59 GMT by cache.163.com (squid/3.0.STABLE23)


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

"Chen Lei" 02-25-2010 05:10 PM

Help needed: patching EMBOSS to use system pcre, expat and zlib
 
Hi Julian,
The emboss seems also bundled a copy of plplot*which already in fedora.
You can first del bundled stuffs and then modify Makefile.am*and configure,in to remove those stuffs .
Finally you need to type
* aclocal -I m4
** autoconf
** automake -a
在2010-02-25 12:18:08,"Chen*Lei"*<supercyper@163.com> 写道:

Hi Julian,
I think you should first confirm if the bundled zlib,*expat*and*pcre was heavily changed compared to the system-wide libs. If they are heavily changed, you maybe need use bundled version. otherwise it must be patched to avoid using bundled libs.


在2010-02-25*04:28:33,"Julian*Sikorski"*<belegdol@gmail .com>*写道:
>Hello,
>
>EMBOSS*6.2.0*bundles*zlib,*expat*and*pcre. *In*the*previous*version,*I
>got*help*from*a*fellow*packager*to*patch* the*pcre*out,*but*that*patch*no
>longer*works.*Thus,*I'd*like*to*ask*for*h elp*in*solving*this*problem,
>which*is*unfortunately*beyond*my*skills.
>Ideally,*I'd*gladly*accept*a*co-maintainer*for*this*bioinformatics*suite.
>I*have*built*the*package*with*bundled*libs *for*devel*for*the*time*being,
>so*that*potential*helpers*have*access*to*t he*latest*spec*file.
>
>Regards,
>Julian
>
>--*
>devel*mailing*list
>devel@lists.fedoraproject.org
>https://admin.fedoraproject.org/mailman/listinfo/devel



错误
您所请求的网址(URL)*法获取



当尝试读取以下网址(URL)时: http://popme.163.com/netease/mail/footer163.HTM


发生了下列的错误:


Connection Failed
连接失败

系统返回以下内容:
(110) Connection timed out

The remote host or network may be down. Please try the request again.
您要连结的网络服务器或网络可能发 故障。请稍后再试。


本缓*服务器管理员:webmaster




Generated Thu, 25 Feb 2010 04:17:59 GMT by cache.163.com (squid/3.0.STABLE23)

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

Julian Sikorski 02-26-2010 11:00 PM

Help needed: patching EMBOSS to use system pcre, expat and zlib
 
Hi Chen,

I tried having a look, but I'm not sure how to check that exactly. I
tried diffing the sources against the upstream source, but it's hard for
me to tell anything. The diffs are attached.
In case the uncompressed diffs don't get through moderation, here are
the compressed ones.

Julian

W dniu 25.02.2010 19:10, Chen Lei pisze:
> Hi Julian,
> The emboss seems also bundled a copy of plplot
> <http://koji.fedoraproject.org/koji/packageinfo?packageID=3493> which
> already in fedora.
> You can first del bundled stuffs and then modify Makefile.am and
> configure,in to remove those stuffs .
> Finally you need to type
> aclocal -I m4
> autoconf
> automake -a
> 2010-02-25 12:18:08"Chen Lei" <supercyper@163.com> д
>
> Hi Julian,
>
> I think you should first confirm if the bundled zlib, expat and pcre was heavily changed compared to the system-wide libs. If they are heavily changed, you maybe need use bundled version. otherwise it must be patched to avoid using bundled libs.
>
>
>
> 2010-02-25 04:28:33"Julian Sikorski" <belegdol@gmail.com <mailto:belegdol@gmail.com>> д
> >Hello,
> >
> >EMBOSS 6.2.0 bundles zlib, expat and pcre. In the previous version, I
> >got help from a fellow packager to patch the pcre out, but that patch no
> >longer works. Thus, I'd like to ask for help in solving this problem,
> >which is unfortunately beyond my skills.
> >Ideally, I'd gladly accept a co-maintainer for this bioinformatics suite.
> >I have built the package with bundled libs for devel for the time being,
> >so that potential helpers have access to the latest spec file.
> >
> >Regards,
> >Julian
> >
> >--
> >devel mailing list
> >devel@lists.fedoraproject.org <mailto:devel@lists.fedoraproject.org>
> >https://admin.fedoraproject.org/mailman/listinfo/devel
>
>
>
>
>
>
> ַURL޷ȡ
>
> ------------------------------------------------------------------------
>
> ԶȡַURLʱ
> http://popme.163.com/netease/mail/footer163.HTM
>
> еĴ
>
> * *Connection Failed
> ʧ *
>
> ϵͳݣ
>
> / (110) Connection timed out/
>
> The remote host or network may be down. Please try the request again.
> ҪܷϡԺ
>
> Աwebmaster
> <mailto:webmaster?subject=CacheErrorInfo%20-%20ERR_CONNECT_FAIL&body=CacheHost%3A%20cache.163. com%0D%0AErrPage%3A%20ERR_CONNECT_FAIL%0D%0AErr%3A %20(110)%20Connection%20timed%20out%0D%0ATimeStamp %3A%20Thu,%2025%20Feb%202010%2004%3A17%3A59%20GMT% 0D%0A%0D%0AClientIP%3A%20220.181.13.190%0D%0AServe rIP%3A%20220.181.75.142%0D%0A%0D%0AHTTP%20Request% 3A%0D%0AGET%20%2Fnetease%2Fmail%2Ffooter163.HTM%20 HTTP%2F1.1%0AHost%3A%20popme.163.com%0D%0AAccept-Encoding%3A%20identity%0D%0A%0D%0A%0D%0A>
>
>
> ------------------------------------------------------------------------
> Generated Thu, 25 Feb 2010 04:17:59 GMT by cache.163.com
> (squid/3.0.STABLE23)
>
>
>


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel

"Chen Lei" 03-02-2010 07:47 AM

Help needed: patching EMBOSS to use system pcre, expat and zlib
 
I'll take a look of those patches day^_^
在2010-02-27*08:00:50,"Julian*Sikorski"*<belegdol@gmail .com>*写道:
>Hi*Chen,
>
>I*tried*having*a*look,*but*I'm*not*sure* how*to*check*that*exactly.*I
>tried*diffing*the*sources*against*the*upstr eam*source,*but*it's*hard*for
>me*to*tell*anything.*The*diffs*are*attache d.
>In*case*the*uncompressed*diffs*don't*get*t hrough*moderation,*here*are
>the*compressed*ones.
>
>Julian


--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel


All times are GMT. The time now is 03:26 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.