FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 01-09-2008, 03:16 PM
Braden McDaniel
 
Default Check for libgnomeui failing in rawhide

This configure check is failing in rawhide:

PKG_CHECK_MODULES([GNOMEUI], [libgnomeui-2.0 libgnome-2.0 >= 2.14], ,
[have_gnomeui=no])

This is despite the fact that the spec file includes

BuildRequires: libgnomeui-devel >= 2.14

This was working as recently as Sunday. Anyone know what changed?

--
Braden McDaniel e-mail: <braden@endoframe.com>
<http://endoframe.com> Jabber: <braden@jabber.org>


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 01-09-2008, 03:21 PM
Caolan McNamara
 
Default Check for libgnomeui failing in rawhide

On Wed, 2008-01-09 at 11:16 -0500, Braden McDaniel wrote:
> This configure check is failing in rawhide:
>
> PKG_CHECK_MODULES([GNOMEUI], [libgnomeui-2.0 libgnome-2.0 >= 2.14], ,
> [have_gnomeui=no])
>
> This is despite the fact that the spec file includes
>
> BuildRequires: libgnomeui-devel >= 2.14
>
> This was working as recently as Sunday. Anyone know what changed?

This might be due to a typo in
GConf2-devel's /usr/%{_libdir}/pkgconfig/gconf-2.0.pc
where it says Requires: glib and not Requires: glib-2.0
this is fixed in GConf-devel 2.21.1-2 and is broken in 2.21.1-1

C.

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 01-09-2008, 03:43 PM
Braden McDaniel
 
Default Check for libgnomeui failing in rawhide

On Wed, 2008-01-09 at 16:21 +0000, Caolan McNamara wrote:
> On Wed, 2008-01-09 at 11:16 -0500, Braden McDaniel wrote:
> > This configure check is failing in rawhide:
> >
> > PKG_CHECK_MODULES([GNOMEUI], [libgnomeui-2.0 libgnome-2.0 >= 2.14], ,
> > [have_gnomeui=no])
> >
> > This is despite the fact that the spec file includes
> >
> > BuildRequires: libgnomeui-devel >= 2.14
> >
> > This was working as recently as Sunday. Anyone know what changed?
>
> This might be due to a typo in
> GConf2-devel's /usr/%{_libdir}/pkgconfig/gconf-2.0.pc
> where it says Requires: glib and not Requires: glib-2.0
> this is fixed in GConf-devel 2.21.1-2 and is broken in 2.21.1-1

Thanks. I'll wait for that to propagate and try my build again.

--
Braden McDaniel e-mail: <braden@endoframe.com>
<http://endoframe.com> Jabber: <braden@jabber.org>


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 12:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org