FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 02-21-2010, 12:15 AM
Michael Schwendt
 
Default Heads up! Broken deps in Upgrade from 12 to 13

Just for kicks, the current

Upgrade from 12+updates to 13+updates+testing

broken deps look like below. While several may be due to dead packages
that have been removed in 13, some are likely due to violated upgrade
paths and bad/missing Obsoletes for old subpackages.

[...]

Summary of broken packages (by src.rpm name):

avant-window-navigator
balsa
blacs
blahtexml
bmpx
bzr-gtk
cjkuni-fonts
cobbler
compat-db
dbxml
dbxml-perl
doodle
easystroke
edje
eel2
fusecompress
generic-release
ghc-gtk2hs
ghc-time
ghc-utf8-string
gnome-python2-desktop
gnome-python2-extras
gnome-web-photo
ibus-table
kdevelop
kst
linphone
linuxwacom
mono
monodevelop-debugger-mdb
mozvoikko
mrpt
mysql
netbeans
openvrml
orsa
ovaldi
pdfcube
perl-Archive-RPM
perl-Fedora-Bugzilla
player
qpidc
scalapack
sipwitch
xqilla10
zikula-module-menutree




================================================== ====================
Broken packages in fedora-12-i386:

blacs-lam-1.1-33.fc12.i686 requires blacs-common = 0:1.1-33.fc12
blahtexml-0.6-5.fc12.i686 requires libxerces-c.so.28
bmpx-0.40.14-15.fc12.i686 requires libboost_iostreams-mt.so.5
bmpx-0.40.14-15.fc12.i686 requires libboost_regex-mt.so.5
dbxml-2.4.16-0.5.fc12.i686 requires libxerces-c.so.28
dbxml-perl-2.0040016-2.fc12.i686 requires libxerces-c.so.28
dbxml-python-2.4.16-0.5.fc12.i686 requires libxerces-c.so.28
dbxml-utils-2.4.16-0.5.fc12.i686 requires libxerces-c.so.28
doodle-0.6.7-5.fc12.i686 requires libextractor.so.1
edje-0.9.9.050-6.fc12.i686 requires libembryo.so.0
eel2-2.26.0-2.fc12.i686 requires libgnome-desktop-2.so.11
fusecompress-2.6-3.fc12.i686 requires libboost_serialization-mt.so.5
fusecompress-2.6-3.fc12.i686 requires libboost_system-mt.so.5
fusecompress-2.6-3.fc12.i686 requires libboost_program_options-mt.so.5
fusecompress-2.6-3.fc12.i686 requires libboost_filesystem-mt.so.5
fusecompress-2.6-3.fc12.i686 requires libboost_iostreams-mt.so.5
ghc-gtk2hs-compat-0.10.1-5.fc12.i686 requires ghc-glade-devel = 0:0.10.1-5.fc12
ghc-gtk2hs-compat-0.10.1-5.fc12.i686 requires ghc-gconf-devel = 0:0.10.1-5.fc12
ghc-gtk2hs-compat-0.10.1-5.fc12.i686 requires ghc-soegtk-devel = 0:0.10.1-5.fc12
ghc-time-devel-1.1.2.4-2.fc12.i686 requires ghc = 0:6.10.4
ghc-time-devel-1.1.2.4-2.fc12.i686 requires ghc = 0:6.10.4
ghc-time-doc-1.1.2.4-2.fc12.i686 requires ghc-doc = 0:6.10.4
ghc-time-doc-1.1.2.4-2.fc12.i686 requires ghc-doc = 0:6.10.4
ghc-time-prof-1.1.2.4-2.fc12.i686 requires ghc-prof = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.i686 requires ghc = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.i686 requires ghc = 0:6.10.4
ghc-utf8-string-doc-0.3.5-3.fc12.i686 requires ghc-doc = 0:6.10.4
ghc-utf8-string-doc-0.3.5-3.fc12.i686 requires ghc-doc = 0:6.10.4
ghc-utf8-string-prof-0.3.5-3.fc12.i686 requires ghc-prof = 0:6.10.4
linphone-2.1.1-4.fc12.i686 requires libortp.so.7
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.i686 requires libmrpt-hwdrivers.so.0.7
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.i686 requires libmrpt-core.so.0.7
netbeans-apisupport1-6.7.1-1.fc12.noarch requires netbeans-platform = 0:6.7.1
netbeans-apisupport1-6.7.1-1.fc12.noarch requires netbeans-platform-harness = 0:6.7.1
pdfcube-0.0.3-5.fc12.i686 requires libboost_program_options-mt.so.5
scalapack-lam-1.7.5-7.fc12.i686 requires scalapack-common = 0:1.7.5-7.fc12
sipwitch-php-swig-0.5.7-1.fc12.i686 requires sipwitch = 0:0.5.7-1.fc12
sipwitch-python-swig-0.5.7-1.fc12.i686 requires sipwitch = 0:0.5.7-1.fc12
xqilla10-1.0.2-6.fc11.i586 requires libxerces-c.so.28


================================================== ====================
Broken packages in fedora-12-x86_64:

9:kdevelop-libs-3.5.4-6.fc12.i686 requires kdevelop = 9:3.5.4-6.fc12
blacs-lam-1.1-33.fc12.i686 requires blacs-common = 0:1.1-33.fc12
blacs-lam-1.1-33.fc12.x86_64 requires blacs-common = 0:1.1-33.fc12
blahtexml-0.6-5.fc12.x86_64 requires libxerces-c.so.28()(64bit)
bmpx-0.40.14-15.fc12.x86_64 requires libboost_iostreams.so.5()(64bit)
bmpx-0.40.14-15.fc12.x86_64 requires libboost_regex.so.5()(64bit)
dbxml-2.4.16-0.5.fc12.x86_64 requires libxqilla.so.4()(64bit)
dbxml-2.4.16-0.5.fc12.x86_64 requires libxerces-c.so.28()(64bit)
dbxml-perl-2.0040016-2.fc12.x86_64 requires libxqilla.so.4()(64bit)
dbxml-perl-2.0040016-2.fc12.x86_64 requires libxerces-c.so.28()(64bit)
dbxml-python-2.4.16-0.5.fc12.x86_64 requires libxqilla.so.4()(64bit)
dbxml-python-2.4.16-0.5.fc12.x86_64 requires libxerces-c.so.28()(64bit)
dbxml-utils-2.4.16-0.5.fc12.x86_64 requires libxqilla.so.4()(64bit)
dbxml-utils-2.4.16-0.5.fc12.x86_64 requires libxerces-c.so.28()(64bit)
doodle-0.6.7-5.fc12.i686 requires libextractor.so.1
doodle-0.6.7-5.fc12.x86_64 requires libextractor.so.1()(64bit)
edje-0.9.9.050-6.fc12.i686 requires libembryo.so.0
edje-0.9.9.050-6.fc12.x86_64 requires libembryo.so.0()(64bit)
eel2-2.26.0-2.fc12.i686 requires libgnome-desktop-2.so.11
eel2-2.26.0-2.fc12.x86_64 requires libgnome-desktop-2.so.11()(64bit)
fusecompress-2.6-3.fc12.x86_64 requires libboost_system-mt.so.5()(64bit)
fusecompress-2.6-3.fc12.x86_64 requires libboost_program_options-mt.so.5()(64bit)
fusecompress-2.6-3.fc12.x86_64 requires libboost_iostreams-mt.so.5()(64bit)
fusecompress-2.6-3.fc12.x86_64 requires libboost_filesystem-mt.so.5()(64bit)
fusecompress-2.6-3.fc12.x86_64 requires libboost_serialization-mt.so.5()(64bit)
ghc-gtk2hs-compat-0.10.1-5.fc12.x86_64 requires ghc-glade-devel = 0:0.10.1-5.fc12
ghc-gtk2hs-compat-0.10.1-5.fc12.x86_64 requires ghc-gconf-devel = 0:0.10.1-5.fc12
ghc-gtk2hs-compat-0.10.1-5.fc12.x86_64 requires ghc-soegtk-devel = 0:0.10.1-5.fc12
ghc-time-devel-1.1.2.4-2.fc12.i686 requires ghc = 0:6.10.4
ghc-time-devel-1.1.2.4-2.fc12.i686 requires ghc = 0:6.10.4
ghc-time-devel-1.1.2.4-2.fc12.x86_64 requires ghc = 0:6.10.4
ghc-time-devel-1.1.2.4-2.fc12.x86_64 requires ghc = 0:6.10.4
ghc-time-doc-1.1.2.4-2.fc12.x86_64 requires ghc-doc = 0:6.10.4
ghc-time-doc-1.1.2.4-2.fc12.x86_64 requires ghc-doc = 0:6.10.4
ghc-time-prof-1.1.2.4-2.fc12.x86_64 requires ghc-prof = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.i686 requires ghc = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.i686 requires ghc = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.x86_64 requires ghc = 0:6.10.4
ghc-utf8-string-devel-0.3.5-3.fc12.x86_64 requires ghc = 0:6.10.4
ghc-utf8-string-doc-0.3.5-3.fc12.x86_64 requires ghc-doc = 0:6.10.4
ghc-utf8-string-doc-0.3.5-3.fc12.x86_64 requires ghc-doc = 0:6.10.4
ghc-utf8-string-prof-0.3.5-3.fc12.x86_64 requires ghc-prof = 0:6.10.4
linphone-2.1.1-4.fc12.i686 requires libortp.so.7
linphone-2.1.1-4.fc12.x86_64 requires libortp.so.7()(64bit)
monodevelop-debugger-mdb-2.1.0-1.fc12.i686 requires mono(MonoDevelop.Debugger) = 0:2.1.0.0
monodevelop-debugger-mdb-2.1.0-1.fc12.i686 requires mono(MonoDevelop.Core) = 0:2.1.0.0
monodevelop-debugger-mdb-2.1.0-1.fc12.i686 requires mono(MonoDevelop.AspNet) = 0:2.1.0.0
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.i686 requires libmrpt-hwdrivers.so.0.7
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.i686 requires libmrpt-core.so.0.7
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.x86_64 requires libmrpt-core.so.0.7()(64bit)
mrpt-monoslam-0.7.1-0.1.20090818svn1148.fc12.x86_64 requires libmrpt-hwdrivers.so.0.7()(64bit)
netbeans-apisupport1-6.7.1-1.fc12.noarch requires netbeans-platform = 0:6.7.1
netbeans-apisupport1-6.7.1-1.fc12.noarch requires netbeans-platform-harness = 0:6.7.1
openvrml-0.18.3-5.fc12.i686 requires libboost_thread-mt.so.5
openvrml-0.18.3-5.fc12.i686 requires libboost_filesystem-mt.so.5
pdfcube-0.0.3-5.fc12.x86_64 requires libboost_program_options-mt.so.5()(64bit)
scalapack-lam-1.7.5-7.fc12.i686 requires scalapack-common = 0:1.7.5-7.fc12
scalapack-lam-1.7.5-7.fc12.x86_64 requires scalapack-common = 0:1.7.5-7.fc12
sipwitch-php-swig-0.5.7-1.fc12.x86_64 requires sipwitch = 0:0.5.7-1.fc12
sipwitch-python-swig-0.5.7-1.fc12.x86_64 requires sipwitch = 0:0.5.7-1.fc12
xqilla10-1.0.2-6.fc11.i586 requires libxerces-c.so.28
xqilla10-1.0.2-6.fc11.x86_64 requires libxerces-c.so.28()(64bit)


================================================== ====================
Broken packages in fedora-13-development-i386:

balsa-2.4.6-3.fc13.i686 requires libgmime-2.4.so.2
easystroke-0.5.2-1.fc13.i686 requires libboost_serialization-mt.so.5
generic-release-rawhide-13-0.4.noarch requires generic-release-13-0.4
gnome-python2-totem-2.29.1-4.fc13.i686 requires libtotem-plparser.so.12
koan-2.0.3.1-1.fc13.noarch requires mkinitrd
ovaldi-5.5.25-2.fc13.i686 requires libxerces-c.so.28
perl-Archive-RPM-0.05-1.fc13.noarch requires perl(MooseX::Types:ateTimeX)
perl-Fedora-Bugzilla-0.13-2.fc13.noarch requires perl(MooseX::Types:ateTimeX)
qpidc-server-devel-0.5.819819-4.fc13.i686 requires qpidc-client-devel = 0:0.5.819819-4.fc13
qpidc-server-rdma-0.5.819819-4.fc13.i686 requires qpidc-client-rdma = 0:0.5.819819-4.fc13
qpidc-server-ssl-0.5.819819-4.fc13.i686 requires qpidc-client-ssl = 0:0.5.819819-4.fc13
zikula-module-menutree-2.2-1.fc13.noarch requires zikula >= 0:1.2


================================================== ====================
Broken packages in fedora-13-development-x86_64:

balsa-2.4.6-3.fc13.x86_64 requires libgmime-2.4.so.2()(64bit)
compat-db-4.7.25-2.fc13.x86_64 requires compat-db45 = 0:4.5.20-2.fc13
compat-db-4.7.25-2.fc13.x86_64 requires compat-db46 = 0:4.6.21-2.fc13
easystroke-0.5.2-1.fc13.x86_64 requires libboost_serialization-mt.so.5()(64bit)
generic-release-rawhide-13-0.4.noarch requires generic-release-13-0.4
gnome-python2-totem-2.29.1-4.fc13.x86_64 requires libtotem-plparser.so.12()(64bit)
koan-2.0.3.1-1.fc13.noarch requires mkinitrd
ovaldi-5.5.25-2.fc13.x86_64 requires libxerces-c.so.28()(64bit)
perl-Archive-RPM-0.05-1.fc13.noarch requires perl(MooseX::Types:ateTimeX)
perl-Fedora-Bugzilla-0.13-2.fc13.noarch requires perl(MooseX::Types:ateTimeX)
qpidc-server-devel-0.5.819819-4.fc13.i686 requires qpidc-client-devel = 0:0.5.819819-4.fc13
qpidc-server-devel-0.5.819819-4.fc13.x86_64 requires qpidc-client-devel = 0:0.5.819819-4.fc13
qpidc-server-rdma-0.5.819819-4.fc13.x86_64 requires qpidc-client-rdma = 0:0.5.819819-4.fc13
qpidc-server-ssl-0.5.819819-4.fc13.x86_64 requires qpidc-client-ssl = 0:0.5.819819-4.fc13
zikula-module-menutree-2.2-1.fc13.noarch requires zikula >= 0:1.2


================================================== ====================
Broken packages in fedora-updates-12-i386:

avant-window-navigator-0.3.2.1-3.fc12.i686 requires libgnome-desktop-2.so.11
cjkuni-fonts-compat-0.2.20080216.1-30.fc12.noarch requires cjkuni-uming-fonts = 0:0.2.20080216.1-30.fc12
gnome-python2-gtkmozembed-2.25.3-16.fc12.i686 requires gecko-libs = 0:1.9.1.8
gnome-web-photo-0.9-5.fc12.i686 requires gecko-libs = 0:1.9.1.8
ibus-table-additional-1.2.0.20100111-1.fc12.noarch requires ibus-table = 0:1.2.0.20100111-1.fc12
linuxwacom-devel-0.8.2.2-17.fc12.i686 requires linuxwacom = 0:0.8.2.2-17.fc12
linuxwacom-devel-0.8.2.2-17.fc12.i686 requires libwacomcfg.so.0
mono-moonlight-2.4.3.1-1.fc12.i686 requires mono-core = 0:2.4.3.1-1.fc12
mozvoikko-1.0-8.fc12.i686 requires gecko-libs = 0:1.9.1.8
mysql-cluster-5.1.42-7.fc12.i686 requires mysql = 0:5.1.42-7.fc12
nautilus-bzr-0.97.0-2.fc12.i686 requires bzr-gtk = 0:0.97.0-2.fc12
orsa-lam-0.7.0-11.fc12.1.i686 requires orsa-common = 0:0.7.0-11.fc12.1
orsa-lam-devel-0.7.0-11.fc12.1.i686 requires orsa-headers = 0:0.7.0-11.fc12.1
player-3.0.1-3.fc12.i686 requires libboost_signals-mt.so.5
player-3.0.1-3.fc12.i686 requires libcv.so.2
player-3.0.1-3.fc12.i686 requires libhighgui.so.2
player-3.0.1-3.fc12.i686 requires libcxcore.so.2
player-3.0.1-3.fc12.i686 requires libcvaux.so.2
player-3.0.1-3.fc12.i686 requires libml.so.2
player-3.0.1-3.fc12.i686 requires libboost_thread-mt.so.5
player-3.0.1-3.fc12.i686 requires libpqxx-2.6.8.so
qmf-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qmf-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-perftest-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-perftest-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-rdma-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-rdma-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-ssl-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-ssl-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-acl-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-acl-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-cluster-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-cluster-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-rdma-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-rdma-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-ssl-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-ssl-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-xml-0.5.829175-3.fc12.i686 requires libxerces-c.so.28
qpidd-xml-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-xml-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
rhm-cpp-server-store-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
rhm-cpp-server-store-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
ruby-qmf-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
ruby-qmf-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5


================================================== ====================
Broken packages in fedora-updates-12-x86_64:

avant-window-navigator-0.3.2.1-3.fc12.i686 requires libgnome-desktop-2.so.11
avant-window-navigator-0.3.2.1-3.fc12.x86_64 requires libgnome-desktop-2.so.11()(64bit)
cjkuni-fonts-compat-0.2.20080216.1-30.fc12.noarch requires cjkuni-uming-fonts = 0:0.2.20080216.1-30.fc12
gnome-python2-gtkmozembed-2.25.3-16.fc12.x86_64 requires gecko-libs = 0:1.9.1.8
gnome-web-photo-0.9-5.fc12.x86_64 requires gecko-libs = 0:1.9.1.8
ibus-table-additional-1.2.0.20100111-1.fc12.noarch requires ibus-table = 0:1.2.0.20100111-1.fc12
linuxwacom-devel-0.8.2.2-17.fc12.i686 requires linuxwacom = 0:0.8.2.2-17.fc12
linuxwacom-devel-0.8.2.2-17.fc12.i686 requires libwacomcfg.so.0
linuxwacom-devel-0.8.2.2-17.fc12.x86_64 requires linuxwacom = 0:0.8.2.2-17.fc12
linuxwacom-devel-0.8.2.2-17.fc12.x86_64 requires libwacomcfg.so.0()(64bit)
mono-moonlight-2.4.3.1-1.fc12.x86_64 requires mono-core = 0:2.4.3.1-1.fc12
mozvoikko-1.0-8.fc12.x86_64 requires gecko-libs = 0:1.9.1.8
mysql-cluster-5.1.42-7.fc12.x86_64 requires mysql = 0:5.1.42-7.fc12
nautilus-bzr-0.97.0-2.fc12.x86_64 requires bzr-gtk = 0:0.97.0-2.fc12
orsa-lam-0.7.0-11.fc12.1.x86_64 requires orsa-common = 0:0.7.0-11.fc12.1
orsa-lam-devel-0.7.0-11.fc12.1.i686 requires orsa-headers = 0:0.7.0-11.fc12.1
orsa-lam-devel-0.7.0-11.fc12.1.x86_64 requires orsa-headers = 0:0.7.0-11.fc12.1
player-3.0.1-3.fc12.i686 requires libboost_signals-mt.so.5
player-3.0.1-3.fc12.i686 requires libcv.so.2
player-3.0.1-3.fc12.i686 requires libhighgui.so.2
player-3.0.1-3.fc12.i686 requires libcxcore.so.2
player-3.0.1-3.fc12.i686 requires libcvaux.so.2
player-3.0.1-3.fc12.i686 requires libml.so.2
player-3.0.1-3.fc12.i686 requires libboost_thread-mt.so.5
player-3.0.1-3.fc12.i686 requires libpqxx-2.6.8.so
player-3.0.1-3.fc12.x86_64 requires libml.so.2()(64bit)
player-3.0.1-3.fc12.x86_64 requires libboost_signals-mt.so.5()(64bit)
player-3.0.1-3.fc12.x86_64 requires libcxcore.so.2()(64bit)
player-3.0.1-3.fc12.x86_64 requires libcvaux.so.2()(64bit)
player-3.0.1-3.fc12.x86_64 requires libpqxx-2.6.8.so()(64bit)
player-3.0.1-3.fc12.x86_64 requires libhighgui.so.2()(64bit)
player-3.0.1-3.fc12.x86_64 requires libcv.so.2()(64bit)
player-3.0.1-3.fc12.x86_64 requires libboost_thread-mt.so.5()(64bit)
qmf-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qmf-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qmf-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qmf-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidc-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidc-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidc-perftest-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidc-perftest-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidc-rdma-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-rdma-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-rdma-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidc-rdma-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidc-ssl-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidc-ssl-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidc-ssl-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidc-ssl-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-0.5.829175-3.fc12.i686 requires libboost_program_options.so.5
qpidd-0.5.829175-3.fc12.i686 requires libboost_filesystem.so.5
qpidd-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-acl-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-acl-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-cluster-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-cluster-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-rdma-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-rdma-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-ssl-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-ssl-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-xml-0.5.829175-3.fc12.x86_64 requires libxqilla.so.4()(64bit)
qpidd-xml-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
qpidd-xml-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
qpidd-xml-0.5.829175-3.fc12.x86_64 requires libxerces-c.so.28()(64bit)
rhm-cpp-server-store-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
rhm-cpp-server-store-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)
ruby-qmf-0.5.829175-3.fc12.x86_64 requires libboost_filesystem.so.5()(64bit)
ruby-qmf-0.5.829175-3.fc12.x86_64 requires libboost_program_options.so.5()(64bit)


================================================== ====================
Broken packages in fedora-updates-testing-13-i386:

kst-fits-1.8.0-6.fc13.i686 requires cfitsio = 0:3.24


================================================== ====================
Broken packages in fedora-updates-testing-13-x86_64:

kst-fits-1.8.0-6.fc13.x86_64 requires cfitsio = 0:3.24



--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 12:46 AM
Braden McDaniel
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Sun, 2010-02-21 at 02:15 +0100, Michael Schwendt wrote:
> Just for kicks, the current
>
> Upgrade from 12+updates to 13+updates+testing
>
> broken deps look like below. While several may be due to dead packages
> that have been removed in 13, some are likely due to violated upgrade
> paths and bad/missing Obsoletes for old subpackages.
>
> [...]
>
> Summary of broken packages (by src.rpm name):

[snip]

> openvrml

[snip]

> openvrml-0.18.3-5.fc12.i686 requires libboost_thread-mt.so.5
> openvrml-0.18.3-5.fc12.i686 requires libboost_filesystem-mt.so.5

This doesn't look to me like F12 updates are being factored in properly.
openvrml-0.18.3-10 is currently in F12 updates.

--
Braden McDaniel <braden@endoframe.com>

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 01:03 AM
Braden McDaniel
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Sat, 2010-02-20 at 20:46 -0500, Braden McDaniel wrote:
> On Sun, 2010-02-21 at 02:15 +0100, Michael Schwendt wrote:
> > Just for kicks, the current
> >
> > Upgrade from 12+updates to 13+updates+testing
> >
> > broken deps look like below. While several may be due to dead packages
> > that have been removed in 13, some are likely due to violated upgrade
> > paths and bad/missing Obsoletes for old subpackages.
> >
> > [...]
> >
> > Summary of broken packages (by src.rpm name):
>
> [snip]
>
> > openvrml
>
> [snip]
>
> > openvrml-0.18.3-5.fc12.i686 requires libboost_thread-mt.so.5
> > openvrml-0.18.3-5.fc12.i686 requires libboost_filesystem-mt.so.5
>
> This doesn't look to me like F12 updates are being factored in properly.
> openvrml-0.18.3-10 is currently in F12 updates.

I guess I should properly read the headings... I guess I misunderstood
where this was going from your summary.

If I understand it correctly, it's telling me that a F12 that hasn't
been updated will have problems being upgraded to F13. Certainly that's
not ideal; but it doesn't strike me as exactly tragic, either. How
important is this considered, generally?

I'm not crystal clear on why this is broken, either. It may have
something to do with the fact that the openvrml binary RPM changed to
being a metapackage; but the implication of Boost is a bit confounding.

--
Braden McDaniel <braden@endoframe.com>

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 02:41 AM
Tom Lane
 
Default Heads up! Broken deps in Upgrade from 12 to 13

Michael Schwendt <mschwendt@gmail.com> writes:
> mysql-cluster-5.1.42-7.fc12.i686 requires mysql = 0:5.1.42-7.fc12

Yeah, so? Those come out of the same SRPM, so it's hardly possible that
we are providing one and not the other. I think there's something
fishy about your script.

regards, tom lane
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 03:16 AM
Leigh Scott
 
Default Heads up! Broken deps in Upgrade from 12 to 13

avant-window-navigator doesn't have broken deps, this error occurred
because the F12 package had a higher release version.
Perhaps yum should deal with this better i.e take dist tag into account


On Sun, 2010-02-21 at 02:15 +0100, Michael Schwendt wrote:
> ================================================== ====================
> Broken packages in fedora-updates-12-x86_64:
>
> avant-window-navigator-0.3.2.1-3.fc12.i686 requires
> libgnome-desktop-2.so.11
> avant-window-navigator-0.3.2.1-3.fc12.x86_64 requires
> libgnome-desktop-2.so.11()(64bit)

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 03:20 AM
Conrad Meyer
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Saturday 20 February 2010 06:03:28 pm Braden McDaniel wrote:
> I guess I should properly read the headings... I guess I misunderstood
> where this was going from your summary.
>
> If I understand it correctly, it's telling me that a F12 that hasn't
> been updated will have problems being upgraded to F13. Certainly that's
> not ideal; but it doesn't strike me as exactly tragic, either. How
> important is this considered, generally?
>
> I'm not crystal clear on why this is broken, either. It may have
> something to do with the fact that the openvrml binary RPM changed to
> being a metapackage; but the implication of Boost is a bit confounding.

The ratio of "badness" to the difficulty of fixing it is fairly high. Fixing
it is fairly trivial. Leaving it broken breaks upgrades for users who upgrade
distributions using yum update -- which, though it isn't supported, is
reasonably common.

The solution varies somewhat depending on how broken it is; I'll try to
describe all possible problems / solutions. There's going to be a lot of text
here, but nothing hard to do.

If the F-12 package has a higher Epoch than the F-13 package, this is *very*
broken, but can be fixed by bumping the F-13 Epoch to at least the F-12 Epoch.

If the F-12 package has a higher Version than the F-13 package and the same
Epoch, this is probably broken. If the F-13 Epoch is higher (i.e., you
reverted the version in F-13), you should probably revert in F-12 as well. If
you just bumped the version in F-12 and forgot to for F-13, you should bump
F-13 to the same or higher version as is in F-12.

If the F-12 package has the same-or-lower Epoch and the same version, but a
higher Release, then a couple things may be wrong:
- You may have incorporated changes into the F-12 package that *should* go to
F-13 as well, but you forgot; in this case, incorporate them and bump F-13's
Release to that of F-12 (if using the %{?dist} macro) or higher (if not using
it).
- You may have incorporated changes into the F-12 package that *should not* go
to F-13 and then mistakenly bumped the release past that of F-13. In this
case, just bump the F-13 release up. In the future, when making a change that
only affects a single version of Fedora, append a ".1" to the Release version
(or if it already has a ".1", bump that). Example: "Release 4%{?dist}" ->
"Release 4%{?dist}.1".

I think that's everything. Let me know if you have any questions, or if I'm
wrong .

Hope that helps,
--
Conrad Meyer <cemeyer@u.washington.edu>
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 03:27 AM
Conrad Meyer
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Saturday 20 February 2010 08:20:17 pm Conrad Meyer wrote:
> I think that's everything.

Oh, and I forgot something: After making whatever changes need to be made to
F-13, tag and rebuild the package.

Regards,
--
Conrad Meyer <cemeyer@u.washington.edu>
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 03:34 AM
Braden McDaniel
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Sat, 2010-02-20 at 20:20 -0800, Conrad Meyer wrote:
> On Saturday 20 February 2010 06:03:28 pm Braden McDaniel wrote:
> > I guess I should properly read the headings... I guess I misunderstood
> > where this was going from your summary.
> >
> > If I understand it correctly, it's telling me that a F12 that hasn't
> > been updated will have problems being upgraded to F13. Certainly that's
> > not ideal; but it doesn't strike me as exactly tragic, either. How
> > important is this considered, generally?
> >
> > I'm not crystal clear on why this is broken, either. It may have
> > something to do with the fact that the openvrml binary RPM changed to
> > being a metapackage; but the implication of Boost is a bit confounding.
>
> The ratio of "badness" to the difficulty of fixing it is fairly high. Fixing
> it is fairly trivial. Leaving it broken breaks upgrades for users who upgrade
> distributions using yum update -- which, though it isn't supported, is
> reasonably common.

I'm happy to fix it if I can figure out what's broken.

> The solution varies somewhat depending on how broken it is; I'll try to
> describe all possible problems / solutions. There's going to be a lot of text
> here, but nothing hard to do.
>
> If the F-12 package has a higher Epoch than the F-13 package, this is *very*
> broken, but can be fixed by bumping the F-13 Epoch to at least the F-12 Epoch.

That's not it.

> If the F-12 package has a higher Version than the F-13 package and the same
> Epoch, this is probably broken.

Also not it.

> If the F-12 package has the same-or-lower Epoch and the same version, but a
> higher Release, then a couple things may be wrong:

Nope.

> I think that's everything. Let me know if you have any questions, or if I'm
> wrong .

I'm afraid I'm still at a loss.

--
Braden McDaniel <braden@endoframe.com>

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 03:54 AM
Conrad Meyer
 
Default Heads up! Broken deps in Upgrade from 12 to 13

On Saturday 20 February 2010 08:34:39 pm Braden McDaniel wrote:
> (portions snipped)
>
> On Sat, 2010-02-20 at 20:20 -0800, Conrad Meyer wrote:
> > ...
> I'm happy to fix it if I can figure out what's broken.
> > ...
> That's not it.
> > ...
> Also not it.
> > ...
> Nope.
>
> > I think that's everything. Let me know if you have any questions, or if
> > I'm wrong .
>
> I'm afraid I'm still at a loss.

I don't think openvrml has upgrade issues related to epoch/version/release,
then .

Regards,
--
Conrad Meyer <cemeyer@u.washington.edu>
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 02-21-2010, 08:43 AM
Thomas Janssen
 
Default Heads up! Broken deps in Upgrade from 12 to 13

2010/2/21 Michael Schwendt <mschwendt@gmail.com>:
> Just for kicks, the current
>
> * Upgrade from *12+updates *to *13+updates+testing
>
> broken deps look like below. While several may be due to dead packages
> that have been removed in 13, some are likely due to violated upgrade
> paths and bad/missing Obsoletes for old subpackages.
>
> [...]
>
> Summary of broken packages (by src.rpm name):
>
> * *edje

This one will be solved soonish, once the review request for a needed
dep (libeina) is trough.
My co-maintainer was a bit over-motivated and built edje before the
the new chain was ready.

--
LG Thomas

Dubium sapientiae initium
--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 10:05 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org