FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 01-17-2010, 05:55 PM
Matthias Clasen
 
Default gnome-desktop bump

I'm going to build gnome-desktop 2.29.5 in rawhide, which bumps the
soname of libgnome-desktop-2.so. Affected packages are:

avant-window-navigator
awn-extras-applets
cheese
compiz-gnome
control-center
deskbar-applet
eel2
eog
evolution
evolution-bogofilter
evolution-conduits
galeon
gnome-applets
gnome-launch-box
gnome-panel
gnome-python2-gnomedesktop
gnome-screensaver
gnome-settings-daemon
gnome-shell
icewm-gnome
nautilus
nautilus-open-terminal
nautilus-search-tool
padevchooser
tracker-search-tool
tsclient



--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 01-27-2010, 05:00 AM
Adam Williamson
 
Default gnome-desktop bump

On Sun, 2010-01-17 at 13:55 -0500, Matthias Clasen wrote:

> I'm going to build gnome-desktop 2.29.5 in rawhide, which bumps the
> soname of libgnome-desktop-2.so. Affected packages are:

> eel2

I asked on IRC for someone to rebuild this. Warren told me it's been
blocked, apparently by Tbzatek. However, it has live dependencies.
nautilus-python requires eel2, and tortoisehg-nautilus , postr and
nautilus-phatch all depend on nautilus-python. Please, either make
nautilus-python not require eel2 somehow, make all nautilus-python's
dependencies not require nautilus-python any more and block that too, or
restore eel2. Thanks.
--
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 01-27-2010, 05:49 AM
Toshio Kuratomi
 
Default gnome-desktop bump

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 01-27-2010, 03:34 PM
Matthias Clasen
 
Default gnome-desktop bump

On Tue, 2010-01-26 at 22:00 -0800, Adam Williamson wrote:
> On Sun, 2010-01-17 at 13:55 -0500, Matthias Clasen wrote:
>
> > I'm going to build gnome-desktop 2.29.5 in rawhide, which bumps the
> > soname of libgnome-desktop-2.so. Affected packages are:
>
> > eel2
>
> I asked on IRC for someone to rebuild this. Warren told me it's been
> blocked, apparently by Tbzatek. However, it has live dependencies.
> nautilus-python requires eel2, and tortoisehg-nautilus , postr and
> nautilus-phatch all depend on nautilus-python. Please, either make
> nautilus-python not require eel2 somehow, make all nautilus-python's
> dependencies not require nautilus-python any more and block that too, or
> restore eel2. Thanks.
> --

The current upstream version of nautilus-python, 0.6.1, doesn't depend
on the dead eel. Unfortunately, nautilus-python seems 'weakly
maintained' in Fedora, the last non-mass rebuild dating from Dec 2008.

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 
Old 01-27-2010, 04:47 PM
Adam Williamson
 
Default gnome-desktop bump

On Wed, 2010-01-27 at 11:34 -0500, Matthias Clasen wrote:
> On Tue, 2010-01-26 at 22:00 -0800, Adam Williamson wrote:
> > On Sun, 2010-01-17 at 13:55 -0500, Matthias Clasen wrote:
> >
> > > I'm going to build gnome-desktop 2.29.5 in rawhide, which bumps
> the
> > > soname of libgnome-desktop-2.so. Affected packages are:
> >
> > > eel2
> >
> > I asked on IRC for someone to rebuild this. Warren told me it's been
> > blocked, apparently by Tbzatek. However, it has live dependencies.
> > nautilus-python requires eel2, and tortoisehg-nautilus , postr and
> > nautilus-phatch all depend on nautilus-python. Please, either make
> > nautilus-python not require eel2 somehow, make all nautilus-python's
> > dependencies not require nautilus-python any more and block that
> too, or
> > restore eel2. Thanks.

> The current upstream version of nautilus-python, 0.6.1, doesn't depend
> on the dead eel. Unfortunately, nautilus-python seems 'weakly
> maintained' in Fedora, the last non-mass rebuild dating from Dec 2008.

So, an update: Toshio and I found the new nautilus-python too, and
indeed it builds perfectly happily without eel.

It doesn't appear to actually _work_, though. The app I actually use -
postr - claims to do nautilus integration via a Python nautilus
extension. I can rebuild postr as well and it'll 'build' (it's
Python...) its extension and install it in the right place, but it
doesn't actually work. It's supposed to provide a right-click menu entry
in nautilus when you click on an image file, to let you open it in postr
(and hence send it to flickr). The menu entry never shows up. This works
in F11 (can't test F12, don't have an F12 system handy).

We can of course take the cowardly^H^H^H^H^H^H^H^Hpragmatic approach and
just send a bump of nautilus-python anyway; it builds fine (the patch
needs a trivial tweak) and would at least resolve the dependency issues.
Making it actually work could be, ahem...properly prioritized.
--
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Fedora Talk: adamwill AT fedoraproject DOT org
http://www.happyassassin.net

--
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
 

Thread Tools




All times are GMT. The time now is 12:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org