FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 11-29-2008, 01:09 PM
Paul
 
Default Strange patch problem (not being fully applied)

Hi,

I'm trying to get mono-tools-2.2 pre1 into rawhide but have hit a snag
with a patch which is not getting correctly applied. The daft thing is
that the second part it, but the first thing isn't!

Below is that patch (in part). The uninstall hook patch is applied, but
not the install hook part. This is happening on both my home box and on
koji. Nothing else is hitting this particular makefile.in. Any ideas?

2.2-5.pre1 is in cvs currently and has recently failed to build on koji
(ID=71568). I can't get monodevelop 1.9.1 into rawhide until mono-tools
is in.

--- mono-tools-2.2/gendarme/rules/Makefile.in 2008-11-17
17:01:20.000000000 +0000
+++ mono-tools-2.2/gendarme/rules/Makefile-new.in 2008-11-29
13:22:55.000000000 +0000
@@ -526,10 +526,10 @@


install-data-hook:
- $(INSTALL) -c -m 0644 $(addprefix $(srcdir)/, rules.xml)
$(DESTDIR)$(prefix)/lib/gendarme;
+ $(INSTALL) -c -m 0644 $(addprefix $(srcdir)/, rules.xml)
$(DESTDIR)$(libdir)/gendarme;

uninstall-hook:
- rm -f $(DESTDIR)$(prefix)/lib/gendarme/`basename rules.xml`;
+ rm -f $(DESTDIR)$(libdir)/gendarme/`basename rules.xml`;

test:
for ASM in $(SUBDIRS); do

TTFN

Paul
--
Sie können mich aufreizen und wirklich heiß machen!
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 11-29-2008, 01:18 PM
"Xavier Lamien"
 
Default Strange patch problem (not being fully applied)

2008/11/29 Paul <paul@all-the-johnsons.co.uk>:
> Hi,
>
> I'm trying to get mono-tools-2.2 pre1 into rawhide but have hit a snag
> with a patch which is not getting correctly applied. The daft thing is
> that the second part it, but the first thing isn't!
>
> Below is that patch (in part). The uninstall hook patch is applied, but
> not the install hook part. This is happening on both my home box and on
> koji. Nothing else is hitting this particular makefile.in. Any ideas?
>
> 2.2-5.pre1 is in cvs currently and has recently failed to build on koji
> (ID=71568). I can't get monodevelop 1.9.1 into rawhide until mono-tools
> is in.
>

Could you point us to the build.log ?

--
Xavier.t Lamien
--
http://fedoraproject.org/wiki/XavierLamien
GPG-Key ID: F3903DEB
Fingerprint: 0F2A 7A17 0F1B 82EE FCBF 1F51 76B7 A28D F390 3DEB

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 11-29-2008, 01:22 PM
Paul
 
Default Strange patch problem (not being fully applied)

Hi,

> Could you point us to the build.log ?

http://koji.fedoraproject.org/koji/getfile?taskID=957876&name=build.log

It builds fine on x86. However when I check the makefile.in file
concerned, it has not been changed on my local system either. I don't
know if there is a problem with the patching operation.

TTFN

Paul
--
Sie können mich aufreizen und wirklich heiß machen!
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 11-29-2008, 02:06 PM
Mamoru Tasaka
 
Default Strange patch problem (not being fully applied)

Paul wrote, at 11/29/2008 11:09 PM +9:00:

Hi,

I'm trying to get mono-tools-2.2 pre1 into rawhide but have hit a snag
with a patch which is not getting correctly applied. The daft thing is
that the second part it, but the first thing isn't!

Below is that patch (in part). The uninstall hook patch is applied, but
not the install hook part. This is happening on both my home box and on
koji. Nothing else is hitting this particular makefile.in. Any ideas?

--- mono-tools-2.2/gendarme/rules/Makefile.in 2008-11-17
17:01:20.000000000 +0000
+++ mono-tools-2.2/gendarme/rules/Makefile-new.in 2008-11-29
13:22:55.000000000 +0000
@@ -526,10 +526,10 @@


install-data-hook:

- $(INSTALL) -c -m 0644 $(addprefix $(srcdir)/, rules.xml)
$(DESTDIR)$(prefix)/lib/gendarme;
+ $(INSTALL) -c -m 0644 $(addprefix $(srcdir)/, rules.xml)
$(DESTDIR)$(libdir)/gendarme;

uninstall-hook:

- rm -f $(DESTDIR)$(prefix)/lib/gendarme/`basename rules.xml`;
+ rm -f $(DESTDIR)$(libdir)/gendarme/`basename rules.xml`;

test:

for ASM in $(SUBDIRS); do

TTFN

Paul


This patch modifies Makefile.in, however mono-tools.spec says
after this patch is applied autoreconf is called, which
perhaps regenerates Makefile.in from (unmodified) Makefile.am,
which I guess is the reason.


Regards,
Mamoru

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 11-29-2008, 02:07 PM
"Xavier Lamien"
 
Default Strange patch problem (not being fully applied)

2008/11/29 Paul <paul@all-the-johnsons.co.uk>:
> Hi,
>
>> Could you point us to the build.log ?
>
> http://koji.fedoraproject.org/koji/getfile?taskID=957876&name=build.log
>
> It builds fine on x86. However when I check the makefile.in file
> concerned, it has not been changed on my local system either. I don't
> know if there is a problem with the patching operation.
>
> TTFN

Have a closer look into both your patch and the Makefile.am
You forgot a '$(prefix)/lib' in the install method



--
Xavier.t Lamien
--
http://fedoraproject.org/wiki/XavierLamien
GPG-Key ID: F3903DEB
Fingerprint: 0F2A 7A17 0F1B 82EE FCBF 1F51 76B7 A28D F390 3DEB

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 02:34 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org