FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 10-23-2008, 09:56 PM
Orion Poplawski
 
Default Broken dependencies in Fedora 9 - 2008-10-23

Michael Schwendt wrote:

Your following packages in the repository suffer from broken dependencies:

================================================== ====================
The results in this summary consider Test Updates!
================================================== ====================

package: paraview-3.2.1-6.fc9.i386 from fedora-9-x86_64
unresolved deps:
paraview-data = 0:3.2.1-6.fc9

package: paraview-mpi-3.2.1-6.fc9.i386 from fedora-9-x86_64
unresolved deps:
paraview-data = 0:3.2.1-6.fc9


? These are old versions...


$ yum list paraview*
Loaded plugins: dellsysidplugin, downloadonly
Installed Packages
paraview.i386 3.2.2-1.fc9 installed
paraview-data.i386 3.2.2-1.fc9 installed
Available Packages
paraview-devel.i386 3.2.2-1.fc9
updates-newkey
paraview-mpi.i386 3.2.2-1.fc9
updates-newkey

paraview-mpi-devel.i386 3.2.1-6.fc9 fedora

Ah, so I dropped paraview-mpi-devel, but I obsolete/provide it in
paraview-devel:


%package devel
Summary: Development files for ParaView
Group: Applications/Engineering
Requires: %{name} = %{version}-%{release}
Obsoletes: %{name}-mpi-devel < %{version}-%{release}
Provides: %{name}-mpi-devel = %{version}-%{release}

So, what's up?

--
Orion Poplawski
Technical Manager 303-415-9701 x222
NWRA/CoRA Division FAX: 303-415-9702
3380 Mitchell Lane orion@cora.nwra.com
Boulder, CO 80301 http://www.cora.nwra.com

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 10-23-2008, 10:10 PM
Michael Schwendt
 
Default Broken dependencies in Fedora 9 - 2008-10-23

On Thu, 23 Oct 2008 15:56:51 -0600, Orion Poplawski wrote:

> Michael Schwendt wrote:
> > Your following packages in the repository suffer from broken dependencies:
> >
> > ================================================== ====================
> > The results in this summary consider Test Updates!
> > ================================================== ====================
> >
> > package: paraview-3.2.1-6.fc9.i386 from fedora-9-x86_64
> > unresolved deps:
> > paraview-data = 0:3.2.1-6.fc9
> >
> > package: paraview-mpi-3.2.1-6.fc9.i386 from fedora-9-x86_64
> > unresolved deps:
> > paraview-data = 0:3.2.1-6.fc9
>
> ? These are old versions...
>
>
> $ yum list paraview*
> Loaded plugins: dellsysidplugin, downloadonly
> Installed Packages
> paraview.i386 3.2.2-1.fc9 installed
> paraview-data.i386 3.2.2-1.fc9 installed
> Available Packages
> paraview-devel.i386 3.2.2-1.fc9
> updates-newkey
> paraview-mpi.i386 3.2.2-1.fc9
> updates-newkey
> paraview-mpi-devel.i386 3.2.1-6.fc9 fedora

That's the wrong arch repo.

> Ah, so I dropped paraview-mpi-devel, but I obsolete/provide it in
> paraview-devel:
>
> %package devel
> Summary: Development files for ParaView
> Group: Applications/Engineering
> Requires: %{name} = %{version}-%{release}
> Obsoletes: %{name}-mpi-devel < %{version}-%{release}
> Provides: %{name}-mpi-devel = %{version}-%{release}
>
> So, what's up?

See bodhi comment. This is multiarch breakage. paraview-mpi.i386 no
longer is made available for x86_64 because of your modified inter-package
dependencies.

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 10-24-2008, 12:21 AM
Jens Petersen
 
Default Broken dependencies in Fedora 9 - 2008-10-23

> package: scim-bridge-qt-0.4.15-5.fc9.i386 from fedora-9-x86_64
> unresolved deps:
> scim-bridge = 0:0.4.15-5.fc9

Yes, it seems scim-bridge-0.4.15-8.fc9 in f9 updates was not pushed multilib...

Should we open a ticket with releng about that?

Jens

ps CC me or the package owner in case we miss followups.

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 09:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org