FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 10-17-2008, 02:39 PM
Matthias Clasen
 
Default Updating gtksourceview

On Fri, 2008-10-17 at 16:16 +0200, Denis Leroy wrote:
> I just realized that F-10 is going to ship with a very old version of
> gtksourceview (18-month old 1.8.5, while latest is 2.4). Is there a
> specific reason for that ?
>
> I would like to push updates for glom that require the 2.0 API. I see
> about 10 dependent packages for libgtksourceview-1.0.so.0, some of which
> already support the 2.0 API. We're left with the following packages with
> hard 1.0 API dependencies :
>
> - ocaml-lablgtk
> - gnome-python2-gtksourceview
> - mathmap
> - conglomerate
> - libgnomedb
> - scratchpad
>
> So either we'll have to write patches, or create a
> compat-gtksourceview10 package. Does anyone know the work involved to
> port from the 1.0 to the 2.0 API ?
>
> -denis

gtksourceview2

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 10-17-2008, 02:42 PM
Denis Leroy
 
Default Updating gtksourceview

Matthias Clasen wrote:

On Fri, 2008-10-17 at 16:16 +0200, Denis Leroy wrote:
I just realized that F-10 is going to ship with a very old version of
gtksourceview (18-month old 1.8.5, while latest is 2.4). Is there a
specific reason for that ?


I would like to push updates for glom that require the 2.0 API. I see
about 10 dependent packages for libgtksourceview-1.0.so.0, some of which
already support the 2.0 API. We're left with the following packages with
hard 1.0 API dependencies :


- ocaml-lablgtk
- gnome-python2-gtksourceview
- mathmap
- conglomerate
- libgnomedb
- scratchpad

So either we'll have to write patches, or create a
compat-gtksourceview10 package. Does anyone know the work involved to
port from the 1.0 to the 2.0 API ?


-denis


gtksourceview2


Don't know how I missed it. nothing to see here, carry along :-)


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 06:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org