FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 08-14-2008, 09:41 PM
Vnpenguin
 
Default Missing Dependency: mktemp ?

Hi all,
I'm using pungi to build a Fedora9-based customized installation CD.
Some week ago, it works no problem. But now, with update, I can not
run /usr/lib/anaconda-runtime/buildinstall, here are errors:

Pungi.Pungi.DEBUG: Running buildinstall...
/tmp/buildinstall.tree.Zgd5Dz /tmp
/tmp
Building images...
Assembling package list...
Thu Aug 14 23:24:36 CEST 2008 Expanding text packages...
1:initscripts-8.76.2-1.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp is needed by package
1:initscripts-8.76.2-1.i386 (anacondarepo)
5:metacity-2.22.0-3.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: redhat-artwork >= 0.62 is needed by package
5:metacity-2.22.0-3.fc9.i386 (an
acondarepo)
mkinitrd-6.0.52-2.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp >= 1.5-5 is needed by package
mkinitrd-6.0.52-2.fc9.i386 (anacondarep
o)
mkinitrd-6.0.52-2.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp >= 1.5-5 is needed by package
mkinitrd-6.0.52-2.fc9.i386 (anacondarep
o)
1:bash-3.2-22.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp is needed by package
1:bash-3.2-22.fc9.i386 (anacondarepo)
openssl-0.9.8g-9.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp is needed by package
openssl-0.9.8g-9.fc9.i386 (anacondarepo)
grub-0.97-33.fc9.i386 from anacondarepo has depsolving problems
--> Missing Dependency: mktemp is needed by package
grub-0.97-33.fc9.i386 (anacondarepo)
gzip-1.3.12-6.fc9.i386 from anacondarepo has depsolving problems
...

I can not found "mktemp" rpm package in Fedora repo
Anyone has same problem ?

Thanks


--
http://vnoss.org

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 08-15-2008, 06:27 AM
David Tardon
 
Default Missing Dependency: mktemp ?

On Thu, Aug 14, 2008 at 11:41:07PM +0200, Vnpenguin wrote:
> Hi all,
> I'm using pungi to build a Fedora9-based customized installation CD.
> Some week ago, it works no problem. But now, with update, I can not
> run /usr/lib/anaconda-runtime/buildinstall, here are errors:
>
> Pungi.Pungi.DEBUG: Running buildinstall...
> /tmp/buildinstall.tree.Zgd5Dz /tmp
> /tmp
> Building images...
> Assembling package list...
> Thu Aug 14 23:24:36 CEST 2008 Expanding text packages...
> 1:initscripts-8.76.2-1.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp is needed by package
> 1:initscripts-8.76.2-1.i386 (anacondarepo)
> 5:metacity-2.22.0-3.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: redhat-artwork >= 0.62 is needed by package
> 5:metacity-2.22.0-3.fc9.i386 (an
> acondarepo)
> mkinitrd-6.0.52-2.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp >= 1.5-5 is needed by package
> mkinitrd-6.0.52-2.fc9.i386 (anacondarep
> o)
> mkinitrd-6.0.52-2.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp >= 1.5-5 is needed by package
> mkinitrd-6.0.52-2.fc9.i386 (anacondarep
> o)
> 1:bash-3.2-22.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp is needed by package
> 1:bash-3.2-22.fc9.i386 (anacondarepo)
> openssl-0.9.8g-9.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp is needed by package
> openssl-0.9.8g-9.fc9.i386 (anacondarepo)
> grub-0.97-33.fc9.i386 from anacondarepo has depsolving problems
> --> Missing Dependency: mktemp is needed by package
> grub-0.97-33.fc9.i386 (anacondarepo)
> gzip-1.3.12-6.fc9.i386 from anacondarepo has depsolving problems
> ...
>
> I can not found "mktemp" rpm package in Fedora repo
> Anyone has same problem ?
>

Hi,
/bin/mktemp is part of coreutils now (starting by 6.1, I think).

David

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 04:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org