FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 07-01-2008, 09:39 AM
"Richard W.M. Jones"
 
Default Dependencies breakage in released Fedora versions (twice now)

On Tue, Jul 01, 2008 at 11:42:28AM +0200, Hans de Goede wrote:
> Hans de Goede wrote:
>> Hi All,
>>
>> The last week I've had bugs filed twice against packages I maintain
>> because their dependencies had broken, and this is not with rawhide but in
>> F-9 and F-8 !!
>
> I've just learned that the rrdtool update breaks 2 more packages, bad bad bad!

.. and collectd.

Rich.

--
Richard Jones, Emerging Technologies, Red Hat http://et.redhat.com/~rjones
virt-top is 'top' for virtual machines. Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.
http://et.redhat.com/~rjones/virt-top

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 07-01-2008, 09:42 AM
Hans de Goede
 
Default Dependencies breakage in released Fedora versions (twice now)

Hans de Goede wrote:

Hi All,

The last week I've had bugs filed twice against packages I maintain
because their dependencies had broken, and this is not with rawhide but
in F-9 and F-8 !!




I've just learned that the rrdtool update breaks 2 more packages, bad bad bad!

Regards,

Hans

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 07-01-2008, 09:42 AM
Joe Orton
 
Default Dependencies breakage in released Fedora versions (twice now)

On Tue, Jul 01, 2008 at 09:59:33AM +0200, Hans de Goede wrote:
> One of these 2 breakages was due to a php version bump for security
> reasons, and I can live with that. One kind request to Joe Orton (in the
> CC) though, next time if you have the time please remember that
> maniadrive has a full versioned dependency on php and will break with
> each upstream version change. All my packages are wide open so next time
> please feel free to rebuild maniadrive and include it in the update.

Sure - sorry, I keep forgetting I need to do this.

joe

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 07-01-2008, 10:45 AM
Ignacio Vazquez-Abrams
 
Default Dependencies breakage in released Fedora versions (twice now)

On Tue, 2008-07-01 at 09:59 +0200, Hans de Goede wrote:
> Perhaps we can add a dependency check in bodhi, or if that slows bodhi down to
> much atleast run the dep-checking script currently run on rawhide also on "F-x
> + upodates + updates-testing", running the dep-checking script on "F-x +
> upodates + updates-testing" would have caught both these dep breakages as both
> packages have gone through testing first.

https://fedorahosted.org/bodhi/ticket/79

--
Ignacio Vazquez-Abrams <ivazqueznet@gmail.com>

PLEASE don't CC me; I'm already subscribed
--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 04:21 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org