FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development

 
 
LinkBack Thread Tools
 
Old 06-03-2008, 05:54 PM
Mamoru Tasaka
 
Default strange koji build failures...?

Eric Sandeen wrote, at 06/04/2008 01:50 AM +9:00:

Trying to get newer ecryptfs-utils built I'm seeing something odd (or
not seeing something obvious...)

http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log


I just tried scratch build and it was all successful...
http://koji.fedoraproject.org/koji/taskinfo?taskID=643448

Mamoru

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-03-2008, 06:04 PM
Eric Sandeen
 
Default strange koji build failures...?

Mamoru Tasaka wrote:
> Eric Sandeen wrote, at 06/04/2008 01:50 AM +9:00:
>> Trying to get newer ecryptfs-utils built I'm seeing something odd (or
>> not seeing something obvious...)
>>
>> http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log
>
> I just tried scratch build and it was all successful...
> http://koji.fedoraproject.org/koji/taskinfo?taskID=643448
>
> Mamoru
>

My scratch builds also were successful... and now a proper build was too.

I think maybe there's a race somewhere... ?

-Eric

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-03-2008, 06:30 PM
Tim Jackson
 
Default strange koji build failures...?

Eric Sandeen wrote:

Trying to get newer ecryptfs-utils built I'm seeing something odd (or
not seeing something obvious...)

http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log

for things like this in the specfile:

%doc README COPYING AUTHORS NEWS THANKS


Yes, me too on x86_64.

http://koji.fedoraproject.org/koji/getfile?taskID=643592&name=build.log

Tim

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 01:09 AM
Matthias Clasen
 
Default strange koji build failures...?

On Tue, 2008-06-03 at 13:04 -0500, Eric Sandeen wrote:
> Mamoru Tasaka wrote:
> > Eric Sandeen wrote, at 06/04/2008 01:50 AM +9:00:
> >> Trying to get newer ecryptfs-utils built I'm seeing something odd (or
> >> not seeing something obvious...)
> >>
> >> http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log
> >
> > I just tried scratch build and it was all successful...
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=643448
> >
> > Mamoru
> >
>
> My scratch builds also were successful... and now a proper build was too.
>
> I think maybe there's a race somewhere... ?

Any insight on this ? I'm seeing quite a few of my builds fail in the
same way, with 'setting times of `<some file>' errors from cp or touch.
The latest is:

http://koji.fedoraproject.org/koji/getfile?taskID=644137&name=build.log

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 02:45 AM
Mamoru Tasaka
 
Default strange koji build failures...?

Matthias Clasen wrote, at 06/04/2008 10:09 AM +9:00:
> On Tue, 2008-06-03 at 13:04 -0500, Eric Sandeen wrote:
>>> Eric Sandeen wrote, at 06/04/2008 01:50 AM +9:00:
>>>> Trying to get newer ecryptfs-utils built I'm seeing something odd (or
>>>> not seeing something obvious...)
>>>>
>>>> http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log
> Any insight on this ? I'm seeing quite a few of my builds fail in the
> same way, with 'setting times of `<some file>' errors from cp or touch.
> The latest is:
>
> http://koji.fedoraproject.org/koji/getfile?taskID=644137&name=build.log

Another example:
https://bugzilla.redhat.com/show_bug.cgi?id=449328#c4
http://koji.fedoraproject.org/koji/getfile?taskID=644003&name=build.log

It seems that something strange is really happening..

Mamoru

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 04:36 AM
Ray Van Dolson
 
Default strange koji build failures...?

On Tue, Jun 03, 2008 at 09:09:48PM -0400, Matthias Clasen wrote:
> On Tue, 2008-06-03 at 13:04 -0500, Eric Sandeen wrote:
> > Mamoru Tasaka wrote:
> > > Eric Sandeen wrote, at 06/04/2008 01:50 AM +9:00:
> > >> Trying to get newer ecryptfs-utils built I'm seeing something odd (or
> > >> not seeing something obvious...)
> > >>
> > >> http://koji.fedoraproject.org/koji/getfile?taskID=643262&name=build.log
> > >
> > > I just tried scratch build and it was all successful...
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=643448
> > >
> > > Mamoru
> > >
> >
> > My scratch builds also were successful... and now a proper build was too.
> >
> > I think maybe there's a race somewhere... ?
>
> Any insight on this ? I'm seeing quite a few of my builds fail in the
> same way, with 'setting times of `<some file>' errors from cp or touch.
> The latest is:
>
> http://koji.fedoraproject.org/koji/getfile?taskID=644137&name=build.log

I had some weird build issues today. Seemed to fail only on the
rawhide build and only with x86_64. It seemed to be erroring out in
%doc trying to copy the README.txt file -- kind of like it was missing.
I re-uploaded the source file and ran the build again and it worked
fine at last...

Two initial failed builds:

http://koji.fedoraproject.org/koji/taskinfo?taskID=643987
http://koji.fedoraproject.org/koji/taskinfo?taskID=644076

Build that succeeded after re-uploading the source portion:

http://koji.fedoraproject.org/koji/taskinfo?taskID=644117

Everything had built fine and error free in my local x86_64 rawhide
mock setup, so I was _pretty_ sure my package wasn't bad.

Ray

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 04:42 AM
Eric Sandeen
 
Default strange koji build failures...?

Ray Van Dolson wrote:

> I had some weird build issues today. Seemed to fail only on the
> rawhide build and only with x86_64. It seemed to be erroring out in
> %doc trying to copy the README.txt file -- kind of like it was missing.
> I re-uploaded the source file and ran the build again and it worked
> fine at last...
>
> Two initial failed builds:
>
> http://koji.fedoraproject.org/koji/taskinfo?taskID=643987
> http://koji.fedoraproject.org/koji/taskinfo?taskID=644076
>
> Build that succeeded after re-uploading the source portion:
>
> http://koji.fedoraproject.org/koji/taskinfo?taskID=644117
>
> Everything had built fine and error free in my local x86_64 rawhide
> mock setup, so I was _pretty_ sure my package wasn't bad.

Mine also only failed on x86_64 rawhide, as are the other failures I've
seen. Interesting...

Since it is cp failing I can't help but notice that coreutils was just
upgraded to a new upstream version today... coincidence?

-Eric

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 04:56 AM
Ray Van Dolson
 
Default strange koji build failures...?

On Tue, Jun 03, 2008 at 11:42:55PM -0500, Eric Sandeen wrote:
> Ray Van Dolson wrote:
>
> > I had some weird build issues today. Seemed to fail only on the
> > rawhide build and only with x86_64. It seemed to be erroring out in
> > %doc trying to copy the README.txt file -- kind of like it was missing.
> > I re-uploaded the source file and ran the build again and it worked
> > fine at last...
> >
> > Two initial failed builds:
> >
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=643987
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=644076
> >
> > Build that succeeded after re-uploading the source portion:
> >
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=644117
> >
> > Everything had built fine and error free in my local x86_64 rawhide
> > mock setup, so I was _pretty_ sure my package wasn't bad.
>
> Mine also only failed on x86_64 rawhide, as are the other failures I've
> seen. Interesting...
>
> Since it is cp failing I can't help but notice that coreutils was just
> upgraded to a new upstream version today... coincidence?

Is the mock setup on koji different from the one my mock syncs up
again? My mock is querying the "default" Fedora mirrors setup for the
latest rawhide stuff.

Perhaps the coreutils on Koji's mock pulls from somewhere else...

Ray

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 05:18 AM
Mamoru Tasaka
 
Default strange koji build failures...?

Ray Van Dolson wrote, at 06/04/2008 01:56 PM +9:00:

On Tue, Jun 03, 2008 at 11:42:55PM -0500, Eric Sandeen wrote:

Ray Van Dolson wrote:


I had some weird build issues today. Seemed to fail only on the
rawhide build and only with x86_64. It seemed to be erroring out in
%doc trying to copy the README.txt file -- kind of like it was missing.
I re-uploaded the source file and ran the build again and it worked
fine at last...

Two initial failed builds:

http://koji.fedoraproject.org/koji/taskinfo?taskID=643987
http://koji.fedoraproject.org/koji/taskinfo?taskID=644076

Build that succeeded after re-uploading the source portion:

http://koji.fedoraproject.org/koji/taskinfo?taskID=644117

Everything had built fine and error free in my local x86_64 rawhide
mock setup, so I was _pretty_ sure my package wasn't bad.

Mine also only failed on x86_64 rawhide, as are the other failures I've
seen. Interesting...

Since it is cp failing I can't help but notice that coreutils was just
upgraded to a new upstream version today... coincidence?


Maybe coreutils-6.12-1.fc10 should be untagged?



Is the mock setup on koji different from the one my mock syncs up
again? My mock is querying the "default" Fedora mirrors setup for the
latest rawhide stuff.

Perhaps the coreutils on Koji's mock pulls from somewhere else...

Ray


Yes, rawhide coreutils is still 6.11-4.fc10, where koji dist-f10 coreutils
is already coreutils-6.12-1.fc10. You can enable [local] repo in
/etc/mock/fedora-rawhide-XXX.cfg

Mamoru


--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 
Old 06-04-2008, 08:26 AM
Alex Lancaster
 
Default strange koji build failures...?

"MT" == Mamoru Tasaka writes:

[...]

MT> Maybe coreutils-6.12-1.fc10 should be untagged?

> Is the mock setup on koji different from the one my mock syncs up
> again? My mock is querying the "default" Fedora mirrors setup for the
> latest rawhide stuff.
>
> Perhaps the coreutils on Koji's mock pulls from somewhere else...
>
> Ray

MT> Yes, rawhide coreutils is still 6.11-4.fc10, where koji dist-f10
MT> coreutils is already coreutils-6.12-1.fc10. You can enable [local]
MT> repo in /etc/mock/fedora-rawhide-XXX.cfg

I can also confirm two similar build failures, both with "touch":

f-spot:
http://koji.fedoraproject.org/koji/getfile?taskID=644642&name=build.log

perl-Convert-Binary-C:
http://koji.fedoraproject.org/koji/getfile?taskID=644607&name=build.log

Alex

--
fedora-devel-list mailing list
fedora-devel-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-devel-list
 

Thread Tools




All times are GMT. The time now is 06:00 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org