FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development Java

 
 
LinkBack Thread Tools
 
Old 04-29-2012, 09:44 AM
Johannes Lips
 
Default multiple dependencies installed during yum update

I think it would help if you could attach the output of the yum update.
So that one could see which package pulled in those deps and if there is
something wrong with it.


Johannes
On 04/29/2012 10:14 AM, Guido Grazioli wrote:

Hello, today after running, as usual, yum update --skip-broken on rawhide,
i got several java packages installed as dependencies, I mean about
40 megs of rpms, some ant-, a lot of jetty-, mongo-, lucene-contrib,
some felix-, down to some eclipse-).
I can post the full list if needed.

The only java packages I had installed in rawhide before the update were:
jetty, jboss-, maven- and their dependencies (and openjdk).

Is all that an intended behaviour?
Guido


--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 04-29-2012, 11:46 AM
Guido Grazioli
 
Default multiple dependencies installed during yum update

Il 29 aprile 2012 19:44, Johannes Lips ha scritto:
> I think it would help if you could attach the output of the yum update. So
> that one could see which package pulled in those deps and if there is
> something wrong with it.
>
> Johannes
>


Here is output of yum history info:
http://guidograzioli.fedorapeople.org/yum-20120429.txt

It seems that update of jetty from 8.1.0-5 to 8.1.2-3 brought in
jetty-osgi, which in turn requires eclipse-platform, and most
dependencies were eclipse-platform dependencies.


--
Guido Grazioli <guido.grazioli@gmail.com>
Via Parri 11 48011 - Alfonsine (RA) (Italy)
3 Baltic Circuit - 3030 Point Cook - VIC (Australia)
Mobile: +39 347 1017202 (10-18 GMT+12)
Key FP = 7040 F398 0DED A737 7337* DAE1 12DC A698 5E81 2278
Linked in: http://www.linkedin.com/in/guidograzioli
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 04-30-2012, 07:47 AM
Stanislav Ochotnicky
 
Default multiple dependencies installed during yum update

Quoting Guido Grazioli (2012-04-29 13:46:39)
> Il 29 aprile 2012 19:44, Johannes Lips ha scritto:
> > I think it would help if you could attach the output of the yum update. So
> > that one could see which package pulled in those deps and if there is
> > something wrong with it.
> >
> > Johannes
> >
>
>
> Here is output of yum history info:
> http://guidograzioli.fedorapeople.org/yum-20120429.txt
>
> It seems that update of jetty from 8.1.0-5 to 8.1.2-3 brought in
> jetty-osgi, which in turn requires eclipse-platform, and most
> dependencies were eclipse-platform dependencies.

jetty has been split into several sub-packages, jetty-osgi being the
largest with eclipse dependencies. I believe eclipse-platform Requires
is a bug and/or can be replaced by a different package.

In any case: jetty is being worked on right now. This was a problem of
pulling in jetty-osgi in the first place. I'll fix it in the next
revision with few additional fixes

--
Stanislav Ochotnicky <sochotnicky@redhat.com>
Software Engineer - Base Operating Systems Brno

PGP: 7B087241
Red Hat Inc. http://cz.redhat.com
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 

Thread Tools




All times are GMT. The time now is 05:44 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org