FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development Java

 
 
LinkBack Thread Tools
 
Old 12-15-2010, 02:47 PM
Stanislav Ochotnicky
 
Default Orphaning of classpathx-jaf

Hi,

I noticed you recently retired classpathx-jaf. There are still quite a
few packages requiring this package though:
$ repoquery --whatrequires classpathx-jaf
classpathx-jaf-0:1.0-15.1.fc12.x86_64
ant-javamail-0:1.7.1-12.fc12.x86_64
ant-javamail-0:1.7.1-13.fc13.x86_64
axis-0:1.2.1-7.fc12.x86_64
classpathx-mail-0:1.1.1-9.1.fc12.x86_64
dumbster-0:1.6-9.fc12.noarch
ec2-api-tools-0:1.3.53907-3.fc14.noarch
javatar-0:2.5-2.fc13.x86_64
mx4j-1:3.0.1-9.9.fc12.x86_64
mx4j-1:3.0.1-9.11.fc13.noarch
tomcat5-0:5.5.27-7.4.fc12.noarch
+ gdata-java for BR

Unfortunately dead.package contents don't help me much:
$ cat dead.package
Obsolete package."

When you are retiring a package it's considered common courtesy to let
other stakeholders know about it. Care to elaborate what happened?

--
Stanislav Ochotnicky <sochotnicky@redhat.com>
Associate Software Engineer - Base Operating Systems Brno

PGP: 71A1677C
Red Hat Inc. http://cz.redhat.com

--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 12-15-2010, 03:11 PM
Stanislav Ochotnicky
 
Default Orphaning of classpathx-jaf

On 12/15/2010 04:47 PM, Stanislav Ochotnicky wrote:
> Hi,
>
> I noticed you recently retired classpathx-jaf. There are still quite a
> few packages requiring this package though:
> $ repoquery --whatrequires classpathx-jaf
> classpathx-jaf-0:1.0-15.1.fc12.x86_64
> ant-javamail-0:1.7.1-12.fc12.x86_64
> ant-javamail-0:1.7.1-13.fc13.x86_64
> axis-0:1.2.1-7.fc12.x86_64
> classpathx-mail-0:1.1.1-9.1.fc12.x86_64
> dumbster-0:1.6-9.fc12.noarch
> ec2-api-tools-0:1.3.53907-3.fc14.noarch
> javatar-0:2.5-2.fc13.x86_64
> mx4j-1:3.0.1-9.9.fc12.x86_64
> mx4j-1:3.0.1-9.11.fc13.noarch
> tomcat5-0:5.5.27-7.4.fc12.noarch
> + gdata-java for BR

Ah, sorry. This is actually only javatar and gdata-java in rawhide.
Still it would have been nicer if you would send email to their owners
first :-)

javatar itself was fixed already in rawhide by orionp by requiring java
>= 1:1.6.0 (that's the information that should have been in dead.package
IMO).


--
Stanislav Ochotnicky <sochotnicky@redhat.com>
Associate Software Engineer - Base Operating Systems Brno

PGP: 71A1677C
Red Hat Inc. http://cz.redhat.com

--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 12-15-2010, 05:24 PM
Alexander Kurtakov
 
Default Orphaning of classpathx-jaf

On 08:21:08 pm Wednesday, December 15, 2010 Stanislav Ochotnicky wrote:
> On 12/15/2010 04:47 PM, Stanislav Ochotnicky wrote:
> > Hi,
> >
> > I noticed you recently retired classpathx-jaf. There are still quite a
> >
> > few packages requiring this package though:
> > $ repoquery --whatrequires classpathx-jaf
> >
> > classpathx-jaf-0:1.0-15.1.fc12.x86_64
> > ant-javamail-0:1.7.1-12.fc12.x86_64
> > ant-javamail-0:1.7.1-13.fc13.x86_64
> > axis-0:1.2.1-7.fc12.x86_64
> > classpathx-mail-0:1.1.1-9.1.fc12.x86_64
> > dumbster-0:1.6-9.fc12.noarch
> > ec2-api-tools-0:1.3.53907-3.fc14.noarch
> > javatar-0:2.5-2.fc13.x86_64
> > mx4j-1:3.0.1-9.9.fc12.x86_64
> > mx4j-1:3.0.1-9.11.fc13.noarch
> > tomcat5-0:5.5.27-7.4.fc12.noarch
> > + gdata-java for BR
>
> Ah, sorry. This is actually only javatar and gdata-java in rawhide.
> Still it would have been nicer if you would send email to their owners
> first :-)
>
> javatar itself was fixed already in rawhide by orionp by requiring java
>
> >= 1:1.6.0 (that's the information that should have been in dead.package
>
> IMO).

Sorry about that. It's entirely my fault. Classpathx-jaf has been merged into
gcj long long time ago. It is now obsoleted by java-1.5.0-gcj but not provided
in order to not having do this for every JVM out there. You don't need to BR
java >=1:1.6.0 but just >= 1:1.5.0 .
Every occurance of jaf should be simply removed as we no longer ship pre 1.5
JVMs.

P.S. I'm the one that added the obsolete and asked devrim to deprecate it.

Regards,
Alex
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 

Thread Tools




All times are GMT. The time now is 06:45 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org