FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Development Java

 
 
LinkBack Thread Tools
 
Old 09-17-2010, 12:56 PM
Edmon Begoli
 
Default Help needed - errors while building rpm from srpm

Hi,

I used commons-codec as well as previous version of the htmlunit to
create a new .spec file.

I did SRPM build on FC13.

Here are the issues I encountered:

1. My package POM file requires maven-release-plugin. On F13 I could
not find any maven plugin that has to do with
maven and release (sudo yum search maven | grep release)

2. When I build the srpm (rpmbuild -bs --clean htmlunit.spec) I get
srpm built but when I try to build rpm or to install rpm
I get this:

$ rpmbuild --ba --clean SPECS/htmlunit.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.OqRY17
+ umask 022
+ cd /home/edmon/rpmbuild/BUILD
+ cd /home/edmon/rpmbuild/BUILD
+ rm -rf htmlunit-2.7
+ /usr/bin/gzip -dc /home/edmon/rpmbuild/SOURCES/htmlunit-2.7-1.tar.gz
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd htmlunit-2.7
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.3IIwbQ
+ umask 022
+ cd /home/edmon/rpmbuild/BUILD
+ cd htmlunit-2.7
++ pwd
+ export MAVEN_REPO_LOCAL=/home/edmon/rpmbuild/BUILD/htmlunit-2.7/.m2/repository
+ MAVEN_REPO_LOCAL=/home/edmon/rpmbuild/BUILD/htmlunit-2.7/.m2/repository
+ mkdir -p /home/edmon/rpmbuild/BUILD/htmlunit-2.7/.m2/repository
+ mvn-jpp -Dmaven.repo.local=/home/edmon/rpmbuild/BUILD/htmlunit-2.7/.m2/repository
install javadoc:javadoc
/usr/lib/jvm/java
/usr/share/maven2/bin/mvn: line 157: /usr/lib/jvm/java/bin/java: Success
error: Bad exit status from /var/tmp/rpm-tmp.3IIwbQ (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.3IIwbQ (%build)

My most recent srpm and spec files are on:
http://ebegoli.fedorapeople.org/htmlunit-2.7-1.src.rpm
http://ebegoli.fedorapeople.org/htmlunit.spec

If you could, would you please take a look at what I may be doing
wrong (or if the absence of maven-release-plugin may
be an issue).

Thank you in advance,
Edmon
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 09-17-2010, 01:42 PM
Guido Grazioli
 
Default Help needed - errors while building rpm from srpm

2010/9/17 Edmon Begoli <ebegoli@gmail.com>:
> Hi,
>
> I used commons-codec as well as previous version of the htmlunit to
> create a new .spec file.
>
> I did SRPM build on FC13.
>
> Here are the issues I encountered:
>
> 1. My package POM file requires maven-release-plugin. On F13 I could
> not find any maven plugin that has to do with
> * *maven and release (sudo yum search maven | grep release)

Hello Edmon, i packaged maven-release but it's sitting only in F-14
(a pre-2.0 svn snapshot) and rawhide (release tagged 2.0) right now.
It contains both maven-release-manager and maven-release-plugin

>
> 2. When I build the srpm (rpmbuild -bs --clean htmlunit.spec) I get
> srpm built but when I try to build rpm or to install rpm
> * I get this:
>
> $ rpmbuild --ba --clean SPECS/htmlunit.spec

The logs doesnt tell that much, try invoking mvn-jpp with the -X flag to get
the exception.

Your specfile needs some work beside the failing build:
- URL should be the webpage of the project
- Source should point to the actual download url:
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
- you should Require: java
- groupId in %add_to_maven_depmap is net.sourceforge.htmlunit
- verrel in changelog is 2.7-1 not 1:2.7


cheers,
Guido
--
Guido Grazioli <guido.grazioli@gmail.com>
Via Parri 11 48011 - Alfonsine (RA)
Mobile: +39 347 1017202 (10-18)
Key FP = 7040 F398 0DED A737 7337* DAE1 12DC A698 5E81 2278
Linked in: http://www.linkedin.com/in/guidograzioli
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 09-21-2010, 12:53 PM
Edmon Begoli
 
Default Help needed - errors while building rpm from srpm

Guido,

Would you point me to the link/location where I can download the most
recent working version
of maven-release-plugin that I can use for building my package(s).

Thank you,
Edmon

On Fri, Sep 17, 2010 at 9:42 AM, Guido Grazioli
<guido.grazioli@gmail.com> wrote:
> 2010/9/17 Edmon Begoli <ebegoli@gmail.com>:
>> Hi,
>>
>> I used commons-codec as well as previous version of the htmlunit to
>> create a new .spec file.
>>
>> I did SRPM build on FC13.
>>
>> Here are the issues I encountered:
>>
>> 1. My package POM file requires maven-release-plugin. On F13 I could
>> not find any maven plugin that has to do with
>> * *maven and release (sudo yum search maven | grep release)
>
> Hello Edmon, i packaged maven-release but it's sitting only in F-14
> (a pre-2.0 svn snapshot) and rawhide (release tagged 2.0) right now.
> It contains both maven-release-manager and maven-release-plugin
>
>>
>> 2. When I build the srpm (rpmbuild -bs --clean htmlunit.spec) I get
>> srpm built but when I try to build rpm or to install rpm
>> * I get this:
>>
>> $ rpmbuild --ba --clean SPECS/htmlunit.spec
>
> The logs doesnt tell that much, try invoking mvn-jpp with the -X flag to get
> the exception.
>
> Your specfile needs some work beside the failing build:
> - URL should be the webpage of the project
> - Source should point to the actual download url:
> Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
> - you should Require: java
> - groupId in %add_to_maven_depmap is net.sourceforge.htmlunit
> - verrel in changelog is 2.7-1 not 1:2.7
>
>
> cheers,
> Guido
> --
> Guido Grazioli <guido.grazioli@gmail.com>
> Via Parri 11 48011 - Alfonsine (RA)
> Mobile: +39 347 1017202 (10-18)
> Key FP = 7040 F398 0DED A737 7337* DAE1 12DC A698 5E81 2278
> Linked in: http://www.linkedin.com/in/guidograzioli
>
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 
Old 09-21-2010, 01:11 PM
Stanislav Ochotnicky
 
Default Help needed - errors while building rpm from srpm

Excerpts from Edmon Begoli's message of Tue Sep 21 14:53:39 +0200 2010:
> Would you point me to the link/location where I can download the most
> recent working version
> of maven-release-plugin that I can use for building my package(s).

You can find all builds of Fedora packages on koji[1]. maven-release can
be found there as well[2]

[1] http://koji.fedoraproject.org/koji
[2] http://koji.fedoraproject.org/koji/packageinfo?packageID=10354


--
Stanislav Ochotnicky <sochotnicky@redhat.com>
Associate Software Engineer - Base Operating Systems Brno

PGP: 71A1677C
Red Hat Inc. http://cz.redhat.com
--
java-devel mailing list
java-devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/java-devel
 

Thread Tools




All times are GMT. The time now is 10:40 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org