FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Build System

 
 
LinkBack Thread Tools
 
Old 05-06-2008, 04:07 PM
"William F. Acker WB2FLW +1-303-722-7209"
 
Default Unresolvable deps when building Rawhide.

Hi all,

When I do a Pungi run on an x86_64, I get the following.
Pungi.Gather:WARNING: Unresolvable dependency jakarta-commons-beanutils-javadoc in checkstyle.noarch
Pungi.Gather:INFO: Added jakarta-commons-beanutils.x86_64 for checkstyle.noarch
Pungi.Gather:WARNING: Unresolvable dependency antlr-javadoc in checkstyle.noarch
Pungi.Gather:INFO: Added jdom.x86_64 for checkstyle.noarch
Pungi.Gather:WARNING: Unresolvable dependency xml-commons-apis-javadoc in checkstyle.noarch
Pungi.Gather:WARNING: Unresolvable dependency ant-javadoc in checkstyle.noarch

I believe this is related to the last batch of package exclusions to
save space that appeared in the fedora-9 ks file with the latest version
of Pungi. Is this condition OK? Might it be possible for someone to
select the wrong package combination and have a failed installation, or
would this be caught when dependencies are checked


Thanks.
-- Bill in Denver

--
Fedora-buildsys-list mailing list
Fedora-buildsys-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-buildsys-list
 
Old 05-06-2008, 06:03 PM
Jesse Keating
 
Default Unresolvable deps when building Rawhide.

On Tue, 2008-05-06 at 10:07 -0600, William F. Acker WB2FLW
+1-303-722-7209 wrote:
>
> When I do a Pungi run on an x86_64, I get the following.
> Pungi.Gather:WARNING: Unresolvable dependency
> jakarta-commons-beanutils-javadoc in checkstyle.noarch
> Pungi.Gather:INFO: Added jakarta-commons-beanutils.x86_64 for
> checkstyle.noarch
> Pungi.Gather:WARNING: Unresolvable dependency antlr-javadoc in
> checkstyle.noarch
> Pungi.Gather:INFO: Added jdom.x86_64 for checkstyle.noarch
> Pungi.Gather:WARNING: Unresolvable dependency xml-commons-apis-javadoc
> in checkstyle.noarch
> Pungi.Gather:WARNING: Unresolvable dependency ant-javadoc in
> checkstyle.noarch
>
> I believe this is related to the last batch of package
> exclusions to
> save space that appeared in the fedora-9 ks file with the latest
> version
> of Pungi. Is this condition OK? Might it be possible for someone to
> select the wrong package combination and have a failed installation,
> or
> would this be caught when dependencies are checked
>

Hrm, that's odd. I could have sworn the code would allow for the deps
to be dragged in if they're asked for. You may have uncovered a bug in
pungi code... Can you file this in bugzilla or the pungi trac space?

--
Jesse Keating RHCE (jkeating.livejournal.com)
Fedora Project (fedoraproject.org/wiki/JesseKeating)
GPG Public Key (geek.j2solutions.net/jkeating.j2solutions.pub)
--
Fedora-buildsys-list mailing list
Fedora-buildsys-list@redhat.com
https://www.redhat.com/mailman/listinfo/fedora-buildsys-list
 

Thread Tools




All times are GMT. The time now is 01:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org