Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora Build System (http://www.linux-archive.org/fedora-build-system/)
-   -   cannot build packages after update (http://www.linux-archive.org/fedora-build-system/580418-cannot-build-packages-after-update.html)

Michael Cronenworth 09-26-2011 10:16 PM

cannot build packages after update
 
It seems koji-web is the least of my worries.

I cannot get Fedora 15 or RHEL5 packages to build in my, once working,
koji instance. I can queue the package build and yum downloads the
build-deps, but when the build starts I get messages such as:


Fedora 15 builds:
collect2: cannot find 'ld'

RHEL5 builds:
gcc: error trying to exec 'cc1': execvp: Permission denied

Note: The Koji builder has SELinux in permissive mode at the moment.

I am fixing to revert the package update I applied, but before I do I am
going to attach the list of updates I applied in hope someone sees a
possible update I can downgrade.


Thanks,
Michael
Sep 23 15:19:14 Updated: python-slip-0.2.17-1.fc14.noarch
Sep 23 15:19:15 Updated: python-slip-dbus-0.2.17-1.fc14.noarch
Sep 23 15:19:16 Updated: ca-certificates-2011.78-1.fc14.noarch
Sep 23 15:19:20 Updated: system-config-firewall-base-1.2.27-2.fc14.noarch
Sep 23 15:19:21 Updated: system-config-firewall-tui-1.2.27-2.fc14.noarch
Sep 23 15:19:29 Updated: tzdata-2011i-1.fc14.noarch
Sep 23 15:19:41 Updated: glibc-common-2.13-2.x86_64
Sep 23 15:19:51 Updated: glibc-2.13-2.x86_64
Sep 23 15:19:52 Updated: 1:dbus-libs-1.4.0-3.fc14.x86_64
Sep 23 15:19:53 Updated: 2:libpng-1.2.46-1.fc14.x86_64
Sep 23 15:19:58 Updated: openssl-1.0.0e-1.fc14.x86_64
Sep 23 15:19:59 Updated: freetype-2.4.2-5.fc14.x86_64
Sep 23 15:20:00 Updated: audit-libs-2.1.3-1.fc14.x86_64
Sep 23 15:20:01 Updated: php-common-5.3.8-1.fc14.x86_64
Sep 23 15:20:02 Updated: libjpeg-turbo-1.1.1-1.fc14.x86_64
Sep 23 15:20:07 Updated: gdk-pixbuf2-2.22.0-2.fc14.x86_64
Sep 23 15:20:10 Updated: 1:dbus-1.4.0-3.fc14.x86_64
Sep 23 15:20:11 Updated: avahi-libs-0.6.27-8.fc14.x86_64
Sep 23 15:20:12 Updated: libacl-2.2.49-9.fc14.x86_64
Sep 23 15:20:15 Updated: libcap-2.22-1.fc14.x86_64
Sep 23 15:20:16 Updated: 1:cups-libs-1.4.8-2.fc14.x86_64
Sep 23 15:20:17 Updated: PackageKit-yum-0.6.12-4.fc14.x86_64
Sep 23 15:20:17 Updated: PackageKit-glib-0.6.12-4.fc14.x86_64
Sep 23 15:20:26 Updated: PackageKit-0.6.12-4.fc14.x86_64
Sep 23 15:20:28 Updated: avahi-0.6.27-8.fc14.x86_64
Sep 23 15:20:30 Updated: 32:bind-libs-9.7.4-0.3.b1.fc14.x86_64
Sep 23 15:20:31 Updated: php-pdo-5.3.8-1.fc14.x86_64
Sep 23 15:20:33 Updated: 1:qt-4.7.3-8.fc14.x86_64
Sep 23 15:20:40 Updated: ruby-libs-1.8.7.352-1.fc14.x86_64
Sep 23 15:20:43 Updated: augeas-libs-0.9.0-1.fc14.x86_64
Sep 23 15:20:44 Updated: libudev-161-10.fc14.x86_64
Sep 23 15:20:50 Updated: udev-161-10.fc14.x86_64
Sep 23 15:20:51 Updated: libgudev1-161-10.fc14.x86_64
Sep 23 15:20:52 Updated: 1:NetworkManager-glib-0.8.4-2.git20110622.fc14.x86_64
Sep 23 15:20:54 Updated: nut-client-2.6.1-3.fc14.x86_64
Sep 23 15:20:55 Updated: netcf-libs-0.1.9-1.fc14.x86_64
Sep 23 15:20:59 Updated: libvirt-client-0.8.3-10.fc14.x86_64
Sep 23 15:21:04 Updated: 1:qt-x11-4.7.3-8.fc14.x86_64
Sep 23 15:21:07 Updated: avahi-glib-0.6.27-8.fc14.x86_64
Sep 23 15:21:10 Updated: acl-2.2.49-9.fc14.x86_64
Sep 23 15:21:20 Updated: 1:cups-1.4.8-2.fc14.x86_64
Sep 23 15:21:26 Updated: xulrunner-1.9.2.22-1.fc14.x86_64
Sep 23 15:21:28 Updated: php-cli-5.3.8-1.fc14.x86_64
Sep 23 15:21:29 Updated: audit-libs-python-2.1.3-1.fc14.x86_64
Sep 23 15:21:30 Updated: audit-2.1.3-1.fc14.x86_64
Sep 23 15:21:33 Updated: setroubleshoot-server-3.0.38-1.fc14.x86_64
Sep 23 15:21:34 Updated: mysql-libs-5.1.58-1.fc14.x86_64
Sep 23 15:21:35 Updated: corosynclib-1.4.1-2.fc14.x86_64
Sep 23 15:21:38 Updated: corosync-1.4.1-2.fc14.x86_64
Sep 23 15:21:38 Updated: 1:perl-Pod-Escapes-1.04-146.fc14.noarch
Sep 23 15:21:39 Updated: 4:perl-libs-5.12.4-146.fc14.x86_64
Sep 23 15:21:40 Updated: 1:perl-Module-Pluggable-3.90-146.fc14.noarch
Sep 23 15:21:41 Updated: 1:perl-Pod-Simple-3.13-146.fc14.noarch
Sep 23 15:21:42 Updated: perl-threads-shared-1.32-146.fc14.x86_64
Sep 23 15:22:00 Updated: 4:perl-5.12.4-146.fc14.x86_64
Sep 23 15:22:00 Updated: 1:perl-Digest-SHA-5.47-146.fc14.x86_64
Sep 23 15:22:00 Updated: avahi-autoipd-0.6.27-8.fc14.x86_64
Sep 23 15:22:01 Updated: 389-ds-base-libs-1.2.9.10-3.fc14.x86_64
Sep 23 15:22:04 Updated: libsndfile-1.0.25-1.fc14.x86_64
Sep 23 15:22:05 Updated: 2:ntfs-3g-2011.4.12-5.fc14.x86_64
Sep 23 15:22:05 Updated: 1:rmt-0.4-0.9.b43.fc14.x86_64
Sep 23 15:22:06 Updated: foomatic-filters-4.0.7-2.fc14.x86_64
Sep 23 15:22:06 Updated: 12:dhclient-4.2.0-23.P2.fc14.x86_64
Sep 23 15:22:10 Updated: 1:NetworkManager-0.8.4-2.git20110622.fc14.x86_64
Sep 23 15:22:11 Updated: logrotate-3.7.9-4.fc14.x86_64
Sep 23 15:22:14 Updated: rsyslog-4.6.3-3.fc14.x86_64
Sep 23 15:22:15 Updated: cronie-anacron-1.4.8-2.fc14.x86_64
Sep 23 15:22:16 Updated: cronie-1.4.8-2.fc14.x86_64
Sep 23 15:22:18 Updated: perl-ExtUtils-MakeMaker-6.56-146.fc14.noarch
Sep 23 15:22:23 Updated: perl-CPAN-1.9402-146.fc14.noarch
Sep 23 15:22:28 Updated: perl-Test-Harness-3.17-146.fc14.noarch
Sep 23 15:22:28 Updated: 1:perl-ExtUtils-ParseXS-2.2206-146.fc14.noarch
Sep 23 15:22:31 Updated: 4:perl-devel-5.12.4-146.fc14.x86_64
Sep 23 15:22:43 Installed: perl-DateTime-Locale-0.45-1.fc14.noarch
Sep 23 15:22:46 Updated: 1:perl-parent-0.223-146.fc14.noarch
Sep 23 15:22:51 Installed: perl-DateTime-TimeZone-1.36-1.fc14.noarch
Sep 23 15:22:52 Updated: 2:perl-DateTime-0.70-2.fc14.x86_64
Sep 23 15:22:53 Updated: hplip-common-3.11.7-2.fc14.x86_64
Sep 23 15:22:54 Updated: hplip-libs-3.11.7-2.fc14.x86_64
Sep 23 15:22:58 Updated: 1:hpijs-3.11.7-2.fc14.x86_64
Sep 23 15:22:58 Updated: 2:vim-filesystem-7.3.289-1.fc14.x86_64
Sep 23 15:23:09 Updated: 2:vim-common-7.3.289-1.fc14.x86_64
Sep 23 15:23:16 Updated: tzdata-java-2011i-1.fc14.noarch
Sep 23 15:23:51 Updated: 1:java-1.6.0-openjdk-1.6.0.0-54.1.9.9.fc14.x86_64
Sep 23 15:24:00 Updated: kernel-headers-2.6.35.14-96.fc14.x86_64
Sep 23 15:24:06 Updated: glibc-headers-2.13-2.x86_64
Sep 23 15:24:07 Updated: vlgothic-fonts-common-20110722-1.fc14.noarch
Sep 23 15:24:07 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-54.1.9.9.fc14.x86_64
Sep 23 15:24:08 Updated: 2:vim-enhanced-7.3.289-1.fc14.x86_64
Sep 23 15:24:12 Updated: hplip-3.11.7-2.fc14.x86_64
Sep 23 15:24:21 Updated: 1:NetworkManager-gnome-0.8.4-2.git20110622.fc14.x86_64
Sep 23 15:24:23 Updated: foomatic-4.0.7-2.fc14.x86_64
Sep 23 15:24:24 Updated: 1:dump-0.4-0.9.b43.fc14.x86_64
Sep 23 15:24:25 Installed: 2:ntfsprogs-2011.4.12-5.fc14.x86_64
Sep 23 15:24:25 Updated: libsndfile-utils-1.0.25-1.fc14.x86_64
Sep 23 15:24:33 Updated: 389-ds-base-1.2.9.10-3.fc14.x86_64
Sep 23 15:24:35 Updated: fence-agents-3.1.5-1.fc14.x86_64
Sep 23 15:24:38 Updated: php-mysql-5.3.8-1.fc14.x86_64
Sep 23 15:24:39 Updated: setroubleshoot-3.0.38-1.fc14.x86_64
Sep 23 15:24:40 Updated: php-5.3.8-1.fc14.x86_64
Sep 23 15:24:41 Updated: avahi-ui-0.6.27-8.fc14.x86_64
Sep 23 15:24:44 Updated: 1:qt-webkit-4.7.3-8.fc14.x86_64
Sep 23 15:24:45 Updated: nut-cgi-2.6.1-3.fc14.x86_64
Sep 23 15:24:49 Updated: nut-2.6.1-3.fc14.x86_64
Sep 23 15:24:50 Updated: PackageKit-device-rebind-0.6.12-4.fc14.x86_64
Sep 23 15:24:50 Updated: mdadm-3.1.3-0.git20100804.3.fc14.x86_64
Sep 23 15:24:53 Updated: ruby-1.8.7.352-1.fc14.x86_64
Sep 23 15:24:54 Updated: php-pgsql-5.3.8-1.fc14.x86_64
Sep 23 15:24:55 Updated: 32:bind-utils-9.7.4-0.3.b1.fc14.x86_64
Sep 23 15:24:59 Updated: 32:bind-9.7.4-0.3.b1.fc14.x86_64
Sep 23 15:25:02 Updated: avahi-compat-libdns_sd-0.6.27-8.fc14.x86_64
Sep 23 15:25:03 Updated: PackageKit-gstreamer-plugin-0.6.12-4.fc14.x86_64
Sep 23 15:25:03 Updated: PackageKit-gtk-module-0.6.12-4.fc14.x86_64
Sep 23 15:25:04 Updated: nscd-2.13-2.x86_64
Sep 23 15:25:05 Updated: libisofs-1.1.2-1.fc14.x86_64
Sep 23 15:25:06 Updated: 2:vim-minimal-7.3.289-1.fc14.x86_64
Sep 23 15:25:06 Updated: 1:dbus-x11-1.4.0-3.fc14.x86_64
Sep 23 15:25:07 Updated: unique-1.1.6-3.fc14.x86_64
Sep 23 15:25:11 Updated: evolution-data-server-2.32.3-1.fc14.x86_64
Sep 23 15:25:12 Updated: librsvg2-2.32.0-4.fc14.x86_64
Sep 23 15:25:13 Updated: scim-chewing-0.3.4-1.fc14.x86_64
Sep 23 15:25:14 Updated: libv4l-0.8.5-1.fc14.x86_64
Sep 23 15:25:14 Updated: php-gd-5.3.8-1.fc14.x86_64
Sep 23 15:25:15 Updated: php-ldap-5.3.8-1.fc14.x86_64
Sep 23 15:25:16 Updated: php-xml-5.3.8-1.fc14.x86_64
Sep 23 15:25:17 Updated: php-soap-5.3.8-1.fc14.x86_64
Sep 23 15:25:19 Updated: xorg-x11-drv-savage-2.3.2-3.fc14.x86_64
Sep 23 15:25:22 Updated: 12:dhcp-4.2.0-23.P2.fc14.x86_64
Sep 23 15:25:23 Updated: flashrom-0.9.4-1.svn1412.fc14.x86_64
Sep 23 15:25:24 Updated: pinentry-0.8.1-4.fc14.x86_64
Sep 23 15:25:25 Updated: SDL-1.2.14-11.fc14.x86_64
Sep 23 15:25:26 Updated: 2:ethtool-2.6.39-1.fc14.x86_64
Sep 23 15:25:27 Updated: at-3.1.12-6.fc14.x86_64
Sep 23 15:25:28 Updated: dosfstools-3.0.9-6.fc14.x86_64
Sep 23 15:25:29 Updated: libburn-1.1.0-1.fc14.x86_64
Sep 23 15:25:30 Updated: 1:libmodplug-0.8.8.4-1.fc14.x86_64
Sep 23 15:25:33 Updated: vlgothic-fonts-20110722-1.fc14.noarch
Sep 23 15:25:34 Updated: glibc-devel-2.13-2.x86_64
Sep 23 15:25:35 Updated: idm-console-framework-1.1.7-2.fc14.noarch
Sep 23 15:26:01 Installed: kernel-devel-2.6.35.14-96.fc14.x86_64
Sep 23 15:26:08 Updated: firefox-3.6.22-1.fc14.x86_64
Sep 23 15:26:08 Updated: PackageKit-yum-plugin-0.6.12-4.fc14.x86_64
Sep 23 15:26:09 Updated: 1:php-eaccelerator-0.9.6.1-9.fc14.x86_64
Sep 23 15:26:10 Updated: python-simplejson-2.1.6-1.fc14.1.x86_64
Sep 23 15:26:13 Updated: system-config-firewall-1.2.27-2.fc14.noarch
Sep 23 15:26:20 Updated: system-config-samba-1.2.93-1.fc14.noarch
Sep 23 15:26:22 Updated: system-config-date-1.9.65-1.fc14.noarch
Sep 23 15:26:22 Updated: python-slip-gtk-0.2.17-1.fc14.noarch
Sep 23 15:26:30 Updated: python-pygments-1.4-1.fc14.noarch
Sep 23 15:26:38 Updated: system-config-keyboard-1.3.1-5.fc14.x86_64
Sep 23 15:26:42 Updated: fedora-logos-14.0.2-1.fc14.noarch
Sep 23 15:26:44 Updated: system-config-lvm-1.1.16-1.fc14.noarch
Sep 23 15:26:49 Updated: mock-1.1.14-1.fc14.noarch
Sep 23 15:26:51 Updated: ql2400-firmware-5.06.01-1.fc14.noarch
Sep 23 15:26:52 Updated: python-IPy-0.75-1.fc14.noarch
Sep 23 15:27:06 Installed: kernel-2.6.35.14-96.fc14.x86_64

--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Dan Hor√°k 09-27-2011 06:47 AM

cannot build packages after update
 
Michael Cronenworth p√*Ň°e v Po 26. 09. 2011 v 17:16 -0500:
> It seems koji-web is the least of my worries.
>
> I cannot get Fedora 15 or RHEL5 packages to build in my, once working,
> koji instance. I can queue the package build and yum downloads the
> build-deps, but when the build starts I get messages such as:
>
> Fedora 15 builds:
> collect2: cannot find 'ld'
>
> RHEL5 builds:
> gcc: error trying to exec 'cc1': execvp: Permission denied
>
> Note: The Koji builder has SELinux in permissive mode at the moment.
>
> I am fixing to revert the package update I applied, but before I do I am
> going to attach the list of updates I applied in hope someone sees a
> possible update I can downgrade.

Two things I would try first - updating mock to 1.1.15 and check if the
build (e.g. running ./configure) will work after manual chroot into the
buildroot.


Dan


--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 07:11 AM

cannot build packages after update
 
On 09/27/2011 01:47 AM, Dan HorŠk wrote:
> Two things I would try first - updating mock to 1.1.15 and check if the
> build (e.g. running ./configure) will work after manual chroot into the
> buildroot.

I upgraded mock, and I was able to build a RHEL6 package successfully,
but Fedora 15 and RHEL5 packages still fail in the same way. It's not
making much sense.

The package I am compiling does not use autotools (plain Makefiles), but
I will try manual chrooting and see what happens.

I had to manually build the RPMs on VMs of F15 and RHEL5 for now.
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 07:14 AM

cannot build packages after update
 
On 09/27/2011 02:11 AM, Michael Cronenworth wrote:
> I upgraded mock, and I was able to build a RHEL6 package successfully,
> but Fedora 15 and RHEL5 packages still fail in the same way. It's not
> making much sense.

I should note I also tried downgrading mock to 1.1.10, which is the last
version I had installed that worked fine. Package building still fails
for F15 and RHEL5. It must be one of those python updates I applied,
shouldn't it?

Does the error I see in koji-web have anything to do with this?
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 01:43 PM

cannot build packages after update
 
Dan HorŠk wrote:
> manual chroot into the buildroot.

When I manually inspect the buildroot I can see it is no longer being
built right and depending on the version of mock I see two different
outputs. The "/usr/bin/ld" symbolic link is never being created as the
alternatives directory is not being built correctly.

This is from a Fedora 15 build:

mock 1.1.15
[snip yum install list]
DEBUG util.py:250: Transaction Summary
DEBUG util.py:250:
================================================== ==============================
DEBUG util.py:250: Install 124 Package(s)
DEBUG util.py:250: Total download size: 95 M
DEBUG util.py:250: Installed size: 95 M
DEBUG util.py:250: warning: /etc/hosts created as /etc/hosts.rpmnew
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: admindir /var/lib/alternatives invalid
DEBUG util.py:250: Installed:
[snip installed package list]

mock 1.1.10
[snip yum install list]
DEBUG util.py:250: Transaction Summary
DEBUG util.py:250:
================================================== ==============================
DEBUG util.py:250: Install 124 Package(s)
DEBUG util.py:250: Total download size: 95 M
DEBUG util.py:250: Installed size: 95 M
DEBUG util.py:250: warning: /etc/hosts created as /etc/hosts.rpmnew
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: altdir /etc/alternatives invalid
DEBUG util.py:250: Installed:
[snip installed package list]
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 01:48 PM

cannot build packages after update
 
Michael Cronenworth wrote:
> mock 1.1.10

Note: this is a version of mock that used to build correctly just three
days ago. When it was building correctly it did not emit:

DEBUG util.py:250: altdir /etc/alternatives invalid
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 02:07 PM

cannot build packages after update
 
Michael Cronenworth wrote:
> DEBUG util.py:250: admindir /var/lib/alternatives invalid
> DEBUG util.py:250: altdir /etc/alternatives invalid

From looking at the source code of "alternatives" this error is printed
when the /etc/alternatives (altdir) or /var/lib/alternatives (admindir)
directories don't exist.

When I inspect the buildroots of mock 1.1.15 and 1.1.10 tasks the
directories are both there in each buildroot.

I'm going to start downgrading packages that I upgraded. I see no other
solution.
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-27-2011 02:58 PM

cannot build packages after update
 
Besides the package update I had enabled 64-bit inodes (XFS filesystem).

I believe this is what is causing koji and koji-web to act up, but I
won't be able to go back to 32-bit inodes for about 6 hours.
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys

Michael Cronenworth 09-28-2011 12:03 AM

cannot build packages after update
 
Michael Cronenworth wrote:
> Besides the package update I had enabled 64-bit inodes (XFS filesystem).
>
> I believe this is what is causing koji and koji-web to act up, but I
> won't be able to go back to 32-bit inodes for about 6 hours.

It turns out that 64-bit inodes are the problem.
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys


All times are GMT. The time now is 03:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.