FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora Build System

 
 
LinkBack Thread Tools
 
Old 01-21-2011, 06:53 PM
 
Default New koji install - having issues with mock initial packages

I think that I'm having issues with the initial package list for mock.

New koji install (Thanks Mike, BTW).

I added some packages and groups:

koji add-group-pkg dist-EL5-beatport-build build bash bzip2 coreutils cpio diffutils findutils gawk gcc gcc-c++ grep gzip info make patch redhat-rpm-config centos-release rpm-build sed shadow-utils tar unzip unil-linux-ng which

koji add-group-pkg dist-EL5-beatport-build srpm-build bash buildsys-macros cvs fedpkg gnupg make redhat-release redhat-rpm-config rpm-build

koji add-pkg --owner swebb dist-EL5-beatport bash bzip2 coreutils cpio diffutils findutils gawk gcc gcc-c++ grep gzip info make patch redhat-rpm-config centos-release rpm-build sed shadow-utils tar unzip unil-linux-ng which

... but I think that I'm missing something.

Here's my mock_output.log:

INFO: mock.py version 1.1.6 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.6
INFO: Mock Version: 1.1.6
State Changed: running yum
WARNING: Command failed. See logs for output.
# umount -n /var/lib/mock/dist-EL5-beatport-build-12-847/root/dev/shm --setopt=tsflags=nocontexts
WARNING: Command failed. See logs for output.
# umount -n /var/lib/mock/dist-EL5-beatport-build-12-847/root/dev/pts --setopt=tsflags=nocontexts
WARNING: Command failed. See logs for output.
# umount -n /var/lib/mock/dist-EL5-beatport-build-12-847/root/proc/filesystems --setopt=tsflags=nocontexts
WARNING: Command failed. See logs for output.
# umount -n /var/lib/mock/dist-EL5-beatport-build-12-847/root/sys --setopt=tsflags=nocontexts
WARNING: Command failed. See logs for output.
# umount -n /var/lib/mock/dist-EL5-beatport-build-12-847/root/proc --setopt=tsflags=nocontexts
WARNING: Forcibly unmounting '/var/lib/mock/dist-EL5-beatport-build-12-847/root/dev/shm' from chroot.
WARNING: Forcibly unmounting '/var/lib/mock/dist-EL5-beatport-build-12-847/root/dev/pts' from chroot.
WARNING: Forcibly unmounting '/var/lib/mock/dist-EL5-beatport-build-12-847/root/proc/filesystems' from chroot.
WARNING: Forcibly unmounting '/var/lib/mock/dist-EL5-beatport-build-12-847/root/sys' from chroot.
WARNING: Forcibly unmounting '/var/lib/mock/dist-EL5-beatport-build-12-847/root/proc' from chroot.
ERROR: Command failed:
# /usr/bin/yum --installroot /var/lib/mock/dist-EL5-beatport-build-12-847/root/ groupinstall build --setopt=tsflags=nocontexts
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libgcc_s.so.1(GCC_3.0)(64bit)
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: /bin/sh
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libsqlite3.so.0()(64bit)
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1(ELFUTILS_1.1.1)(64bit)
Error: Package: logrotate-3.7.4-9.el5_5.2.x86_64 (build)
Requires: libselinux.so.1()(64bit)
Error: Package: nss-3.12.8-1.el5.centos.x86_64 (build)
Requires: libz.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: elfutils
Error: Package: 4erl-5.8.8-32.el5_5.2.x86_64 (build)
Requires: libgdbm.so.2()(64bit)
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1(ELFUTILS_1.0)(64bit)
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libselinux.so.1()(64bit)
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libz.so.1()(64bit)
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libsqlite3.so.0()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libsqlite3.so.0()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: gzip
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: gawk
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: unzip
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libselinux.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: /bin/sh
Error: Package: glibc-2.5-49.el5_5.7.x86_64 (build)
Requires: basesystem
Error: Package: logrotate-3.7.4-9.el5_5.2.x86_64 (build)
Requires: /bin/sh
Error: Package: nss-3.12.8-1.el5.centos.x86_64 (build)
Requires: /bin/sh
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: file
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: crontabs
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libz.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: diffutils
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1(ELFUTILS_1.0)(64bit)
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: patch >= 2.5
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libgcc_s.so.1(GCC_3.3.1)(64bit)
Error: Package: nspr-4.8.6-1.el5_5.x86_64 (build)
Requires: /bin/sh
Error: Package: db4-4.3.29-10.el5_5.2.x86_64 (build)
Requires: libgcc_s.so.1(GCC_3.0)(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: binutils
Error: Package: db4-4.3.29-10.el5_5.2.x86_64 (build)
Requires: libstdc++.so.6(GLIBCXX_3.4)(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: grep
Error: Package: db4-4.3.29-10.el5_5.2.x86_64 (build)
Requires: libstdc++.so.6(CXXABI_1.3)(64bit)
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: /bin/bash
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1()(64bit)
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: coreutils
Error: Package: rpm-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libselinux.so.1()(64bit)
Error: Package: bzip2-1.0.3-6.el5_5.x86_64 (build)
Requires: /bin/sh
Error: Package: glibc-2.5-49.el5_5.7.x86_64 (build)
Requires: libgcc
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: sed
Error: Package: db4-4.3.29-10.el5_5.2.x86_64 (build)
Requires: libgcc_s.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libelf.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libz.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: cpio
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: findutils
Error: Package: rpm-libs-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: libgcc_s.so.1()(64bit)
Error: Package: rpm-build-4.4.2.3-20.el5_5.1.x86_64 (build)
Requires: /bin/bash
Error: Package: db4-4.3.29-10.el5_5.2.x86_64 (build)
Requires: libstdc++.so.6()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest



--
Steve Webb | System Administrator
Beatport | Play With Music
------------------------------------------
2399 Blake Street, Suite 170
Denver, Colorado USA 80205
tel: +1.720.932.9103
fax: +1.720.932.9104
noc: +1.303.565.2710
mobile: +1.303.564.4269
--
buildsys mailing list
buildsys@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/buildsys
 

Thread Tools




All times are GMT. The time now is 10:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org