Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   EXT3 Users (http://www.linux-archive.org/ext3-users/)
-   -   badblocks output format question (http://www.linux-archive.org/ext3-users/164034-badblocks-output-format-question.html)

Jelle de Jong 09-22-2008 08:01 AM

badblocks output format question
 
Hello List,

I was testing a harddisk with badblocks, but i cant find what the exact
output means. I have attached my logfile. Is the drive bad or ok :-p.

Reading and comparing: 1556108 done, 339455:18:25 elapsed
3656908 done, 339455:20:00 elapsed
10566092done, 339455:25:11 elapsed

Package: e2fsprogs
Architecture: i386
Version: 1.41.1-3

Best regards,

Jelle

_______________________________________________
Ext3-users mailing list
Ext3-users@redhat.com
https://www.redhat.com/mailman/listinfo/ext3-users

Jelle de Jong 09-22-2008 08:55 PM

badblocks output format question
 
Jelle de Jong wrote:
> Hello List,
>
> I was testing a harddisk with badblocks, but i cant find what the exact
> output means. I have attached my logfile. Is the drive bad or ok :-p.
>
> Reading and comparing: 1556108 done, 339455:18:25 elapsed
> 3656908 done, 339455:20:00 elapsed
> 10566092done, 339455:25:11 elapsed
>
> Package: e2fsprogs
> Architecture: i386
> Version: 1.41.1-3
>
> Best regards,
>
> Jelle
>

Seems the log I sent is of a broken device, i ran badblocks on an other
disk and there were no sector in the output. However the time indicator
is a bid awkward (339455:20:00 elapsed) seems to my like a integer
overflow or initialization bug.

Best regards,

Jelle

_______________________________________________
Ext3-users mailing list
Ext3-users@redhat.com
https://www.redhat.com/mailman/listinfo/ext3-users

Theodore Tso 09-23-2008 05:07 AM

badblocks output format question
 
On Mon, Sep 22, 2008 at 10:01:37AM +0200, Jelle de Jong wrote:
> Hello List,
>
> I was testing a harddisk with badblocks, but i cant find what the exact
> output means. I have attached my logfile. Is the drive bad or ok :-p.

You're drive is fine. This was a bug in the badblocks program which
was introduced in e2fsprogs 1.41.1. This caused the percentage and
elapsed time to be incorrectly displayed when the badblocks options -w
and -s were given.

Thanks for mentioning it. I'll fix it for the next release.

- Ted

_______________________________________________
Ext3-users mailing list
Ext3-users@redhat.com
https://www.redhat.com/mailman/listinfo/ext3-users


All times are GMT. The time now is 06:31 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.